Haiku 64bit on Ryzen


Something goes well except for the video driver my RX580 doesn’t work shows invalid format on the screen.

This is the information from GNU/Linux:

0a:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X] (rev e7) (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd Ellesmere [Radeon RX 470/480/570/570X/580/580X]
Flags: bus master, fast devsel, latency 0, IRQ 87
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=2M]


Seriously, I will take that in account next time I had to build a machine. :+1:


Interesting, I don’t have a RX470-580 anymore to test with but my RX460’s work ok on the KGPE-D16 when disabling half the cores (2 socket bug).


But for the rest work this test is in last hrev 52775 … But i don try to view if my intel wireless 7260 is detected by system. I suppose there is no problem with VESA accelerant only with Radeon Accelerant.


mmmm… Using failsafe driver in the safe mode options loads a Framebuffer driver which can not change screen resolution on the preferences. In network preferences Intel Pro Wireless 7260 disappeared( dev.id: 0x24f3 vendor id.: 0x8086). And the radeon rx580 shows invalid format(dev.id: 0x67df vend. id.: 0x1002).

And the keyboard simply stops working i don’t know what is the exactly problem with the keybaord. It’s on a frontal panel USB3.0 port.


I’m considering buying one of those Asus boards. Have you had any issues besides that?


Have you tried the keyboard in a USB <= 2.0 port if you have any? Since you lost wireless, perhaps you have hardware conflicts. Try moving the GPU to another slot. Swap cards around.


The built in VGA doesn’t work corrently with Haiku at the moment… the one used for remote management.

Other than that I think if you only populate one socket it would be fine… you only get half the ram then though but 128GB is nothing to sneeze at either. I would only recommend it once we get the other socket working…

A Ryzen system is going to be faster in single thread and most stuff though… so once that works it will be a better option. My x370 desktop does work with Haiku although only with 4GB ram limit.


xmy gigabyte works ok without this limit of 4 GB of ram but in contrast the radeon accelerant isn’t working only boot in safe mode graphics driver which uses framebuffer(this can’t change screen resolution in screen preferences). And my intel wireless disappeared from beign to be detected :frowning: but for the rest it boots from usb drive, when the radeon accelerant or radeon hd accelerant work again i wll install the entire system on an ssd of 1 Tb.

And yep my rx580 is not supported no dev id’s in sources :frowning:


i test on another computer and the ryzen driver is broken i test with a radeon rx460 and doesn’t work input not admitted in the aoc monitor :frowning:


@zantak, as @bullfrog pointed out, keyboard/mouse should be on an USB 2.0 port, other than that, I never got keyboard/mouse working with Haiku on a 3.0 usb port, and better don’t use a keyboard switcher. Switching keyboard between two computers locks the Haiku system (already ticketed), needing hard reset.



works well on my case my relevant preocupation is with the radeon drivers which in two different computers/monitors seems to occurs the same case invalid format on the screen or format not admited. :frowning: this is frustrating and the framebuffer driver doesn’t change resolution at all.


You should post a bug report with the PCIE ID’s in it pretty sure the RX480-RX590 should work.


I finally got around to retesting my HP Envy x360 2017, 2500u and 32GB ram works with 64bit + UEFI.

Also note this was booted from USB port on XHCI so thanks for those fixes @waddlesplash !

Vega graphics is broken though so only failsafe works, and also my NICs were not detected.

https://dev.haiku-os.org/ticket/14956 updated with logs and screenshot of crash when booting with integrated graphics instead of failesafe.


From the listdev, I only see a WiFi controller, and we already have a ticket for that. If that’s mistaken and there is also an ethernet controller which is not detected, please file a new ticket for it.


Yeah, my brain just assumed all reasonable computers have Ethernet when I typed that… it doesn’t have Ethernet I’ll probably try my asix usb ethernet on it though.


Seems to be the same to me , on latest hrev, i have the same problems with radeon driver. Only works in framebuffer mode, and it’s not related to the resolution, i think .There is a method to change the resolution parameters for radeon or radeonhd driver? This question is to verify if the problem is for the resolution(1920x1080 seems to be supported for my monitor it’s an LG M2762D).


Screen preferences. For radeonHD driver, there are no current multi-monitor options (although, I can do cloned monitor mode with two monitors - but not stretched. I can do a 1280x1024x32 resolution on one monitor and a 1080p resolution on my HDTV. This is with a Radeon HD 4000-series card with a max display resolution of 2560x1600x32.

NOTE: You mentioned you can’t change resolutions, so is the resolution pull-down menu greyed out preventing this in screen preferences? Have you tested with the boot menu screen resolution preferences?


Yes with boot mode options resolution and no failsafe driver , same result invalid function. Perhaps must be a problem related to EDID on LG FLATRON M2762D?? Or maybe a problem related with driver, i test this on another computer (ryzen 5 1600) and another monitor(this is no Monitor/TV) AOC i don’t remember what model, and the same result :frowning: . Sorry i forgot to mention the computer is connected to monitor/TV with a hdmi cable from the hdmi output of my video card to my hdmi input on my monitor


There is a bug report to support the RX 580 (see bug 14918) .


  1. In screen preferences, do you see your monitor info and graphic card info?
    Example (on left window pane of screen preferences):
  • LG 2762D 27.1"
  • Radeon RX 580 (Polaris20 XT)