Haiku 64bit on Ryzen

Good day everyone!

(this post is valid as of 2018.09.05, new results will be added as they come out)
Today I’ve been carrying out some tests on a Ryzen box, which will be devoted to Haiku only in the next days. This test was carried on Bare Metal, no Virtual Machine. The setup is the following:

MB: MSI B350M Bazooka
Processor: Ryzen 5 2400G 4Core
RAM: 8 GB 2400
HD: 500 GB SSD SATA (no NVMe) using GPT partition table
KVM: Ugreen USB/VGA switch
Keyboard-Mouse: Wireless Microsoft Comfort Desktop 5050 (plugged in the KVM)
Video through VGA out (later will change to HDMI to check audio)

MotherBoard Settings:

  • USB set to compatibility with USB 2.0
  • BIOS set to Legacy/UEFI (not set to UEFI only)
  • Video set to auto, so it picks IGD with auto VRAM
  • Boot mode set to Legacy devices, non UEFI

I tested two, only 64bits Haiku ISOs:
1- @kallisti5 released R1 Beta1 testing image as posted in his thread R1 Beta 1 Testing Image
2- Latest Anyboot ISO hrev52312

None of this ISOs are UEFI ready, AFAIK, so I set the BIOS to legacy mode and legacy usb compatibility.
Both ISOs were tried out of a USB key.

What I can say right now is that Haiku can be installed and ran on a Ryzen computer with these ISOs without the need for UEFI version (I will try the UEFI ISO when available and report).

I was able to install and run Haiku, setting up the SSD with 2 partitions (GPT), one for Haiku, one for Data, with just by setting some Safe Mode options, which I found after unchecking one by one. The safe mode options are:

  • Default VESA video driver

  • Ignore memory over 4 GB

With these two marked, can run Haiku without issues. Network works, monitor resolution works with VESA graphics. Can install any app available… and seems stable, in both cases R1 Beta1 and hrev52312). Have to be careful to remember to mark those every time at boot. I don’t want to blacklist anything yet because I will try other revisions later, so it is not worth it. Being the only difference, the “Welcome” links on the desktop in the Beta, as well as the “About Haiku” window.

(Edited) Most likely, and just thinking about this right now, the issue with the 4GB Ram might be related to the fact that Ryzen 5 2400G has integrated Radeon Vega graphics, and in the BIOS, if I recall correctly, I had the video memory set to auto. 4GB of ram is the maximum RAM that can be assigned to video, so I presume that this is why the 4GB limit. I will try with fixed RAM assigned to video.

(Edited 2018.09.06) - well, the 4GB issue has nothing to do with the VRAM, and besides, today, none of the images are capable of booting the box, no matter what safe mode options are set. Therefore, I will keep testing and posting. For now, installing on Ryzen is more a matter of witchcraft than technology :smile:

I messed things up later by being stupid and installing bootmanager. Before I was running Xubuntu on this box with Haiku inside Virtualbox, which were wiped out while the Haiku install. Therefore, there was Grub2 there. Installing Boot Manager Removed Grub and then Boot Manager did not show any menu and stayed there in the Boot Manager window forever. Will fix that tomorrow.

The only hardware issue I faced, just while testing, was that the KVM switch for USB keyboard/mouse was detected at boot and not recognized when on Haiku’s desktop. So had to plug the keyboard/mouse directly to the box.

A funny issue I saw is that Haiku reported having 8 processors and being it Ryzen 7 (the Ryzen 7 thing I alredy knew will come because I checked some code somewhere I can’t remember now and no Ryzen 5 there).

Other than that, everything seemed fine.

So thanks to the haiku developers for their work. I will keep testing this when I fix the boot thing until UEFI ISOs are available.

Best regards,


4 Cores with SMT make 8 threads, what is the issue?

The Ryzen 7 has 8 cores and 16 threads.

@MrEntropy roiredxsoto’s setup is with Ryzen 5, so what’s with Ryzen 7?

Oh, sorry, I misread the line about it being reported as a Ryzen 7.

But, in case anyone is wondering, those are the core/thread counts for a Ryzen 7.

@korli, the setup is a Ryzen 5. In Xubuntu is reported as a 16 core processor, though is a 4 core/dual thread. I presume Xubuntu is counting the Vega GPU cores as CPU cores, as well as CPU+GPU threads.

The Ryzen 5 is reported to be a Ryzen 7, just because the code I saw (I don’t remember where, maybe in Trac or GitHub) would report any AMD processor other than the old ones as a Ryzen 7. I did not see any Ryzen 3 neither Ryzen 5 strings there. This is not important whatsoever. It’s just a funny issue.

Haiku reporting it as a 8 core processor is also a curious issue. Though could make more sense than the Xubuntu report, 4 cores, 2 threads per core, 8 virtual processors, not 16. No matter what, none of both are taking into account the Vega cores (11 gpu cores on this APU).

What is puzzling is that one day I could install Haiku with the Safe Options stated in the previous post, and the next day there was now way to get the USB key booting, regardless the safe options.

To build the USB key I always use Etcher, be it on Xubuntu as well as on Windows. So I just presume some witchcraft is involved. Then again, the day it worked there was a big storm nearby, the next day, sunny. Maybe Haiku is being affected by climate change. You never know :smile:


The Ryzen self-reports as 8 cores.
“model name : AMD Ryzen 7 1800X Eight-Core Processor” per /proc/cpuinfo on linux. We’re likely just reading that name and returning it as the cpu. Check the number of cores in process controller, it should be 16?

EDIT Yup. We parse out “Eight-Core” from the self-reported name: :slight_smile:

1 Like

Yeah but He’s said he has a Raven Ridge Ryzen 5 G series APU… those should never report 8 full cores there. As they only have a single CCX 4cores/8threads + Vega GPU instead of the second CCX as is on Summit Ridge.

I just testd by desktop Summit Ridge 1700x and it boots up fine with the 4GB limited enabled, however my Vega FE seems to cause a crash if I leave the radeon_hd accelerant enabled. I attached a screenshot of the crash to the relevant ticket here https://dev.haiku-os.org/ticket/13846#comment:9

Also process controller doesn’t seem to handle 16 cores correctly… it’s icon in the deskbar gets corrupted looking though it works normally otherwise.

My HP x360 w/ Ryzen 2500U (Raven Ridge) doesn’t get past the bootsplash’s initial paint… none of the icons light up. No matter what things I disable also no on screen debug output shows up. I have 32GB installed it’s a bit of a pain but I’ll see if I can test with only 4GB installed next weekend.

Just to reiterate Ryzen 3/5/7 is not enough to tell you the core count. You need to know the series also.

Currently the CPU suffixes are U, G , X and no suffix. U (low power mobile APU) and G (desktop APU) so far are all Raven Ridge a single 2-4core CCX + GPU. There is talk of an H series high power APU but it hasn’t showed up yet.

X and no suffix are the desktop parts Summit and Pinnacle Ridge the X denotes extra boost via XFR. Which are 2 CPU CCXs (Core complexes) on a single die.

There is also Threadripper as well which is 2 desktop dies up to 4 dies on Threadripper 2 wired together on a single package with 4 memory channels and 64 pcie lanes. EPYC is 4 dies with up to 32 cores the main difference from threadripper is 8 channel memory and 128 pcie lanes. EPYC has a very similar pinout but doesn’t seem to work in threadripper motherboards, the motherboards for it are also generally very high end server boards as they have to support all that massive amount of IO.

Ryzen E series have recently been announced that have lower clocks and much lower power use these are desktop parts. Also I forgot to mention there is also Ryzen GE sereis which is roughly the same as the G series. As well as V series which has partnumbers like V1000 etc… these are embedded versions for the raven ridge core.

1 Like


Maybe need some updating :wink: This is not that important whatsoever. I really don’t mind so much if the processor is reported as being a Ryzen 5, or 7 or 3, as long as I can use it :smile:
This sys info is what xubuntu 16.04 LTS reports. So most likely I understand they updated the code to “identify” the processor name and model.
Don’t worry about this. Is just some funny thing.


Good day everyone,

More news on Haiku on Ryzen. This morning I did some more tests and the results are the following:


Previous picture shows Haiku boot log after a failed boot showing a Ryzen 5 2400G with Vega graphics. That is a good thing.


Previous picture shows “About Haiku” showing a Ryzen 7, and also the Haiku Installer ready to install the OS, after booting with all Safe Options ON.
Actually, I downloaded the last nightly (anyboot no-efi) but if you check the “About Haiku” it shows this is the Beta. I presume that this is because I have been using the same USB key for trying to install different versions of Haiku, and Etcher does, well… witchcraft?

Today I could install again the R1 Beta1 (pre-Release for testing only - apologies @extrowerk) , and I tried to grab the boot log onto an USB Key, FAT32 formatted, in order to provide some more insight to the developers, but no success.

Moreover, after installing Haiku, and the installer writing the Boot Record nothing happened. I could not boot the box. And booting out of the USB key only recognized the Haiku on the USB, not the hard drives, and back to the KDL again and again no matter which safe options.

So, I presume I need to format-wipe the USB key, write something, delete it, so the data location is written on so no remains are kept.

Will keep you posted.


There is no Beta, yet, just tesimages built with beta profile.

You can boot on Ryzen with all safe mode options enabled? Hmm … @kallisti5 may want to know that.

Good day,

I can boot Haiku Beta Image pre release released by @kallisti5, and I can install Haiku and boot from the hard drive. I did it once, and I broke it.

Actually, I am trying that once every week when I have some spare time at work. I tried with the rolling release (different ‘hrevs’) without success, only succeeded with the pre-release. And not just with all safe mode options enabled, I brought it down to 2: no memory above 4 GB and safe video mode. I used GPT partitioning, did not use the Intel partitioning table.

Problem is, that since that day, I haven’t been able to replicate the same behaviour until this Wednesday morning, when I took the images shown in the previous post. So I presume that after I broke the first successful install, I did more testing which rendered everything unusable (mbr, partition tables, etc. ), so as Vizzini said “when something goes wrong, go back to the beginning” (Iñigo Montoya - The Princess Bride), I reset the box config and leave it as it was before the success, that is Ubuntu installed, up and running with BIOS set to legacy (no UEFI), the wireless keyboard plugged to the box (Haiku does not like this KVM switch model just yet - the one at home works without issues, though is just a KM switch), and Video set to Auto, though I found it does not affect setting fixed VRAM to the safe mode option of “don’t use memory above 4 GB”.

Tomorrow I plan to get a couple of small “clean” usb keys, one for the beta pre release, and another for the boot log, the later just in case it can be recognized by the boot manager so I can save the boot log (no success on this yet).

As I am no developer, I don’t know what to search for in the boot log in order to provide that info to @kallisti5, that’s the reason to try to get the boot log, and, in case I am able to succeed in the next try, I will get the Syslog too. Knowing what to search for would help to, at least, take a picture of the boot log page.

When I got Haiku to boot this Wednesday morning I saw the Syslog file, in the USB key system, unreadable, but I presume that file has nothing to do with the “real” Syslog. But as I opened the file nothing there, empty, clean, nada. So no point in doing anything with it.

The funny behaviour is that I can get Haiku beta testing pre release to boot and install. Once. If I try again, it fails, jumping to KDL everytime. With the rolling, always KDL no matter what.

I’ll keep testing and reporting.


Good day,


Here have Haiku preBeta running (BIOS-legacy) on Ryzen 5 2400G, with safe mode (no memory above 4GB, and safe video driver) on…

Haiku sees the 7116 MiB but shows 4596 inaccessible because safe mode settings, though without the safe mode memory setting unset boot jumps to KDL.

Working (with issues).
(Edit 20180919)
Unplugging some USB devices locks the system, either jumping to KDL (i.e.: wacom tablet, USB keys sometimes) or just a lock.
KVM now works, after I plug it into the USB 2.0 port of the Mobo, so no need to plug the Transceiver directly to the box, (UPDATED 20180922: but switching to the other pc makes Haiku lock needing hard reset|<nope|) What happens is that the USB gets a lock, and even plugging the keyboard directly to the box does not do anything, can’t use keyboard nor mouse; but, and this is the important thing, pressing the power button on the box shuts down Haiku normally, which, I presume, means the issue is just related to USB.
Regarding this, if I boot Haiku with the KVM set to the work PC, and wait until Haiku is on the desktop, then switch the KVM to Haiku, it works. It’s when I change back to the work PC when Haiku goes nuts with the USB the moment I switch back to Haiku.

In order to avoid jumping into Boot manager to set safe mode options every time I boot, I modified /boot/home/config/settings/kernel/driver/kernel file uncommenting the safe mode options (4GB limit, and VESA). This I did as there are no haiku core updates in the beta branch. When some system updates come will boot to boot manager to test again:


The fact that can’t switch (yet) from the work pc to Haiku back and forth makes testing harder, as need to (re)boot everytime.

I have already opened tickets with the log files in TRAC.

Other than that, yesterday I started to set the porting environment (with goals for Godot Engine, Musescore and Octave/w/Gui) as Haiku seems quite stable. VESA driver is not a big deal, though. The 4GB limit might be, but not for now.

NOTE: If you read this post, check the first one of this topic to find out which hardware Haiku 64b is installed on



hrev52357 may fix MBR booting on Ryzen without the 4GB memory limit; but I don’t have a Ryzen system so I can’t test.

I’ll test that out as soon as I can download it :slight_smile:

No dice on my 1700x with 16GB installed. Still had to disable 4GB or it wouldn’t boot I deleted the UEFI partition off my USB drive and rewrite the bootsector from the installer.

I was able to boot by enabling the 4GB limit, disabling the radeon_hd accelerant (crashes during boot with Vega FE), and enabling failsafe video output (don’t think I had to do this before but it kept saying it couldn’t initialize the video output over and over… basically hung) it was either that or setting the video mode to 1366x768 32bit… not sure.

Will test on Ryzen 2500u shortly

Also planning on testing on some old Transmeta hardware for kicks.

Good day,

I won’t be able to test on Ryzen until Tuesday 25th. As @cb88 reported can boot from USB key, with safe mode options, I presume it should work.

I will change the repo, from beta branch to rolling/master branch, do the pkgman sync and then update the whole thing. If reboots fine without touching the safe mode options in boot/…/kernel, we are good to go on the rolling. The worst thing that can happen is that box boots to KDL no matter what, then, back to the beginning with hrev52295, and a week delay.

(Edit:: 20180925)
Today I changed branch from beta to rolling/master on the Ryzen box in the repos, without touching the boot config, that is, keeping 4GB limit and the Vesa failsafe options set to TRUE.

Without the 4GB limit Haiku does not boot. It does not even light up the module loading indicator AKA the atom.

Ryzen box updated without issues, and rebooted without issues too. That means, Standard Nightlies work on Ryzen, with MBR boot and GPT partition tables.

Maybe this is due to what has been done in ticket #13370 in Track.

Other than that, still have the issue with plug/unplug keyboard/mouse. When plugging, it works (KVM set to Haiku), after unplug (KVM set to work PC) and re-plug (KVM set to Haiku again), keyboard/mouse don’t work, but system is not locked. It’s like the USB stack went out on holidays. So maybe we need a different ticket for the USB thing, different than the #13370.

Anyway, there has been a lot of improvement since the first day I tried to install Haiku on this box. So, then again, big thanks to the development team!.

Will keep testing and reporting.

hI can’t boot on my ryzen 5 1600 with ASUS TUF B350M-PLUS Gaming motherboard. No atom icon in red :frowning: Sadly this is with hrev52357 x86 and x86_64. With limit for 4 GB option doesn’t boot either using limit for 4 GB and using VESA driver. :frowning:


  • amd ryzen 5 1600
  • asus tuf b35m-plus gaming
  • 32 gb RAM (2400 MHz)
  • Aorus (Gigabyte) AMD Radeon RX 580
  • NVMe for windows one ssd for linux and one (if i can boot for haiku)

@zantak Did you enable on screen debugging and disable paging? Where did it stop?