Haiku 64bit on Ryzen


#21

nope :frowning:
this is in the menu disable io-apic?
in the atom phase


#22

Good day,

@zantak, have you tried with the pre-beta? hrev52295, the one pointed out in the first post baked by @kallisti5?

I was successful with that one installing on my ryzen. I presume you don’t need the safe video because at home I have a RX560 and Haiku deals with it quite ok.

I started with the pre-beta, and it finally worked with those two options Ram limit and Vesa. Today I updated the branch from beta to rolling/master and now hrev52358 works fine with the Ram limit and Vesa too.

No matter what, first run I did was boot Haiku from usb with all safe mode options ON. That way I was able to install Haiku, then rule out the good ones, and ended up with those 2 (Ram+Vesa). As you have a CPU+GPU instead of an APU, situation might be different. Can try that and see if it works (all safe mode options ON).

Regards,
RR


#23

Good day,

@waddlesplash, nope. The memory limit is still needed in the hrev52358, at least in here.

Thanks,
RR


#24

At least nothing works for me, activating all of safe mode options doesn’t boot haiku. What happens ?? :frowning:


#25

Good day,

@zantak, I did not pay attention last time. You have already a multiboot box. If you have EFI, most likely, enabled boot for Windows, and also Linux running on EFI mode, then you should try the UEFI bootable image.
What I have used is the plain Anyboot ISO, which boots in MBR mode as this box is 100% Haiku only, so no need to worry about UEFI in my case.
Probably it will work with the UEFI image and you can boot your box though it needs some fiddling as pointed out in the UEFI topic. I have tried an old UEFI iso which never worked for me, maybe because the process I followed wasn’t the right one.

Whatsoever, @kallisti5 reported that the new R1Beta1 release may or may not work on some devices, Ryzen included, so it is a matter of patience and trial/error. You should be aware, at least in my case, to have the keyboard/mouse plugged into a USB 2.0 port, even if you set your BIOS for usb compatibility… At least in my case is needed.

After I got Haiku installed (hrev52295) I haven’t tried to boot with other revs, be them nightly nor beta. Just changed the branch from beta to rolling/master, and the box keeps working fine with the VESA driver, and the memory limit.

In your case, I would try the UEFI ISO following the recommendations stated in


or newer images if available. And remember to turn off Secure Boot, and all the BIOS stuff.

Regards,
RR


#26

Just an FYI my AM4 board has onboard PS/2 (apparently its a “gaming” feature for people concerned with USB latency) so I can work in the KDL without USB issues.

Fatal1ty X370 Gaming-ITX/ac


#27

Good day,

I will keep this box running on rolling, right now on hrev52379. At this stage, the memory limit is still needed. I just tried right now and there is no way to get passed that, at least in my case.

So as of today, and after a couple of weeks, Haiku is quite stable on this box, taking into account the following:
1- Need the memory limit set to 4GB in order to boot (I’ve already added the Syslog’s to a ticket)
2- Need the VESA graphic driver
3- Unplugging the keyboard/mouse and plugging it again renders the keyboard/mouse useless (I’ve already filed a ticket)
4- There is no sound through HDMI (also no sound through DisplayPort on my home Box, but that is an old A8) maybe related to using the VESA driver?
5- BeCJK does not let me type chinese. Sometimes it looks it works, then it does not. 现在可以,以后不知道. Now it did.
6- Extra keys on the keyboard are useless.

Other than that, everything seems fine. I will keep checking and posting any improvements on Ryzen 5 2400G, and remember this box is running on Anyboot non-UEFI, MBR boot with GPT partition table.

Regards,
RR


#28

at least this is impossible on ASUS Mainboards


#29

Generally if there is no key set then secure boot is off… not being able to turn of secure boot would cause quite a stir among many.


#30

I suspect which the bug is in the memory managment on the boot manager. ArcaOS has this sane bug with the error “Not enough memory” while booting (no kernel loaded).

The message from the arcaos cd boot manager is

Detecting extended memory size … using INT 15 EAX=E820 ‘SMAP’
63 MB starting at 1 MB
Not enough memory

Maybe it does help it does not :disappointed:


#31

this is impossible on ASUS Mainboards

Since when? I have an ASUS laptop and the option to turn off Secure Boot remains available, despite it shipping as a Windows 10 device OOTB. The same goes for my ASUS desktop motherboard; then again, it was from the Windows 8 era where it was mandatory for x86 PCs.


#32

When the impossible is possible…


#33

I confirm that I was, in fact, playing with Haiku in my ASUS laptop where i was able to disable Secure Boot.

The procedure is a pita, whereas you set a string of N characters (in Linux, iirc) and the after reboot a “bios” procedure asks you about the Nth character of the string to confirm that you wanted to disable it.

Then you tweak stuff in the BIOS itself yada yada yada, and you end with a non secure boot mode, and a label “Booting in insecure mode” in the top left part of the screen, but works as intended.


#34

There isnt a laptop is a desktop. Obviously my comment suggests a fail related to boot manager and memory management.


#35

The option in the BIOS clear secure boot keys… will disable secure boot and enable you to select Other OS boot option. If you want to use secure boot later you can renable it by doing install default secure boot keys.


#36

2500u boots a little further on the 64bit EFI anyboot hrev52418, previously it hung at the bootloader… USB3 fails though as it doesn’t have a USB2 port. I may get further by shrinking one of my partitions a bit and installing Haiku to the internal drive.

I used etcher on windows to write the anyboot to the drive first time I’ve tried it actually… quite easy to use and seems to have worked correctly I think.

Ryzen 1700x on x370 hangs at desktop with just the cursor… On the same us drive.

Booting from EFI with smap disabled and failsafe video

Note I get the same crash disabling smap/4gb/failsafe from non uefi also.


#37

That crash is usually the result of I/O transfers failing in a way our kernel does not expect, usually XHCI’s fault. Check the last page of the output of the “syslog” command at that prompt.


#38

Yeah looks like it… I happened to have a ps2 keyboard handly…as my USB one was dead.


#39

My new gigabyte motherboard boots in hrev52420 without problems using the 4GB limit in USB3.1 port and USB2.0 port in the “new” card reader. But has some problems with radeon rx580 white screen with no desktop , and a kernel panic related to net_server. I put this message using the haiku booted on my usb, but with vesa instead of radeon driver. with radeon driver net_server gets a panic and KDL Screen , when net_server is disable only white screen seems like a problem with the radeon driver and net_server


#40

Known issue with radeon driver but go ahead and file a bug report with your computer build info and an attached copy of your syslog info. Also, see tickets 13370, 12885.