Wi-Fi & Ethernet Testers Wanted


#61

#62

yes, I had problems with it even in Ubuntu


#63

Oh please, yes! USB wireless!


#64

Great!

I have the following USB adapters:
0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
7392:a611 Edimax Technology Co., Ltd EW-7611ULB 2-in-1 N150 Wi-Fi & Bluetooth 4.0
2001:3318 D-Link Corp. DWA-172


#65

Well, this is an issue of net_server which sometimes doesn’t bring up ethernet interface.


#66

hello waddlesplash…
I have a Broadcom "BCM 4401-B0 ethernet device…
Device: 170c
it is not recognized at all!
Is there any hope?
Anyway WIFI is working very well now (iprowifi3945) it even did auto connect before hrev 52124…
so just like to know…
thanks very good work with the wifi part so far… happy! Thanks a lot Waddlesplash…


#67

Hi,

I have a Kodlix N42-D and was able to boot into Haiku by setting the boot mode to Legacy, enabling CSM (I think those are the correct three letters), and setting all the things under that option to Legacy.

It’s a Pentium N4200 system with the Apollo Lake chipset.
The Wi-Fi device is:
device Network controller [2|80|0]
vendor 8086: Intel Corporation
device 3165: Wireless 3165
Which, I believe, should be covered by the iwm driver.

Ethernet is:
device Network controller (Ethernet controller) [2|0|0]
vendor 10ec: Realtek Semiconductor Co., Ltd.
device 8168: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
That should be covered (I think) by the re driver.

However, using:
Haiku shredder 1 hrev52124 Jul 19 2018 21:03:54 x86_64 x86_64 Haiku
neither device shows up.

Am I wrong about this? If not, does anyone have any recommendations for getting either of them to work?

Thanks!


#68

Yes, those both should work I believe. Please post a syslog somewhere and I’ll take a look.


#69

rtl8139 ethernet works on rev52130 on 32-bit.

~> listimage | grep dev/net

1204 0x81c20000 0x81c3c000 0 0 /boot/system/add-ons/kernel/drivers
/dev/net/rtl8139
TEAM 771 (/bin/grep --color=auto dev/net):

~> uname -a
Haiku shredder 1 hrev52130 Jul 22 2018 21:07:53 BePC x86 Haiku


#70

iprowifi3945 wifi 32-bit rev52130

~> listimage
1177 0x81c5b000 0x81cca000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/iprowifi3945
1273 0x81e9b000 0x81eb7000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/broadcom440x
TEAM 901 (/bin/grep --color=auto dev/net)

~> uname -a
Haiku shredder 1 hrev52130 Jul 22 2018 21:07:53 BePC x86 Haiku

Seems to work sometimes, but disconnects and reconfigures quite a bit. However, this was after a restart. Starting up the system after install of Haiku and wifi started to work, but then stopped and had to restart.

Ping stats:
— 8.8.8.8 ping statistics —
35 packets transmitted, 35 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 43.673/53.957/90.708/14.306 ms

I tried doing the Internet Speed Test on Google on the computer, but got a error: “The test can’t be completed due to a problem with the network.” However, I’m able to go to websites.
This computer is far-ish away from the modem, so I’ll try using it closer up to see if it’s a signal strength issue (I’m not sure though, because other websites load pretty quickly).
Edit: It also failed to get updates from SoftwareUpdater.
Edit2: Doing it a second time, and it seems to be working so far… got disconnect and reconfigure notifications again, but the updater hasn’t errored out yet, so we’ll see… Been sitting there for a while with 0 bar movement (on software updater) and it’s disconnected and reconnected twice now.

Note: this is a different computer from the one in which I tested the rtl8139 ethernet.


#71

Disable HT. Check the user guide wlan section.


#72

Thanks. It seemed to be working at first, however, eventually I got the disconnect and reconnect issue once again. It also seems that after reconnecting, I can view websites and ping ip addresses, but the HaikuDepot and SoftwareUpdate just stop downloading.


#73

I also have the BCM4312 NIC in my Dell Inspiron (14e4:4315). Would like to get it going in Haiku. waddlesplash, if you need someone to test an implementation of it, I could do so and report back.


#74

I have the same NIC in a netbook, and here’s the answer:


It would certainly be great if @waddlesplash could connect remotely to that netbook and tinker with the hardware, but I’m not sure it’s even possible in this case.


#75

Yes, I saw that comment about the firmware - which is why I’m saying, if he wants to compile it, and perhaps try to commit it to the source for a new nightly build, I could test it that way. …There is a way to withdraw/delete commits if they don’t work or aren’t used anymore, isn’t there?


#76

I’m not sure you understand. It’s not just “add some files to the repository, get them to compile, and ask you to test.” Even for PCI-only devices like the idualwifi7260 driver I added, it took about two dozen attempts tweaking firmware, versions, interrupts glue, timings, etc. for the driver to actually initialize the hardware, and then there were still some crashes I had to fix before it fully worked. AFAICT, those Broadcom chips are PCI + a proprietary Broadcom interconnect bus, so I’d have to add another bus system to the FreeBSD layer. It’s not something that I could really do without access to the hardware.


#77
   ~> listimage | grep dev/net
   1389 0xffffffff81128000 0xffffffff8114e000     0          0  /boot/system/addons/kernel/drivers/dev/net/rtl81xx
  1731 0xffffffff81d45000 0xffffffff81dc8000     0          0  /boot/system/addons/kernel/drivers/dev/net/iprowifi4965
 TEAM 8565 (/bin/grep --color=auto dev/net):
  ~> uname -a

   Haiku shredder 1 hrev52165 Aug  3 2018 11:05:00 x86_64 x86_64 Haiku
   ~> listdev | grep Network
   device Network controller (Ethernet controller) [2|0|0]
  device Network controller [2|80|0]
   ~> listdev | grep Wireless
    device 0896: Centrino Wireless-N 130

Status: It appears on the Freebsd’s list (and works there as I tested) and Works in the last Nightlies.


#78

Hello everyone,

this BM is:
~> uname -a
Haiku shredder 1 hrev52177 Aug 6 2018 12:23:45 x86_64 x86_64 Haiku

and network is:
~> listimage | grep dev/net
1273 0xffffffff8032b000 0xffffffff80351000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/rtl81xx
TEAM 11673 (/bin/grep --color=auto dev/net):

Network works “mostly fine”, that is, DHCP does not work, have to use static IP. I can feel the web browsing speed (web+, qupzilla) is much slower compared to firefox on the linuxos (BM to BM comparison on the same BM). And I can’t get network preferences to keep more than 3 server IP in the DNS settings list to improve routing. I have a particular network setup.

Thanks for your dedication.
Regards,
RR


#79

hmm… I supose is the same valid for BCM 4311?

Tried one of the latest nightlies over the weekend and can’t get WiFi to work on my old faithfull netbook.


#80

No, because B43 depends on restricted firmware that means it needs too much work to implement it and that doesn’t imply your wi-fi will work. Perhaps you should try some gnu/linux where that driver is supported on the restricted repos.