Wi-Fi & Ethernet Testers Wanted


#1

Please read this entire post before replying, as it contains important information and caveats. Thanks.

So. Thanks to the tireless work of korli on the ethernet side, and the less-sleep-than-usual work of myself on the WiFi side, as of hrev52040 Haiku has a fully-updated network driver compatibility layer for FreeBSD 11.1.

In ensuring a smooth upgrade that does not block the beta release, I’d like testers to verify all new / updated drivers before I merge them. So, there are three general categories of chipsets here:

  1. Chipsets that already work with Haiku. If you are in this category, excellent! Please comment below with the device ID of your chipset, the driver you presently use, and what architecture of Haiku you run.
    1. How to get this information: Reply with a copy of your syslog and the output of these commands:
      listimage | grep dev/net
      uname -a
    2. Notes. Before replying, check the below lists to see if your driver has already been upgraded and tested.
      • If it says OK, then it has already been tested, and you don’t need to comment here. :slight_smile:
      • If it says untested, then test with hrev52040 or higher to see if it works, and report back with that information; no need to attach those files.
      • If it says not upgraded, then do comment with those files and I (or someone else) will make a driver for you to test with.
  2. Chipsets that do not work with Haiku but are covered by an 11.1 driver we have. This category is a little tricky. In order to determine if your driver is covered, try following these steps:
    1. Figure out what the name of your chipset is. Try running:
      listdev | grep Network
      listdev | grep Wireless.
    2. Run a Google search with the name of the chipset, like so:
      site:freebsd.org Vendor-name Device-name XXXX
    3. See if a manual page is returned. For instance, this manpage tells me that the iwn driver supports the chipset Intel Centrino Wireless-N 1030.
    4. See if this driver is in one of the lists below. If it is, then congratulations, you are in this category.
      • See 1.2 (“Notes”) above, and determine what the Status? column says about this driver, and proceed according to the instructions there.
  3. Chipsets that do not work with Haiku and are covered by a 11.1 driver we do not have. This category is much like #2, but due to the tricky nature of porting new drivers (firmware…), I’ll be prioritizing drivers covered under #1 and #2 before I try these. (If you know how to code and want to attempt this on your own, see me on IRC for guidance; I’m happy to help!)
    • If you’d like, you can do steps 1-3 of #2 above to determine what driver (if any) you are covered by. If nothing turns up, then it’s possible FreeBSD just doesn’t have a driver for you, in which case I can’t do anything. Sorry. :frowning:
    • As a special case: USB-based ethernet and WiFi chipsets will not be supported at all, even if FreeBSD has a driver for them. Sorry. :cry:

The Lists

Ethernet drivers (list initially copied from this ticket)

Name FreeBSD Name Version Status?
3com xl 11.1 Untested
ar81xx ale 11.1 Untested
atheros813x alc 11.1 OK (korli)
attansic_l1 age 11.1 Untested
attansic_l2 ae 11.1 Untested
broadcom440x bfe 11.1 Untested
broadcom570x bge 11.1 OK (BlueSky)
dec21xxx dc/de 11.1 Untested
ipro100 fxp 11.1 OK (korli)
ipro1000 e1000 11.1 OK (korli)
jmicron2x0 jme 11.1 Untested
marvell_yukon msk 11.1 OK (BeDifferent1)
nforce nfe 11.1 Untested
pcnet le/pcn 11.1 OK (korli)
rdc vte 11.1 Untested
rtl8139 rl 11.1 OK (krixano)
rtl81xx re 11.1 OK (korli)
syskonnect sk 11.1 Untested
via_rhine vr 11.1 Untested
vt612x vge 11.1 Untested

Wi-Fi drivers

Name FreeBSD Name Status?
aironetwifi an Untested
atheroswifi ath OK (return0e, KapiX)
broadcom43xx bwi Untested
iprowifi2100 ipw Untested
iprowifi2200 iwi OK (ttcoder)
iprowifi3945 wpi mixed (K.O. cocobean / partial ttcoder)
iprowifi4965 iwn OK (waddlesplash)
idualwifi7260 iwm OK (waddlesplash)
marvell88w8335 malo Untested
marvell88w8363 mwl Untested
ralinkwifi ral Untested
wavelanwifi wi Untested

How to fail at installing Haiku
Problem with "install-wifi-firmwares.sh" in Haiku
#2

If I (or another trusted developer) gives you a new driver binary to test (i.e. one that is not in master yet), here are the…

Testing instructions

  1. Download the new driver and verify it against the posted SHA256sum.
  2. Blacklist the old driver. (If you’re unfamiliar with blacklisting files, see this page for an introduction.) In general, this will mean creating a file /system/settings/packages/ with contents like this:
Package haiku {
	EntryBlacklist {
		add-ons/kernel/drivers/bin/drivername0123
		add-ons/kernel/drivers/dev/net/drivername0123
	}
}

… where drivername0123 should of course be replaced with whatever the driver’s name is.

  1. Check if there is already a driver with this name in /system/non-packaged/add-ons/kernel/drivers/bin. If there is, delete it before the next step.
  2. Reboot, so the package blacklist will take effect.
  3. Copy the new driver to /system/non-packaged/add-ons/kernel/drivers/bin.
    • If this directory doesn’t exist, create it first, using mkdir -p ... which will make the whole path for you.
  4. Try to use the driver, and report back with whether it works or not. If it doesn’t, be sure to attach your syslog so we can see what the issue is.

#3

Maybe you want to update the instructions regarding uname to “uname -a” or “uname -v” because uname with no parameter just outputs “Haiku” which is great in itself but not very useful in this case I guess :wink:

Anyway, great work, thanks a lot. I’ll be back with my testing info soon.


#4

#5

Tested with hrev52051 x86_64 with rtl81xx ethernet driver on a 60 Mbps uplink:
Performance: Download: 61.2 Mbps, Upload: 60.0 Mbps, Ping: 2 msec

Result: WORKING - Very good performance on the test network and within similar network performance seen on my test Windows desktop (i.e. 62.52 Mbps (d) / 62.03 Mbps (up) / Ping: 2 msec). Some networking stack overhead.causes minor performance degradation in download speed performance during consistent usage with this driver - but not a major issue at this time.

Tested with hrev52044 x86_gcc2 with iprowifi3945 WLAN driver on a 60 Mbps uplink:
Performance: Still Pending…

Result: NOT WORKING YET - My laptop usually produced a recoverable KDL event during boot with the previous driver or during join attempts to my wireless network. The new iprowifi3945 driver crashes during boot - but not during join attempts.


#6

| atheroswifi | ath | Not Upgraded

Wireless is Atheros AR9485

Laptop is a Samsung NP305V5A


#7

Somehow after iprowifi4965 update my machine is unable to connect to the wireless network (and looks like it can’t even scan the available ones). I’m using Intel Centrino Advanced-N 6205. Can’t attach the syslog at the moment, but I tried multiple times with both -ht switch and without it, still couldn’t get it to work. :sweat_smile:


#8

Thanks; merged in hrev52043. (I tweaked the glue code slightly vs. the version I gave you to test; so please delete your non-packaged version and make sure that one still works.)

OK, I’ll have a look.

Yes, I merged the driver slightly incorrectly and so it was broken on 5000 models and up. Also fixed in hrev52043, so please try again.


#9

listimage | grep /dev/net:
1429 0xffffffff801d8000 0xffffffff802b3000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/atheroswifi
1519 0xffffffff81a94000 0xffffffff81abf000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/broadcom570x

uname -a:
Haiku skunk-haiku 1 hrev52042 Jun 28 2018 08:06:37 x86_64 x86_64 Haiku

I would like to test the new atheroswifi driver. Will test broadcom570x ethernet tomorrow.


#10

MacBookPro (mid2014, 11.3)

Ethernet
broadcom 570x, hrev52052 x86_64, worked before (hrev52031), continues to work. Good.

Wireless
device 43a0, vendor 14e4, BCM4360 802.11ac - never worked on Haiku, not supported natively according to freebsd mailing list, but Linux STA driver available (https://bazaar.launchpad.net/~broadcom-sta-hackers/broadcom-sta/bcmwl/files)


#11

Yeah, I won’t be able to help with that then, sorry. :frowning:


#12

After an additional search, the FreeBSD code base has a few hits for BCM4360

So who knows …


#13

Ah, it looks like it is one of the BCM ones that their driver supports now. I had a look at what porting those would entail, and it looks like it needs a whole new bus manager… I’m probably going to defer those to last, if I get around to it at all :confused:


#14

The latest nightlies are hrev52039 for x86 GCC 2 Hybrid and hrev52031 for x86_64. How do we get the latest drivers for testing?


#15

The update packages for those architectures should be newer. But I also know that @kallisti5 is in the process of transitioning us to a new buildbot, which may explain why those are old.


#16

If updating the installed OS is the way to test the new drivers, then it is assumed that we already have functional networking to perform the update. With Debian-based distros I can run the same version on two different PCs, and I copy the package manager’s cache to other PCs to update offline. Is this possible with Haiku?


#17

It is. But ethernet drivers should be working fine; or do you not have access to an eithernet port?

If you want to do an offline update, download the contents of the current repository for your architecture (it will either be x86_gcc2 or x86_64), and then copy these files into /system/packages/, delete the /system/packages/administrative directory, and reboot.


#18

I’m new to Haiku+pkgman, so I had to search how to update Haiku. I’ll see how things go and… I’m still bummed my 5-6 USB network adapters won’t work. :stuck_out_tongue:


#19

Yes, nobody’s done the work to wrap FreeBSD’s USB KPIs with our own. Patches wanted… or I might take a look myself after beta1.


#20

I can report that ‘vendor 1814: Ralink corp. device 0781: RT2790 Wireless 802.11n 1T/2R PCIe’ is not working in hrev52044, see ticket #11013. Tested on an Asus Eee PC 901.