Wi-Fi & Ethernet Testers Wanted


#41

I’m not sure what’s going on, then :confused: Right now I’m focusing on getting the ath driver working on chipsets it already is; and then after that I’ll look into these.


#42

Tested the atheroswifi driver with Atheros (AR928X) on Haiku x86_64 (hrev52092) and can confirm that it works fine. Here’s the syslog of the wifi driver connecting to the router and below is my machine and wifi card information.

/var/log> listimage | grep dev/net
1418 0xffffffff814aa000 0xffffffff814d0000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/rtl81xx
1700 0xffffffff805d8000 0xffffffff806b3000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/atheroswifi
TEAM 824 (/bin/grep --color=auto dev/net):

/var/log> uname -ar
Haiku shredder 1 hrev52092 Jul 10 2018 23:09:01 x86_64 x86_64 Haiku

/var/log> listdev | grep Network
device Network controller (Ethernet controller) [2|0|0]
device Network controller [2|80|0]
device 002a: AR928X Wireless Network Adapter (PCI-Express)

I’ve also tested an Atheros (AR9485) wifi card and it is shown in listdev, but the driver doesn’t recognise the wifi card. It is definitely included in the FreeBSD 11.1-RELEASE sources, so it might be worth having a look to get it recognised by Haiku’s atheroswifi driver.

@waddlesplash Thanks for your work on updating the wifi driver compat layer to FreeBSD 11.1.


#43

OK, the new Atheros driver was merged in hrev52093.

@BlueSky, your issues should be solved.

@vvill, @starsseed, I’m not quite sure what your issues are, but they might be related to #6423. Maybe try the workarounds in that ticket after updating.


Atheros AR2413/14
#44

Thanks waddlesplash. I upgraded to hrev52094 and the atheros driver works. I will do some tests with the signal strength which, with the previous driver, was not as good as under Linux on the same machine.
One minor annoying problem remains: The wifi connection most of the time does not auto-connect at startup, only on rare occasions it does. Is that a known bug/limitation in Haiku or is that driver related?


#45

Known issue; it’s somewhere higher in the stack than drivers.

@vvill, please try again; the AR9300 HAL was added and this seems to make a bunch of newer chipsets work.


#46

Slightly late trying out the Atheros driver. The AR9485 card is now working. It now appears under network preferences. I cannot connect to my wifi network though. The SSID/password box keeps popping back up like I’ve put in the wrong password.


#47

Excellent! The new atheroswifi driver is now loaded at startup, thus making my AR9565 chip [id 168c::036] now fully functional. (As of hrev52099 on x86_64.)

Very, very nice work @waddlespash! FYI, you’ve just made Haiku my primary OS. (Also thanks to previous improvements with stability, hardware support, package management, GUI toolkits and codecs ports. But gaining support for widely-available atheros wireless chips definitely is a huge plus.)


#48

Are you quite sure you haven’t put in the wrong password? :stuck_out_tongue:
But I have heard reports of that in the past. See if there’s an open ticket for it.

:smiley: :smiley: :smiley:


#49

I don’t know if there is already a ticket for this, but instead of the login dialog just reappearing if something went wrong, there should be a dialog alerting the user the password was incorrect, a connection failed to establish, etc. It would definitely help in scenarios like these, and even everyday users to avoid confusion.


#50

Hi all,

I´ve tested with a ThinkPad Z470:
listimage | grep dev/net
1162 0xffffffff813e7000 0xffffffff8140a000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/rtl81xx
1231 0xffffffff8076d000 0xffffffff807e2000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/iprowifi4965
TEAM 1359 (/bin/grep --color=auto dev/net):
~> uname -a
Haiku shredder 1 hrev51993 Jun 7 2018 21:09:33 x86_64 x86_64 Haiku
~> listdev | grep Network
device Network controller [2|80|0]
device Network controller (Ethernet controller) [2|0|0]
~> listdev | grep Wireless
device 0084: Centrino Wireless-N 1000 [Condor Peak]

Wifi has been working for a long time, ethernet (RTL8101/2/6E PCI Express Fast Ethernet controller) doesn´t work (and does not show up in network preferences).


#51

Does “ifconfig dev/net/rtl81xx/0 up” change anything?


#52

That worked! Thanks!! Any idea why doesn’t it work out of the box?


#53

Probably a bug in net_server.


#54

Definitely the right password. Will take a look for an open ticket. Thanks


#55

Or a bug in the wpa_supplicant app, i’ve had this issue bothering me for quite sometime, the workaround i found is to downgrade to wpa_supplicant-2.0, but you 'll have to build it from haikuports.
ps: FWTW, i have an atheroswifi device too.


#56

OK, all but the broadcom43xx drivers have now been synced to FreeBSD 11.1. DHCP is still an issue, but at least on one front, I think @tqh is investigating that.


#57

I can test broadcom 4312
deviceid 4315


#58

Is there no hope for BCM 4312 (14e4:4315)? I have one in a netbook that Haiku would be great for.


#59

Unfortunately this NIC requires some strange, restricted firmware that I don’t really know how to work with, and trying to implement it “blind” (i.e. without hardware to test on) won’t really be easy. :frowning:


#60

All upgrades complete as of hrev52118!

I’ve also started a branch to work on support for USB WiFi chipsets, but it’ll probably be some time before I get back to it…