Where to find RAM limiting bootloader for BeOS R5?

Hi all,
I finished setting up a Core2 quad system with multi-boot Haiku/BeoS 5.03/Linux/Windows. I’d like to have more RAM than 512 MB for the other OS’s, but for now 512 MB is necessary for BeOS 5.03. Does anyone have Euan Kirkhope’s “RAM limiting bootloader” for BeOS R5? I can’t find it anywhere, including the mirror sites referenced here on the Haiku forum. All links from Google go to BeBits which of course is no longer up. Depressing… BeBits was such a great resource. Thanks for any help.

1 Like

I wish I knew… maybe someone here in charge of a repository or BeShare can help you out. Personally, this is why I run Dano on an old machine and leave Haiku and Gnu/Linux to the newer ones. I wish you luck in finding it, and really wish I had what you’re looking for. Good luck.

I’ll post a reply on here if I find it.

Take a look here:


There seem to be several in the BeOS 5 PE archive by damoklas. See https://www.haiku-os.org/community/forum/beos_5_pe_software_archive for the discussion, file listing and to find beos5peware.torrent. You don’t need to download the whole contents, most BitTorrent clients let you select which files you want to download from within the torrent (at least Transmission does).


Thanks guys! I’ll try it out today. I was looking for the wrong filename in the archives… no wonder I couldn’t find it.

enlinea, out of curiosity… what’s your hardware specs? mobo and such.

It’s an older board; I think it’s close to the upper limit that BeOS will still work on, as far as “seeing” all cores in multi-core processors. Extra PCI cards are necessary for ethernet, sound, and IDE. I used the BeOS and Modern Hardware website as a guide. I’ve got a similar board (Biostar TForce P965) that BeOS seems to want to work on, but I need to play with it to see for sure. I’m fairly sure it worked on a newer DFI P35 board, but that was a couple years ago and I had to use the board for another project, so I can’t remember for sure. One thing that’s necessary for BeOS to see more than one core, is the MPS option in the motherboard’s BIOS settings. That’s the main reason newer boards won’t work, since MPS is probably phased out by now. That’s too bad, because I’d like to see if BeOS would work with newer processors like the i3, i5, and i7 series. No practical reason for it, but it’s just fun to experiment with.

DFI P965-S
Intel Q6700 Quad 2.67 Ghz processor
Gskill 512MB DDR2 PC2-6400 RAM
ATI Radeon X300SE PCI-e video card
Promise Ultra 100 PCI IDE card
Soundblaster Live soundcard
Realtek 8139C ethernet card

Haiku, BeOS 5.03, and Puppy Linux in the Grub bootloader.

Unfortunately, the RAM limiter didn’t work out. Replaced zbeos with the new one, but it won’t boot into anything other than failsafe video mode now. Will try out the floppy-boot method and see if that works, as soon as the new floppies arrive.

In case someone finds this thread in the future - the ram limiter also didn’t work for me but the solution here did: Extract zbeos boot loader from image

1 Like

This helped. Unfortunately it only works with 2GB installed. Any more and the system hangs on the Devices icon at boot splash screen.

Does number of DIMMs installed matter, or is it something else? I’d like to use 4GB for Haiku.

This thread is about BeOS, not Haiku and shouldn’t be applicable. 4GB should work just fine in Haiku if your board/cpu supports it.

I’m sorry I should’ve been more clear. I installed the boot loader into BeOS, but with 4GB installed, BeOS hangs during the startup processes.

I would just physically remove RAM, but I’m booting alongside of Haiku.

Why you want to use a 23 years “unused” os?

Use BeOS with a virtial machine if you want to use it or use Haiku.

This isn’t helpful. I’m sure everyone is aware of VMs and Haiku. If you’re genuinely interested why someone wants to run a 20+ year old OS, just ask that, preferrably leaving out the ‘dead’ part. It’s bound to rub people the wrong way… :smiley:

I asked. I’m really interested in why people are bothering with this, so many years after the end of BeOS. It is no longer used anywhere and there are no current drivers for it.

1 Like

I may have misinterpreted the tone of the second sentence. Was a bit imperative… All good. :smiley:

1 Like

Perhaps because BeOS was a commercial OS, some tend to think that it must has been better in some ways. Better hardware support, more available software… That’s completely wrong but I think that they have to discover that by themselves. Only things that I really miss are Refraction and StampTV. Since then TV has gone digital so…

There were commercially sold drivers for one DVB-T and one DVB-S card for BeOS as far as I remember; but considering in lots of places you would need MPEG4 support for DVB-T, and DVB-S2 on satellite (or ATSC/ISDB) that still wouldn’t be enoguh