Install BeOS Thinkpad T42p

Too much ram, maybe unable to find boot drive that unsupported through SCSI/USB.

Reference: 实机运行 BeOS (一)

It’s build in cd drive. I might try to find another ram module, and try again. I still want to use XP on it for now, so using less memory will be painful for that.

There were patched BeOS kernels or bootloaders (can’t recall anymore) to ignore RAM over 768 Mb or so (which is the max supported RAM config for BeOS 5.0 if i recall it correctly, btw.)

I have haiku running just fine on a t42. Something to consider?

Extrowerk, that would be nicer than reconfiguring memory. I’ll search for that while I hunt for a smaller memory module just in case.

Munchausen, I have Haiku running in it as well. Not quite as fast as I would like. Haiku is faster on my other machine but that has a lot of unsupported hardware (-:

I want to enjoy BeOS and enjoy the process of using directly instead of through VirtualBox. This query is specifically about Be as that is what I want to figure out right now. But for Haiku, is there anything that doesn’t/didn’t (before fixing) work on your T42?

1 Like

Look here:

I have a T42, please share your experiences if you attempt the install.
Btw there was definetely a radeon driver, probably you will have to install it aswell:

I will have to check it again, I have beta 4 running but didn’t do much with it. Wifi doesn’t work, but wired ethernet does. I presume I could swap the wifi card for a different one that would work. I can’t remember if I tested sound. I will check and get back to you

Thanks for those, I’ll try later and let you know how it goes.

About beta4, my wifi works. It’s an atheros card. When I mentioned unsupported hardware, I meant my MacBook Pro. Wifi works on the T42p, a little bit unstable. But then again I didn’t use it much.

Update: I made a BeOS Max install cd that had a ram limiting boot loader. I was able to boot. It had purple stripes, so I set it to use fail-safe graphics and 1024x768x16. It offered the Install/live cd/recovery cd option. When I say install, it scans for install media and destination drives, and seems to freeze there without finding anything. When I say live cd, it gets to the desktop and hangs there. (Can’t move cursor at that point).

You can try this.

  1. Rip the second track of R5 install CD out,
  2. Use the dumped file as the raw content of QEMU disk’s partition by using dd to write in the guest machine.
  3. Relaunch QEMU with install CD and boot from it, replace the “zbeos” with the patched one.
  4. Run “makebootable /boot” in the guest machine, then redump the partition to file.
  5. Install personal edition R5 to your real machine.
  6. Replace the C:\BeOS\ with the latest dump file.
  7. Boot the “personal edition”.
  8. Now you can install the patched Pro5.

I used to workaround the freezing by disabling DMA in the boot menu options, it’s something worth trying.

I was able to install BeOS with the professional 5.0.1. CPU runs at full 2ghz when booted plugged in, and 600mhz when booted on battery. The only safe mode option I need is to set the screen to 1280x768x16 instead of the full 1400x1050x16 (32bit doesn’t even show up in graphics options).

I’ll start working on finding drivers and patches a different time.


I attempted to install he Radeon driver listed here.

I tried both versions, neither worked. Am I supposed to blacklist any drivers?

That does not exist in BeOS. You can delete driver files if needed, but I don’t think the base BeOS install has any Radeon driver to delete?

Now updated to r5.0.3. No luck. I couldn’t find the article I was reading on adding my cards device is to list. How would I change a driver? I don’t know how to open the file or change the contents.

Probably you should use a hex editor, like DiskProbe. Look for PCI IDs, and change them.
Research the “Endianness” topic before you start.

Did you try the ATI Mobility driver? BeBytes - The BeOS Software Archive

It’s specifically for ATI RAdeon mobile graphics chipsets. It works great on my Gateway 450ROG laptop. Native resolution 1400x1050 16bit and 32bit. Pretty sure it’s from the same time period as the Thinkpad T42p and probably the same chipset.

That’s for Rage chipsets (and first gen ones at that) - the laptop in question here is significantly newer with a much much newer Radeon.

I presume you know of this site?


I have not had any luck with the graphics drivers. I did get sound working using the ich_ac97_1.7 that I got from PulkoMandy’s website. I did get usb drivers working, but that made it so usb mice wouldn’t work. So I uninstalled that and just use Haiku to move files from USB drives.