Webpositive Bookmarks

Quick question. I tried zipping and moving the zipped file of ‘/boot/home/config/settings/WebPositive’ and un-zipping it in the other Haiku PC. I want to duplicate my bookmarks from one environment and duplicate it in another.

The bookmarks do not work in the new environment–errors out stating cannot open the “” using “Tracker”.

Other Internat browsers have an import/export/manage bookmarks function built in. Webpositive seems not to have that ability.

Any idea how to copy these from originating system to the oher system?

Hi. What application did you used to zip the files in the source Haiku PC? Webpositive bookmarks are just empty files with all the data stored as attributes. Not all compression formats support those extended attributes. I never had any issue using the ZipOMatic tracker addon.

To check if the files still have the extended attributes in your target Haiku PC, check the file properties and confirm if them still have the ‘url’ and ‘title’ attributes:

Initially, I created a tarball (tar,gz) via Ark. No success.

Then, I used Zip-O-Matic to create the zipped file and that is what I used to transfer my bookmarks. I thought it would preserve the bookmark’s attributes. Upon looking at the file’s atributes via Get Info–the File type changed from ‘Bookmark’ to ‘Generic file’ and the file’s attributes have been nulled out as well.

Still no luck; hence my query to the group to properly replicate these bookmarks.

If you used Zip-O-Matic, then it should work. Could you confirm if after you unpacked them in your target location still have the attributes?

If still have the attributes, check if them have the right signature: application/x-vnd.Be-bookmark
You can check it using the FileType addon:

Zip-O-Matic or Zip ( including p7zip or lha) do not work.

These do not preserve the Bookmark’s file attributes once the files are encapsulated inside an archive.


“Kind: Bookmark” changed to “Kind: Generic file”


The attributes have been lost.

Strange, it should preserve attributes; you should open a ticket for that.
In the meantime, you could use bookmarkconverter (available in HD) to convert your bookmarks to html as most browsers have an import function that support it.

Good idea if I was going to a different browser.

Trying to duplicate WebPositive bookmarks into another WebPositive on a different system. So no conversion required.

I manually created hundreds WebPositive bookmarks from Firefox’s json export since WebPositive has no import function.

If attributes are lost there’s no way that you can transfer Web+ bookmarks unless you copy them straight from a bfs partition to another. This isn’t perfect replacement solution but, if you can’t wait till someone of good will fix preserving the attributes, using the conversion, you would be able to use any portable device whatever the filesystem on it…

I will be using a BFS USB harddrive and see if that works. I suspect it will.


Works here. You haven’t replaced the /bin/zip that’s coming with Haiku?

What does zip -v and listattr -l /bin/zip in Terminal say?


Works here too.

That sounds like a pretty easy task to implement. Is there a ticket for this?


FWIW, you’re not the only one who experienced this, i lost about 50+ bookmarks because i was confident that the zip format would preserve the attrs, in my case i did a clean install and the only backup i had was the zipped ones that i copied to another bfs partition. but when i tried copying new ones without zipping them to a bfs partition that worked… go figure?

I think we should start gathering data under which circumstances the attributes are and are not preserved. Best place to do this would be a ticket. Is there already one relating to this problem?

Maybe also, like Humdinger posted,

would also help to know which flavor of zip is running

I will create the ticket, where should it be created? Under Zip-O-Matic or Zip?

~> zip -v
Copyright (c) 1990-2008 Info-ZIP - Type ‘zip “-L”’ for software license.
This is Zip 3.0 (July 5th 2008), by Info-ZIP.

~> listattr -l /bin/zip
File: /bin/zip
Type Size Name Contents

    Text        10  "SYS:PACKAGE"                       zip-3.0-4
    Text        22  "SYS:PACKAGE_FILE"                  zip-3.0-4-x86_64.hpkg

MIME String 35 “BEOS:TYPE” application/x-vnd.be-elfexecutable

67 bytes total in attributes.

I used my external Zeta OS (BFS USB) harddrive when I process my new DVDs with DVDRip and convert them into MP4s with Handbrake. I copied the ‘/boot/home/config/settings/WebPositive/Bookmarks’ directory onto it and replaced the same directory on the target PC system.

Voilà!! Problem solved!! Should have thought of that before…go figure. Webpositive has functional bookmarks again!!

Thanks everyone…

From your Terminal output, the installed zip is the expected one.
You’ve solved your issue by copying the bookmarks to a BFS volume. That doesn’t explain though why, when you zip them up, they lose their attributes. Nobody seems to be able to reproduce that… What’s different with your setup, I wonder.

I’m not alone in encountering this issue, such as khallebal reported. So there are more out there–that’s for sure.

Do not have a clue. Both systems are twins, per se. Running the same installed software in each instance and same OS levels.

My PC is a clean install about a month old (Dell OptiPlex 9020 Haiku R1B4 Installation).

My laptop is older starting with R1B2 upgraded to B3 then B4 (when that was released).

All I know is that both systems shared the same Web+ Bookmarks & Zip issue. So far from what I experienced in one PC is duplicated in the other:

So far the two systems shared the same issues. So I do not know why my two “stock” installs are different from others.