Realtek 8168 ethernet problems


#1

Which Realtek do you have? I have an 8168 that isn’t recognized by Haiku (or FreeBSD). Well, it’s sort of recognized with CSM turned on, but doesn’t see an active Ethernet cable.


Post your Haiku screenshot!
#2

it appears to be an 8168h/8111h.
So if I turn on CSM, would that solve it?


#3

It might, but I couldn’t guarantee it. It may show up, but in an eternal state of disconnection.


#4

Haiku uses the FreeBSD drivers…


#5

#6

Hmm… should I submit some kind of Bug report?
I just remembered that in order to start it up I have to boot it into safe mode.
Would that have something to do with it?


#7

Yes, but it seems this device does not work properly on FreeBSD either, see: https://dev.haiku-os.org/ticket/14576

@JohnpaulTH, safe mode is probably related actually. What happens when you don’t do that?


#8

I can’t boot haiku.


#9

That doesn’t mean much. What happens, specifically?


#10

goes black after the bootloader.
If I disable APM, I can get to the blue screen, but not to the desktop.


#11

What happens when you use “fail-safe video mode”? Or “Disable SMP”?


#12

If I use VESA+Disble SMP+Disable APM+one other which I cannot remember, It will recognize my chip. I will see if it works.


#13

Well, please try eliminating as many of those as possible and see which one specifically fixes the problem.


#14

I will when I have the time.


#15

It is just disable IO-APIC + use failsafe graphics.