KDE Frameworks 5 and KDE apps


#142

To fix KolourPaint not being able to save files run this:
kbuildsycoca5 --global

As for qBittorrent crashing, I also have it. Probably need to revert to an older version.


#143

That fixed it with Kolourpaint. Thanks!


#144

There i can get the kde framework and apps?


#145

Haiku with KDE is in the news:


#146

In 7 years old news… :smile:


#147

But there i can get the kde framework and apps?


#148

Why don’t you check in HaikuDepot?


#149

Because i does nit found them


#150

Haha, saw the date now. Didn’t know that all.


#151

At this moment, are available only in x86_64 repo.

However, I also found some KDE libs being included in x86_gcc2 repo, so probably soon be included there too.


#152

I noticed that kdelibs4support is availbale on x_86_64 repo, so i tried to build it on gcc2h, but i’m getting the following:

Skipping download of source for v5.39.0.tar.gz
Validating checksum of v5.39.0.tar.gz
Unpacking source of v5.39.0.tar.gz
Initialized empty Git repository in /boot/home/haikuports/kde-frameworks/kdelibs4support/work-x86-5.39.0/sources/kdelibs4support-5.39.0/.git/
Applying patchset “/boot/home/haikuports/kde-frameworks/kdelibs4support/patches/kdelibs4support-5.39.0.patchset” …
Applying: Fix haiku build
Fetching package for lib:libgl_x86 >= 1.0.0 …
Nothing to do.
‘NoneType’ object has no attribute ‘packageInfo’

but libgl is not even in the REQUIRES section, how was it built on x_86_64?


#153

Dependecies.


#154

'NoneType' object has no attribute 'packageInfo'

I think this could be because you didn’t specify your name in haikuports.conf (I thought it was fixed in git)


#155

Maybe it is solved already, but nobody told to the users that they needs to update the haikuporter checkout regulary.

It could have some kind of automatic update.


#156

There is KDevelop (A cross-platform IDE for C, C++, Python, QML/JavaScript and PHP) build for Haiku?


#157

Well i think it’ gotta be something else then, because i have my name in the haikuports.conf file and i did a git pull for haikupoter tool right after i got this error but it still the same .


#158

Do you have your name and e-mail set in haikuports.conf?


#159

I had a similar error yesterday when trying to build Otter-Browser. It too said “Fetching package for lib:libgl_x86 >= 1.0.0 … Nothing to do.” (not sure about the exact version anymore).
Luckily mmlr was around on IRC and it turned out that I had an old mesa_x86 package in my system. This tripped up pkgman in some way, that mmlr is now aware of and can hopefully fix eventually.

The solution for me was to do a “pkgman full-sync”, which I haven’t done after switching to the new “eu” repo. I decided to let it uninstall anything that would conflict. After a reboot I tried again and it all worked.
Thanks mmlr!


#160


#161

4.0 KB free :slight_smile:
I know, it is RO.