KDE Frameworks 5 and KDE apps


#122

You can open the report (it’s a textfile) and copy the content here, or the best is if you could open a ticket at Haikuports (you need an account in github):


#123

ok… i’ll try to report it… wait… i’m forget my github password… :tired_face:


#124

i report here … https://github.com/haikuports/haikuports/issues/1797


#125

I just tried the same case (saving a Sheet file), and managed to reproduce the same error too.


#126

try execute from terminal:
kbuildsycoca5 --global


#127

As a quick workaround install dbus.

pkgman install dbus


#128

…after install dbus… it can save correctly… thank you @Diver


#129

@3dEyes …can you little describe whats is the command mean?
and how it is different with @diver solution


#130

WOW, thank you for all your great work.

Seeing Telegram Desktop installed and running on Haiku is just awesome. And I love seeing the preflet in the Deskbar notifying me of unread messages.


#131

Which version of Haiku are you guys running on? The latest one I’m using crashes with a page fault when trying to install.


#132

Hi dwt,

I am running a few KDE apps on build 51568, x86_64 in Virtualbox.


#133

Thank you very much! Got it working now!


#134

I got it working. Wrong url.

Why is the news section on haiku-os.org completely quiet about progress like this? It’s not the core os, but to attract more users its gold stuff.


#135

Because these repositories had a lot of strange inconsistencies and “gotchas” until these past few weeks, to the point where we did not want to advertise them.

I sunk a lot of time (much more than I intended to…) into solving the remaining package build failures this week at KDC, and the last few builds are running now. Unless some other problem occurs, I’ll switch Haiku’s master branch to them in the next few hours and then post on the blog about it.


#136

Qt application still failed to load at latest haiku 32 build (hrev 51615) …i do update haiku into latest build.
error message:


#137

You need to rebuild your projects due to recent Haiku API changes (BControlLook).


#138

We will be soon switching to a new package repository with more up to date packages. It should help solving this particular issue and others.


#139

The program BeeDiff isn’t available in Haikuports so the Software comes from other repo or own-built.
The User or the repo Manager needs to rebuild BeeDiff.


#140

Probably from my repo. Nothing wrong with BeeDiff AFAIK, it is QT4 that is broken, and I can’t recompile or test until it is fixed. Try ponpokodiff instead.

I’ve already removed most of my QT4 apps from the server. This one escaped, but I’ll take it off now.


#141

Having Qt/KDE applications in Haiku really makes a huge difference. So far I encountered problems with Kolourpaint (can’t save file) and qBittorent (crashing immediately when a download starts).

The other applications seem to work very well. Krita especially worked better for me than in Windows and Linux.