Haiku on Asus EEE 701 wont start interface

I tried to install the latest nightly build of Haiku 32 Bit to my Asus EEE 701 (4 GB). It boots to the first splash, but the screen stays black after this.
I went to the debug screen and activeted debug message to the screen. This are shown, but then the screen comes black at the moment it would start to the gui.

I tried different options on the debug screen like graphics mode or APCI, but without any change.

I read some articles online that other persons managed to install Haiku on this hardware. Is there any trick?


I have done it, but probably nine years ago. I would expect using the fail-safe video mode option in “safe mode options” and/or then selecting a fail safe resolution of 640x480 would work (or 800x480 if it’s available, as that’s the native resolution of the display IIRC?). Though I seem to remember that it used to work OK with the intel driver. You can also try enabling on screen debug output which will provide a bit more information about where it fails.

1 Like

I will try resolution 640x480 this evening.
On screen debug brings a lot of messages, but it will become just black without any message at the point where it should start the gui.

Make sure to try the fail safe video mode option as well as it will make it use the VESA driver instead of intel. The intel driver used to work I think, but it has had some changes and in my experience it doesn’t always work on machines where it used to be fine.

Also, could be another issue, though this was supposedly fixed some years ago. See:


thank you for the help. It works with the VESA driver. If I use the default display driver, it is not starting.

Is there anything I can do to help to fix this problem?

I had similar problems with my EeePC 900 and my topic was here no so long ago. It`s the same CPU and GPU too I guess. No one could help me. :frowning: I wanted to do more research, but after about 10 years he had contact with liquid in my backpack and… Well, now screen is black even without Haiku on it. :expressionless:

1 Like

A few people made changes to the intel driver, and it looks like a regression crept in a long the way (it is very hard, since 95% of laptops are using intel GPUs so its impossible to test them all). I know @PulkoMandy did some work on it at one time or another, maybe he has a pointer? It would be good if you could submit a bug report at https://dev.haiku-os.org/

In the mean time, what you can do is blacklist the intel driver, so that you don’t have to select the vesa driver at every boot. There is an example that fortuitously uses the intel driver (intel_extreme) here: https://www.haiku-os.org/guides/daily-tasks/blacklist-packages/

I have pointers to other people who messed with the intel driver, yes :frowning:

The way to get this fixed is grabbing a syslog, creating a bugreport and attaching the syslog there. Then maybe we will have enough information to try to fix something. You should also provide the exact model of the video chip (from listdev) and ideally a syslog from an older version of Haiku where the driver still worked (this makes it easier to look for things that became broken since then)

1 Like

Sorry… :stuck_out_tongue: :smile: