Haiku 64bit on Ryzen


#102

Please use Trac to describe your problems. Also attach files there, don’t link them.


#103

Thank you. The more I look at this the more I think I have the wrong part. I am going to order another M.2 device and ensure it is PCIe to connect before I waste anyone’s valuable time on this.

I am just excited that so far most everything works on the ASRock A300. I think this will make a excellent Haiku box for a modestly low cost.

Great Job and many thanks to the Devs and the Community!


#104

Good day,

@smlnjoe, beware that Radeon driver does not work with ultrawide displays, at least on my Ryzen box. Have to force the Safe Graphics mode and don’t get sound through DP, most likely because using the Safe Graphics. Other than that, in my case I use a standard SSD drive, non NVMe, and works fine. Just sometimes I get the feeling that network is slow compared to the Ubuntu installed dual boot on same hardware.

Glad you don’t have those many issues, and yep, thanks the Devs for that!.

Regards,
RR


#105

Depends,as some ‘working’ Radeon HD graphic cards have issues with the RadeonHD driver. I have it working on my 1080p monitor. Make sure you have a ticket so the dev(s) can review the issue.


#106

@cocobean, thanks and yes, I have already reported the ticket (long ago) :wink:
my card has no issues on FHD either, just with UltraWide

Regards,
RR


#107

There is no indication of NVMe devices anywhere in that log or listdev. There is only one SATA controller. Do the drives appear in any other OS?


#108

Thank you for the support! I have not tried any other OS on it. Plan on it being a Haiku only box. I think that the M.2 connector on the A300 only supports the PCIe NVMe and not the SATA.

I have ordered a Samsung PCIe NVMe that I should get Sunday. Will test and let you know.


#109

Thank you for the heads up. Planning on running in 1080p right now.


#110

Sometimes things posted here aren’t really bugs and don’t need to make it all the way to Trac… as in this case it seems the m.2 ports just don’t have sata on them which is a little odd since AM4 has sata on the socket.

The manual for the A300 doesn’t list a single SATA drive though as compatible with the M.2 ports.


#111

Try looking through the BIOS (or EUFI or whatever we call it these days) and see if there are any options for the M.2 slot. And make sure it’s enabled.


#112

Yup, no options in BIOS. New drive will be in tomorrow. Will have update then. Thanks


#113

Good news! The new Samsung 970 EVO is seen at USB boot. The drive can be initialized and formatted. Looks like installer writes to it. Now I have to figure out how to tell the ASRock A300 to boot from the NVMe drive. I am going to re-read the NVMe bolg

Progress! Thanks to everyone’s helpful guidance. If I get everything up and running I’ll try to put together a little write up on specs and settings to make it easier for others.


#114

It turns out, when you follow the instructions exactly everything works as it should! I now have the NVMe drive as the boot device with nightly 64 bit booting. Will start testing the various devices (sound, wifi, etc) and get a full accounting of what works and what doesn’t.

Thank you to all who helped get a native boot going on the ASRock A300W.


#115

Accordong to bug #15168 the radeon drivers is no longer working. This affects to me on two different computers with different cards Radeon RX580 and RX460 with signal out of range. The radeon drivers needs more love instead of the rest. This problem has more time occurring the haiku boot, and the framebuffer driver seems very initial for the system itself.


#116

I don’t think RX580 ever worked… RX480 did though at one point though the differences between those two would be minor. RX460 should work… which output are you using it’s more likely to work with VGA and DVI than HDMI or displayport I imagine.

My A5000 APU doesn’t have any issues other than being slow to mode switch at startup…

Also note that radeon is a different driver than radeon_hd which is the one for recent cards the bug report you are referring to is for a very old card.


#117

The problem is using either DVI or HDMI RX460 doesn’t have a vga connector. And yes the problem is for real, and for the moment it’s not solved at all.


#118

Good day,

@zantak, my RX 560 has HDMI, DVI and DP. I use it with DP and have to use Safe Graphics mode, runs on framebuffer and no sound. There is a ticket already reported at Trac, though it will take time to get it solved.
Patience.

Regards,
RR


#119

This is not a commercial project that you are paying for so that tone is a bit uncalled for. radeon_hd seems to be mostly in maintanance mode if you want it use it, it’s on you to get compatible hardware and use it in a manner that it supports, or implement the support yourself… this is for all intents and purposes still a hobby operating system despite it being fairly complete in many ways.


#120

FWIW, I don’t find @zantak’s tone rude. Maybe we should save our scoldings to the more deserving posts, lest they wear off needlessly. :slight_smile:


#121

Perhaps not, but there is also no use in beating around the bush, may as well set expectations straight and be as helpful as possible from there. Certainly Haiku’s development pace can be slow in areas, and this is an area I keep an eye on the progress of, so formed him of the status and that basically patches welcome… that’s obviously not ideal but it is realistic.

Probably we should force these cards into VESA mode perhaps I could help testing there? So, people actually get graphics even if accelerated instead of hanging at boot etc… defaulting to VESA with a boot option to enable attempting running the native drivers might go a long way, then people could just post the ID’s of working hardware. We already sort of do this… just backwards i think.