DosBOX System Crashes. Can't find Retroarch


#1

Hello, I just did a fresh install of Haiku RC1 GCC2 X86.

I used Haiku Depot to download DosBOX and its dependencies, then when in and configured DosBOX to run my favorite games. After this, no matter what game I load, my system crashes, dropping me to the terminal where I seem to have no option but to type ‘reboot’.

I am also interested in running Retroarch, but can not seem to find a HPKG for it anywhere. I tried to compile it and a few other things but so far have not succeeded, even with Reminiscence which compiles on everything.


#2

Hello. I’m using Dosbox on gcc2_x86 BETA, and appears to works well. Please, would you like to share a pic of the error?


#3

20181206_202038


#4

https://dev.haiku-os.org/ticket/14711


#5

I see that Retroarch showed up on Haiku Depot. I had to turn on Triple Buffering in VIDEO to get a normal frame rate, though I also see that it is very early and not reliable at this moment. Still though, I’m amazed that it runs at all! Looking forward to the future!


#6

@XD3l Hello. What system do you are trying to emulate? For 8 and 16 bits machines, you also had Mednafen, that works very well.

AdvMame also is available.


#7

I was trying NES and SNES, once triple buffering is turned on, the games will play full speed, though Retroarch exits when I press certain buttons on my controller, or it eventually just crashes on it’s own.

Mednafen throws up an error every time it attempts to load, and I have not gotten to AdvMame as of yet.

My presumption is that my computer is not fully compatible? It’s an old Dell Optiplex 745 Slim running a Quad Core. I have tried putting various old and newish Nvidia cards in the system, but end up with the same results.

Everything runs SMOOTH, except for when it comes to games in which case I am stuck with Snes9x. :slight_smile:

I believe I should be running this under a virtual machine for now, unless the authors of the various pieces of software are interested in all the errors I can produce. :slight_smile:

Thanks for the help!


#8

Please, show me the error from Mednafen. Usually, this kind of errors are more related to the app, and not to the OS.

If you can connect to internet, view videos and listen music, your hardware probably is full supported.


#9

Sure thing, I’ll provide an example of me trying to run Super Mario Kart, and The Legend of Zelda.

20181207_161313 20181207_161358


#10

Let me check, but I’m pretty sure that the problem is related to the video driver that Mednafen are trying to use (OpenGL). If I remember correcly, you have to change it to “SDL” to get it work.

Give me some time to check it, and specially, where do you have to change it.


#11

I was looking for command line options, but could not find them. I swear I’d found them before when using it under Linux.


#12

Hello again. Try this:

Look at the /boot/home/.mednafen folder (depending on the Tracker settings, could be hidden):

screenshot8

Inside this folder, you will see a textfile named mednafen-09x.cfg, or something like that. Edit it and look for the video.driver parameter and set it like this example:

;Video output method/driver.
video.driver sdl

#13

I did not find the file in the folder, so I tried to run mednafen without a rom, and it was able to create the config file. Now that I have that file and made the changes you suggested, it is up and running!

BTW, I also got Half-Life and Opposing Force working at around 24-40 FPS, Duke 3D, Quake 2 (faster in software mode), Morrowing (buggy), Serious Sam (FPS could use a boost), etc.

I believe you are right, my hardware is fine. :slight_smile:


#14

New problem. I set up my controller with ALT SHIT + 1, but now every time I am in the game and press certain buttons, “PRESS COMMAND KEY to REMAP NOW” shows up at the bottom of the screen and forces me to start remapping stuff unless I exit Mednafen.

The strangest thing is that sometimes it just seems to randomly pop up. I.E. I was using the directional pad to navigate and set up a profile on The Legend of Zelda, when one second the joypad works in the game, and the next it seems to be invoking the remapper.

EDIT: I found out what was causing this and removed it from the config file. It was a mishap from when I was trying to set up the joystick initially.

Anyhow, I have come to find that Mednafen, like Retroarch, does not allow me to use certain buttons and directions on the controller.


#15

Hello! Nice to hear that my suggestions worked! :slight_smile:

About your last issue: are you sure that you configurated correctly the controller? Mednafen is a bit tricky. Read carefully:

When they say (for example) “GamePad#1:A(1)” you have to press the controller button that you want to assign. After you press, you will get: “GamePad#1:A(2)” (notice the 2). Here you have to press again the same controller button to confirm the choice.

After that, you will move to the configuration of the next button (B) , and this will continue after you will remap all the button that are related to the system you are emulating.

The rule is that you have to press two times for each button that you are mapping.

For example, if you are running a NES game, you will configure the NES buttons (A, B, select and start). If you are running a SNES game, you will configure the SNES buttons (A,B,X,Y,R,L, select and start).

Here you will get a bit more info:
https://mednafen.github.io/documentation/#Section_remapping_input

Probably this sounds a bit complex, but really is very easy when you get it. The mapping method is the same in Linux.


#16

I am aware of the double press rule, and sadly that is not the issue here.
The problem I had before came from me pressing the wrong keyboard combo. I fixed this by deleting the additional lines in the config file.
Since this has been fixed though, I noticed when setting up the joystick that certain buttons and D-pad directions do not register. They will if they are assigned as a Hotkey in Mednafen, but will not detect for use within the emulated game system.

Again, Retroarch had the same issues, which makes me wonder if this is not some sort of issue with the SDL lib and not the emulators themselves.

Going to try a more common joystick next and see how that goes.


#17

I’m using a Logitech Rumble F510. Is well made and inexpensive. And came with a long cord.


#18

I got a couple F510’s and you are right, they work well!

I tried my Haiku into on a different computer and everything acts the same, as it did on the other machine. DosBOX crashes the system, Retroarch is flakey, etc. Though with Mednafen and the game ports I’ve gotten to run, I’m impressed! All this and more in a mere RC1!


#19

Wait. We’re up to RC1 already? I thought we were still in beta.


#20

Need to get support (or gamepad kit support) for Ps DS4 controller and/or xbox 360 controller.

Both common enough, with linux working drivers.

If i was able to get/port support for my new MRA Arcade stick… even better.