Bootmanager not booting Ubuntu


#1

I’m trying to set up a dual-boot Ubuntu/Haiku on one of my older laptops. So far, I’ve done the following:

  • Installed Ubuntu, splitting the hard drive into two partitions while doing so. Ubuntu is on hd0,1
  • Installed Haiku on hd0,2
  • Installed Bootmanager into the MBR, configuring the menu items for Ubuntu and Haiku
  • Rebooted and successfully booted Haiku from the boot menu
  • Rebooted and tried to boot Ubuntu from the boot menu

When I selected Ubuntu, I received an error stating ‘Not a bootable partition’.

Does anyone know how I can go about fixing this? I tried adding Haiku to GRUB when I initially tried configuring this setup but didn’t have any luck with GRUB booting Haiku and now I’m getting the opposite behavior with Bootmanager. :slight_smile:

Thanks!


#2

Haiku Bootmanager can not boot Ubuntu by itself. There must be installed GRUB on Ubuntu partition.


#3

Did installing Bootmanager remove wipe out GRUB? If so, is it better to have a small partition for the Bootmanager itself so they don’t step on each other?

So something like:

  • Bootmananger partition
  • Linux
  • Haiku

#4

It works if you install grub in the linux partition (i.e. hd0,1, not hd0). Haiku’s BootManager will be installed in the MBR of the disk and then calls either Haiku, or grub (which in turn chainloads Linux).


#5

What would be the way I would go about reinstalling GRUB on the Linux partition (I’m assuming via the Live CD) so that it A) won’t overwrite the MBR and B) will still allow Ubuntu to boot properly from the Bootmanager?


#6

For that you must install GRUB to Ubuntu boot partition. If you install GRUB to MBR you will overwrite Haiku’s Bootmanager.


#7

This is what I followed and GRUB has again regained control of the MBR.

I’m pretty new to all of this so if you can provide some instructions on what I need to do, specifically, I can probably figure it out.

Thanks!


#8

If you install grub to hd0 it wipes out the MBR. You want to install grub to hd0,x where x is your Linux root partition. Then you can reinstall BootManager in the MBR (this is default behavior for BootManager.)

So follow the directions for installing grub, and substitute hd0,x (again x is your Linux root partition) instead of hd0. Don’t type x, put the partition number in place of x.


#9

I’ve finally got it working! Thanks everyone for your help!


#10

Yeah grub and how Linux boots is frustrating. It seems they do things different for the sake of being different and not for any necessarily good reason. I’m glad you got it sorted.


#11

FYI, we sent patches to os-prober (the tool that Grub uses to detect other OS on your machine), which would automate adding an Haiku entry to GRUB (as it works for Windows).

The os-prober developers are waiting for a few users to try the patch and confirm it works. Then we would not need to mess with this anymore.

If you have some Linux skills, please, please, take the time to review this and save our poor dual booting users from all these headaches :frowning:

So, basically, go here to complain: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732696


#12

I’m adding to this thread as it’s a related problem:

  • My system has Windows 10, Archlabs Linux & Haiku installed (GRUB 2 is the bootloader)
  • I successfully (?) added Haiku to GRUB so I get it as an option.
  • When I boot from GRUB I get the Haiku “loading” screen (with the icons), but it just sits there and nothing happens.
  • I can still successfully boot into Linux and Windows.

Any ideas? This kind of thing is on the limits of my knowledge so any help is appreciated.

Cheers.


#13

If you got the Haiku splash screen and icons after the grub menu, it isn’t grub related. Could you please ask in a new thread? Your question deserves the proper attention and splitting up a topic won’t help with that.


#14

No problem. Here is the link to the new post: