Thinkpad W530 Boot Problem


#1
  • My system has Windows 10, Archlabs Linux & Haiku installed (GRUB 2 is the bootloader)
  • I successfully (?) added Haiku to GRUB so I get it as an option.
  • When I boot from GRUB I get the Haiku “loading” screen (with the icons), but it just sits there and nothing happens.
  • I can still successfully boot into Linux and Windows.
  • I have tried different settings in the BIOS (Legacy/UEFI/Both) to no avail

Any ideas? This kind of thing is on the limits of my knowledge so any help is appreciated.

Cheers.


Bootmanager not booting Ubuntu
#2

Hold spacebar while hitting enter when choosing haiku from grub. You’ll be presented with a menu to choose boot options, including safe mode. Try booting with safe mode enabled.


#3

Enabling “Safe Mode” and “continuing to boot” results in the computer immediately rebooting (back to GRUB.) Subsequent tries into safe mode result in the same thing as trying to boot normally (hanging on the Haiku Logo/icon screen).

Should the “boot” flag be enabled on my Haiku partition? I’ve noticed this is not enabled on my other partitions when viewing them in gParted, but it is on my Haiku partition. I’m not sure that it matters but thought I would mention it. As I said this is all a bit out of my depth.


#4

Boot flag shouldn’t make a difference. Are you using Beta or the nightlies?


#5

The current install (that I’m having problems with) is the Beta. I’m trying a new stick with the latest nightly on another machine right now.


#6

More interesting is to check “enable on-screen debug” and boot with that set. The OS will then log things on the screen so we can see where it gets stuck.

How did you install Haiku? Booting from USB? If so, you can also try booting from the USB stick and pressing space, then you can tell our bootloader to load the OS from the installed partition. If that works, it’s either GRUB confusing our bootloader, or maybe a problem with makebootable due to an incomplete/failed install.


#7

There was a bug that caused these symptoms (on 64-bit at least) which was resolved last month. You may want to try a newer nightly build if you aren’t on one already.


#8

I tried a newer build on a Thinkpad X220. Everything is gravy and I’m up and running (and WiFi works!). I reinstalled on the other computer that was having problems (Thinkpad w530) with the latest nightly and get the same issue. I’ll try it again and “enable on-screen debug” to see if it gives me any more information.

@PulkoMandy I can use the USB stick to boot into the Haiku partition on the drive.

Honestly, I’m good with the x220 and a working haiku as I don’t think I’ll be able to get Wifi working on the w530 even if I get Haiku installed. That said I’m happy to try whatever if it is helpful to ya’ll or future users.


#9

The datasheet for the W530 says the WiFi chipset is a “Intel Centrino Advanced-N 6205”. I know some users who run Haiku on laptops with that chipset and use WiFi just fine, so, that wouldn’t be an issue at all.

What build were you trying on this machine – 32-bit or 64-bit? Both were affected by the bug I was thinking of, but only 64-bit was fixed (it seems to really be 2 bugs with the same symptoms.) So try 64-bit if you haven’t yet.