Blender 2.81 is working on Haiku

I managed to build and run Blender 2.81 on Haiku.

I used Mesa 19.3.3 (19.3.2 don’t work), modified HGL (patches are not yet uploaded) and modified libSDL2 (https://github.com/haikuports/haikuports/pull/4535). Blender itself builds with almost no changes.

81

33 Likes

wow very impressive!
Amazing work, hope it will be usable soon…
thx I use it a lot.

Great work! Still looking into some of the dependencies PR’s at haikuports, but looking promising!

The UI of blender really has majorly improved in the last few releases.

1 Like

This Blender version seem more simple to understand than the oldest ones. Good job.

1 Like

The new UI came with 2.80, along with a whole host of changes. IMO it changed more than enough to warrant a full integer increase in the version number, but the Blender devs are saving that for the future.

Many projects stay conservative in version bumping. Devs and users often view milestones from vastly differing viewpoints.

Fantastic! I look forward to giving it a spin when it is ready. As a side note for those of us that also enjoy Haiku on 32bit machines, is there anything intrinsic in the 3.8 code that would not allow it to be compiled for x86?

It may be good to keep both 2.7 and 2.8 versions. Blender 2.8 is heavier (Haiku has only software rendering for now) and has compatibility problems with older projects and scripts.

1 Like

Yipie! I hope I can test it soon :slight_smile: great work!

I tried to compile Blender 2.81 on 32 bit, it compiles, but fails with libstdc++.r4.so not found. Seems mixing of gcc2 and gcc4+ modules appear somewhere.

Blender 2.79 runs fine on 32 bit.

I investigated a bit and found that library path was set in OpenSubDiv libraries dynamic section (RPATH) and that path was wrong. After fixing that Blender 2.81 runs fine on 32 bit.

6 Likes

Would be really nice to see this on a Ryzen system, especially on a Threadripper. Might be a good way to test Haiku’s multithreading capabilities, especially on CPUs with high core counts.

Just note that the OpenGL in software won’t scale past about 8 cores since it’s mainly memory limited… the huge cache on some of the Threadripper 3 CPUS may help.

When you go to do an actual render though it should be quite fast…Cycles is pretty good about that.

Brilliant! So happy to see it work!
(I wanna use it for 2D animation and sound)

I’ve installed blender with pkgman, but I have this error when starting it:

runtime_loader: Cannot open file libosdGPU.so.3.4.0: No such file or directory

libosdGPU.so.3.4.3 is installed, not libosdGPU.so.3.4.0

I’ve tried to copy the lib with a new name:

cp /boot/system/lib/x86/libosdGPU.so.3.4.3 /boot/system/non-packaged/lib/libosdGPU.so.3.4.0

but it’s the same when running blender.

Blender needs to be rebuilt.

1 Like

Good day,

Well, seems that some improvement has been made to Blender lately. The new released 2.79b available in HaikuDepot seems to work fine now on “famebuffer” video driver without the cursor black square trail that was seen before…
blender1
blender2

That means, that there is no interference while working with models. Still need to test this out with a complex model though, but improvement is there. There are some quirks still present, but the direction seems definitely the right one.
Blender4
This one shows a detached viewport (detaching viewports also work) with some weird font rendering.

Kudos to the devs!!!

Regards,
RR

4 Likes

Ah that’s great news.

Maybe the font rendering problem is related to the themes problem here:

It is Blender 2.79b not Blender 2.81 what is working now! Don’t get it wrong because of the headline…

Which means Haiku has to be started in EFI - Mode.

How to get the Framebuffer video driver using the VESA screen size now?