Beta1 on Sony Vaio VGN-SR29XN: unable to poweroff


#1

Hi all,

yet another problem with beta1 on Vaio VGN family laptop. I prefer to collect here more info about before eventually open a bug on trac (to avoid a false positive or a duplicate ticket)

As the title states, system won’t shutoff. Trying to do so, freeze the shutoff process after having killed all the applications and background servers.

This works however when I disable power management features at boot menu (in this case, the familiar and old-style “it’s now safe to turn off your computer” box will show at shutdown as expected)

is it a known problem on this hardware? shall I have to report? Is there something I can do to have a better log of the shutdown process (syslog)?

PS pls bear in mind while it’s not the case I cannot provide info from KDL. The box has no serial port and the screen is so dim that shooting it is almost impossible.


#2

Good day,

@TheClue, As far as I know, it is a known issue related to ACPI. I also have a Vaio VGN-SR19XN running Haiku 64bits, and it does not turn off after clicking on “Power off”. All processes close, but screen keeps showing the “Shutting down” window on black screen.

I need some time to check which tickets are filed and maybe add the info to those tickets. This laptop is old (around 2008) so I do not care so much as I’m thinking of a replacement.

Other laptops from other brands seem to have same issue too. I just press the power on/off button until it shuts down, for now.

Regards,
RR


#3

It might help to know what laptop you are using, VGN represents an enormous range over a large time span.


#4

you’re absolutely right :slight_smile: it is a VGN-SR29XN


#5

Vaio VGN-B100B seems to power off completely, at least with most hrevs. I had to use nightly images because it has USB 1.1 (boots…eventually…) and I had only CD-R discs available (too small for beta1)


#6

Hi, I too have a similar problem. Machine is Vaio VGN-TZ11.
On shutdown, the screen blanks fine but the power status light remains on. The power button has no further effect (pressed for any amount of time!) and the only way to power off the system from here is to remove the battery.
I would be very happy if I had the classic “safe to power off” display!
Does anyone know a solution in Haiku yet? or to change anything in the bios to help?
It works pretty well otherwise!


#7

you can tweak some kernel settings, including power managment, in this file:

~/config/settings/kernel/drivers/kernel

you’ll end up in the good old W95 “it’s not safe to turn off your computer” this way :slight_smile:


#8

This was helpful, thanks. But now I don’t have the ability to use the luxury of the battery display (acpi disabled). Is there a solution which gives me both the cake and allows me to eat it? Or would I need a custom kernel? or is it impossible curently?
Many thanks for your quick reply!


#9

I’ve been running into this too, on several systems that are not Sonys. I’ve been using reboot from the menu or ‘shutdown -r’ to reboot from Terminal. I multi-boot using BootManager, so I default reboot to the boot menu which is safe to power off from. Or I push the power button to shut off once the screen blanks. This has been my workaround to keep acpi turned on, and thus the🔋replicant. I get to have my cake and eat it, albeit slightly less icing. Hope it helps.


#10

I tried the 18.03 version of TrueOS / FreeBSD on this machine too and it does the same thing. Perhaps that’s not a surprise? Given that the intel video drivers didn’t work in either until updated


#11

Afaik, we only use the FreeBSD netstack. Any other similarity is likely just a coincidence.


#12

We also use ACPICA, same as Linux and FreeBSD do, but our usage of it is more similar to FreeBSD’s (and there is some shared code here too, particularly with ACPI interrupt handling.) So this may be related indeed.


#13

Thanks waddlesplash. The bug for these machines then is likely related. No sleep and no power-off in either Haiku or FreeBSD but Linux etc handles this fine (various distributions). I had assumed sleep wasn’t supported in Haiku (screen blanks only).

I think maybe this is a bug that will not be high on everyone’s priority, which is a shame as it’s really nice using Haiku on this machine! Is there anything I can try to improve things?


#14

Patches welcome at review.haiku-os.org :wink: