Wifi is a little unreliable on my laptop


#1

hi all, i noticed that wifi is a little unreliable on haiku to me, for example it does not autoconnect at boot and sometimes drops the connection, i assume due to not finding it (maybe cause of poor signal in haiku, since in fedora linux is working very well)

any way i can solve that?or even help debug those problems? :slight_smile:


#2

which wifi device have your laptop ?

See listdevices command output.

Could be that the driver, from BSD, is an old one, and lack some change which improved stability. And/or the loaded firmware is not the latest one.


#3

don’t know the exact model but it is an atheros wifi module…


#4

I think a number of us still have trouble with Haiku WiFi. (I have an iprowifi4965). See Trac bug #9694. Depending on the hrev I’m using at the time, it may or may not autoconnect (my latest seems to, but my default earlier one doesn’t) so if necessary I just select it from the list in the Taskbar. It is liable to go away after an hour or so, and I can’t get it back without rebooting. Linux on the same laptop doesn’t fail.


#5

For what it’s worth, I routinely use Atheros wifi, and it doesn’t give me any real trouble. It does seem though that device initialization is a little sketchy. wifi “scan” doesn’t ever change anything - apparently the server broadcast list is stored in device memory and won’t be repopulated until the device is powered down. Occasionally the join will fail, for some reason. For all that, though, it really works fine every day.

[Edit] So of course it trips up the next morning: a dialogue box appears, with the correct wifi server name and password, but not set to WPA/WPA2 as it should be. Fixed that, accepted the dialogue box, and all was right.

This has happened before. The context: I have a wifi script in config/settings/boot/launch/, that sets up the connection. I wonder if I’m going there too soon, and sometimes interrupting the initial scan. As of today, the script waits for 2 seconds before ifconfig, maybe that will help with this occasional problem.


#6

You’re having better luck than I am. I have an old WinXP era Dell with iprowifi2200. WiFi was extremely buggy until I did the ifconfig -ht hack. Then WiFi worked better in Haiku than in either Linux or Windows. That is it did so for about 4 hours until I shutdown. Upon and since the next boot, I have yet to duplicate that blissful experience no matter what I’ve tried since. WiFi still works fine in Linux and WinXP.