What happened to KOffice and Scribus?

Hi Haiku users and devs

I’ve not tried Haiku in a few years so I thought it was time to try it again.

The major new feature to have arrived since I last tried Haiku is Haikudepot. I was pleasantly surprised to find LMMS - one great Qt app that I didn’t know had been ported to Haiku - but disappointed there was no KOffice or Scribus in Haikudepot.

Why not? Bit rot? Do they now require a newer Qt than Haiku has available? I suppose those who aren’t happy with using Google Docs , Office 365 etc will have to wait for a Libreoffice port.

Thank you for the link.

Kind regards.

I think KOffice had a lot of dependencies on the KDE platform that has not been maintained or supported on newer versions of Haiku. And now Koffice is a dead project and not supported any more. So we still need a good Office productivity platform for Haiku. Google Docs works ok in the Haiku browser for basic work.

Oh yes! I forgot - KOffice is called Calligra these days.

Calligra isn’t dead, it had a new release less than a month ago. I’d prefer a LO port but I would’ve thought Calligra would’ve been easier - especially as KOffice has already been (mostly) ported in the past.






Thanks for the links kim1963!

I’ll try that Scribus package out soon but is there any reason anyone knows of why its not available from Haikudepot yet? Maybe there is a lot of extra work to get things packaged for the depot?

TFO = JAVA = :confused:

Its better than having no office suites though so I’ll prob try the demo.

I found Scribus here: http://haiku.uwolke.ru/repo/binaries-x86_gcc2/packages/scribus_x86-1.4.5.svn.go-3-x86_gcc2.hpkg

I’ve just tried TFO by instaling kim1963’s package from here:


Unfortunately Write doesn’t show a page and so you can’t enter any text and neither the menus nor the cells get displayed for me under Calc.

ThinkFree don’t seem to officially support Haiku or BeOS so we’re probably out of luck unless someone can fix the JDK port so it all works properly.

I’ve just had a quick look at Scribus and that seems to be working fine. Its definitely one of the most impressive Haiku apps I’ve tried so far but sadly it can’t import Opendocument (.odt) or Office (.doc, .docx) files which is what I expected, to be honest. It can however import PDF, OO/LO draw and Illustrator files so thats handy to have if less in demand by the average user.

It seems Sum-It has some support for importing .xls files but it hasn’t worked well in my (limited) testing.

It would be great to see Sum-It get improved to the point where it can at least load and correctly handle the majority basic spreadsheets. I’m not talking about achieving parity with Excel or even LO/OO Calc but just be able to cover the basics.

Haiku’s limited developer resources are probaby better focused on a LO port but I think many would still like a lightweight, open source and native Haiku spreadsheet which is what sum-it could evolve into if somebody put the effort in.

I’ve got Abiword to build with gcc2 using Haikuporter but it has cursor display / redraw issues and it crashes whenever I try to load a doc or docx file, which was the main thing I wanted it for.

The Abiword port you compiled is a attamp to port a 2.8 version with mainly the base from abiword 1.0 and before… There are lot of bugs and odd stuff in there (eg. the dialogs are loaded from flatterned archives - and not constructed via code)

Some people already trying to bring it to a usable stage:

You can help with creating bugreports
I tried to use Abiword on Windows and linux… i am not shure anymore if its worth the work. Even on linux and windows there are bugs open since years.

Anyway the loading file problem should be solved… in this branch:

But there are still a tons of issues wich renders it unusuable. As i said: its an super outdated an incomplete port.

In the best times (in the year 2000) five people where working on a usable port for beos… and it never was really complete - so you can see how much work it is.

Has any one tryed MasterPiece? It is a markup editor style word processor applcation with a ‘what you see is what you mean’ interface. It can create odt or pdf files.


Thanks for the links. I tried building your fork but it said it couldn’t find fribidibi or whatever but I’ve got both the gcc2 and 4 versions installed and I successfully used them to build the Abiword recipe in ports. From what you say about it its prob not really worth me bothering unless I wanted to try to fix it. It may take more effort but Calligra seems like a better bet to me, plus that’d bring us a spreadsheet.


That’s interesting but not really what I’m looking for, thanks. I’m sure others will find a use for something like that.


If you’ve been reading my other threads on here you’ll have spotted that Calligra looks like a no-go at the moment due to the buggy kdelibs port so I’m back to trying to build your patched Abiword source.

checking for gucharmap >= 1.4… checking for enchant >= 1.1.0… checking for fribidi >= 0.10.4…
fribidi sources can be downloaded from SourceForge


Note: Don’t use the fribidi source which is sometimes
included with AbiWord since that version is for
Windows only.
configure: error: * * * fribidi >= 0.10.4 is required * * *

However I’ve got all the latest fribidi dev packages installed for gcc2 and 4. Any tips?

Have a look at the config.log generated in Abiword folder when running Configure. There should be more details about why it didn’t find fribidi (what sourcecode it tried to compile, the command line used, and the error message). With these informations it should be easier to understand the problem.

Hi PulkoMandy

Unfortunately config.log doesn’t give any more info relating to fribidi than what I’ve already reproduced previously in this thread.

A buggy word processor is better than no word processor IMO. No-one has suggested any fixes to sort out my display issues with TFO and at least with Abiword we have a chance of fixing issues due to it being open source.

I have exact the same type of problem with one of my notebooks. Its a Acer Aspire 5250 (AMD
C-50/RadeonHD 6250 APU). TFO works on my other machines quite well. I didnt had the time to investigate it further, yet.

Sorry for being offtopic :wink:

You’re not off-topic Gedrin. Anything to do with getting a working word processor (read: something that can load .doc and/or .odt files) running under Haiku is on-topic in this thread as far as I’m concerned.


The fribidi depot packages got updated recently so thats no longer the issue when trying to build your AbiWord fork, instead:

checking for
gtk±2.0 >= 2.2.0
libglade-2.0 >= 2.0.0
… configure: error: Package gtk±2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found Package libglade-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containinglibglade-2.0.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘libglade-2.0’ found
make: *** [config.status] Error 1