Video card supported and working from USB but screen is corrupted after installing and booting

Hi everyone

I got my notebook back after two years on a repair shop (!) and I’m trying to install Haiku on a multiple bit system.

I tried from an USB stick before installing and most hardware work fine (being the webcam the only thing that didn’t work, but that was expected).

The point is, after trying from USB, I shrunk the Windows partition and then from the Haiku Installer I created a BeFS partition. Installation was successful. I had to install rEFInd in order to Haiku to be recognized because GRUB wouldn’t find it.

But when I try to boot, it pases the boot screen flawlessly, but the desktop becomes corrupted (See image).

I’ve tried in both UEFI mode and “Dual boot” mode (the only. In Dual boot mode, the computer does not find a bootable drive. And now I see that the (U)EFI setup does not see Haiku. It sees rEFInd, and rEFInd does see Haiku and I can bout, however (but with the video corruption problem described)

So what can I do?

Thanks in advance.

You can access the boot menu (spam the space bar on your keyboard while booting, just before the bootsplash shows). From there, you can select a specific screen resolution. Pick one that works, and then once booted, go to screen preferences and reapply it to all desktops (this will save it to a settings file to make it permanent)


Mmm. “Exo”… How many Argentines we have here? :smiley:

1 Like

Thanks for the answer. It was solved shortly sorry posting. I think it had something to do with EFI and the USB drive, don’t know why. But I changed from EFI to Dual Bout and now it works. Still would like to know what had gone wrong, though.

The “failsafe” driver is different depending on if you boot from BIOS (VESA driver is used) or UEFI (EFI framebuffer driver is used). That probably explains why it was behaving differently.


It happened again. So turned off, restarted, pressed the spacebar and selected a different resolution… Same problem. I had to enable failsafe mode and select the framebuffer driver.

It’s too bad because the card seemed to be supported. It was identified by the Display dialog as Intel IRIS/Haswell.