Using haiku on hardware


#21

I am currently writing this on my Athlon FX 8-core regular desktop. From a EUFI boot. Huzzah!

Unfortunately, I’m stuck at 1024x768, which would have been spectacular back in 1989.

It’s on an ASUS Formula Crosshair IV. I think. It’s been a while since I put it together.

Anyway, it looks like it mostly works. Sound probably works, too, but I use USB headphones, which don’t appear to be supported.

And Ethernet works, so that’s good.


#22
  1. I’ve run Haiku’s VESA driver at both 1080p (1920x1080x32), 1920x1440x32, and currently at 1600x1200x32 on my monitors. You can change it in screen preferences normally.

NOTE: Terminal fonts get tiny on a 1080p and 2560x1440 resolutions (for known reasons). You can read
things, but use lower resolutions for heavy terminal-related use suggested…


#23

Nah, I can’t. 1024x768 is the only available option.

Which is totally weird because when I booted off the install USB the very first time, it was at 1080 and I was able to change it all the way to 4K.

Ever since then, every boot (from the same USB or the hard drive installation) it’s just 1024x768 as the only option.


#24

If you have a ticket already open…check your syslogs if it is either failing on the higher resolutions or detecting them fine but defaulting to 1024x768.

There is an old trick to create a custom file so you can force your video settings during boot.


#25

Next time I boot it up I’ll check the log and see what it says.

What file needs to be created?


#26

I’ll have to review my old notes. It was similar to this info: https://www.haiku-os.org/guides/troubleshooting#blank-or-corrupted-screen-after-booting

Ask on IRC.


#27

I think this used to be /boot/home/config/settings/kernel/drivers/vesa on the old BeOS. Not sure if modern Haiku still references this file or not. Inside, one would put something like,

mode 1024 768 16

To get 1024*768 at “thousands of colors” as the classic Mac would put it or ‘high color’ as Windows would put it.


#28

I tried that, but it didn’t seem to do anything.

I also tried forcing the fail-safe video mode in the kernel configuration, but that looked like it brought up a 1024x768 screen with a hand cursor that wouldn’t move. And never loaded the Deskbar or anything.

In Syslog, I can see this, though:
KERN: app_server: Finding best mode for 1024x768 (8, 60 Hz, strict) failed
KERN: app_server: Finding best mode for 800x600 (8, 60 Hz) failed
KERN: app_server: Use 2576x1118 (8) instead.

Which seems like an odd resolution.


#29

I tried installing Haiku on a compute stick that I bought especially for the job.

That was an unmitigated disaster. Hateful little ***** at Intel have locked the EFI down so that it will ONLY boot Windows 32 bit or some 64 bit versions of Linux. Now when I say “boot” that’s what I mean. I tried several recent Linux distros and although they generally loaded, they would not install. Out of frustration and desperation I bricked the thing so badly, I had to drop into an EFI shell and reflash the bios.

This really makes my blood boil. I thought I was buying a blank computer, not a Windows machine. This is happening more and more (Google is at it to) and something has to be done. Surely the hardware isn’t THAT expensive that they need to get a kickback from these behemoths?


#30

Does it’s UEFI not allow clearing the secureboot keys? This allows any efi OS to boot … Not just a signed one.

I have a gpd win, very similar hardware with practically a debug EFI… So many options to dork up in it lol. Main problem with it is no screen rotation, and it uses a sideways tablet screen. Also wifi on it isn’t supported.


#31

It’s that bad. I had a tablet PC I tried out for the price (it was really cheap) that behaved the same way. Even with SB off, only certain Gnu/Linux distros would start on it. I’m thinking live images, like Slax 6 used to do with USB, is the answer to getting even Linux on these things.


#32

It’s literally DESIGNED to only boot particular operating systems by the firmware. You can’t get to the hardware settings, except for secureboot keys and such but that looks like it’s for OEMs.

Like @apgreimann I also have a Lenvo (badged by Aldi under its own brand) running a quad-core Atom. Pretty much the same thing. Not quite as painful as I didn’t manage to destroy the whole shooting match and have to figure out how to put it all back (that was just a case of restoring the secureboot keys).

The computestick has a 64bit atom and design but will ONLY boot the 32 bit Windows 8.1/10 OR 64 bit Linux. They have it set for Ubutunu 14 in the bios but I’m done fiddling with this thing. It’s going to replace my ARM media centre and allow me to re-task that for something else. Rather an expensive failure in real terms, since the RPi (or Odroid in my case) is less than half the price of a compute stick and has OS distros dedicated to specific tasks like this.

I switched this thing into “boot 16 bit ubuntu” (there isn’t a 32-bit option there despite this thing only having 2gb of RAM) and it booted Ubtunu… but that’s about all. I hosed the thing trying to force the shim into place so badly that I couldn’t get it to boot a Live OS!

Haiku some way in and then kernel panicked (I had to use safe mode to see that going on). GhostBSD which is a nice easy desktop BSD based on Mate or XFCE if you want to give it a go, failed a few cycles out of the gate due to missing hardware.

These things are seriously locked down and I have to wonder what the legal position is since we’re not really buying a computer as such, rather a device which ONLY runs Windows for all practical purposes.


#33

To the original question:

  • I currently do not run Haiku, still running Linux here.
    I used to run Haiku years ago in qemu (but now I can’t get it to work …)

I’d love to install Haiku on one of my computers though, “full-time”.

But I am waiting until there will be a stable release. It’s not that I don’t love
experimenting but I have gotten a LOT older and my real tinker-days are
mostly gone (I am not the youngest anymore so I need to make “good value”
out of my time).

Using Haiku years ago through qemu was a lot of fun, but I need something
“real”. It does not even have to be perfect - just does the most typical
software that you may use … a browser … perhaps a multimedia player…
a terminal … hmm. That’s it mostly for perhaps 80% … having ruby available
would also be nice.

Anyway, I’ll hope that the Haiku devs can squish any bugs and smoothen the
user experience, before I will do a hd-install on one of my “older” machines
(not that old … from 2015 … but you know how quickly the hardware area
moves).

Edit: That reminds me … about emulation versus the “real thing”.

I have nothing against emulation; I think emulation is GREAT. Dosbox and
wine and lots of things there … but at the end of the day, emulation is
like not the “real” thing. Like it is not the real life. I prefer things to run
on “real” hardware rather than in a safe, bootstrapped, locked down
environment. Linux works on real hardware and I have been using it
since almost 20 years. Am very happy with it too (that does not stop me
from trying out reactos or haiku though).


#34

Haiku is stable at the moment for its beta1 release. :tada:


#35

Technically no… The apis can still change beta just means it is considerd feature complete relative to BeOS… Features are still being added and the gcc7+ compliler will continue being updated untill R1 maybe even after if the ABI doesn’t break.


#36

Using R1B1 on Lenovo R400, all works well, can’t figure out wireless Logitech M305 mouse yet. Also have R1B1 running under VirtualBox on Linux Mint 19 on same machine. I have R1B1 installed on a USB drive and have tried it on various machines for testing purposes to see where hardware support is.


#37

Logitech M305? Doesn’t it have a USB receiver? My m705 works fine with everything I plug it into.

Note there isn’t really bluethooth support yet (its a work in progress).


#38

Yes, it is bluetooth to its USB receiver. I thought the bluetooth function was handled between the mouse and the receiver. Doesn’t the receiver appear as a USB device to the computer? I need to do more research.


#39

Generally those recivers are not Bluetooth just a custom 2.4ghz protocol… Does it have a Bluetooth logo on the receiver? If so that would be why it doesn’t work. If it doesn’t it should work perhaps attach the output of listusb here?

The non Bluetooth receivers just present themselves to the PC as a normal wired usb mouse


#40

Today the mouse is working! Nothing has changed on my end, very strange but hey, I’ll take it.