Using haiku on hardware


#1

I here many people here around just using haiku over a virtual Maschine or Emulation, there other people around here who run haiku on Hardware like me?

  • I run Haiku in a virtual machine
  • I run Haiku on bare metal
  • I run Haiku in both, VM and on hardware

0 voters


#2

Only real hardware for me. I’ve never used an emulator and don’t plan on starting any time soon.

Current hardware:
HP Elite 8100 SFF - everything works except Intel graphics
HP Elite 8200 SFF - everything works except Intel graphics
HP Elite 8300 SFF - everything works except Intel graphics
HP Mini 311 Netbook - no WiFi, no audio, only VESA graphics
HP xw9400 workstation - mostly works, no SCSI, no CD boot
Dell Optiplex 780 SFF - everything works
Foxconn G41MXE SFF - everything works
Asus A8N-VM CSM - everything works


#3

I’ve been running Haiku on real hardware for some time and my main use case for doing this is whenever I need to port, compile and test very large software components. I rarely use Haiku in a VM as a daily driver, but when I do, it is only when I am developing on the OS itself.


#4

Real hardware:

  • A few year old Dell Optiplex i5 / 16GB RAM

Virtual Machines:

  • Too many to count. qemu / libvirtd

I’m not exactly an end user though :slight_smile:


#5

I run Haiku on my primary laptop (ThinkPad E550, from ~2015) alongside Windows, and it works pretty well here (now that I’ve imported the new WiFi drivers from FreeBSD :slight_smile:). I have an older ThinkPad T61 and also a Compaq Athlon XP tower sitting around somewhere that it’s installed on also.


#6

Real hardware only:

  • Hand-build Intel i5 workstation
  • Dell Mini 11z
  • Compaq Presario CQ60

#7

Good day,

I started with Haiku on VBox about 2.5 months ago. Now I am running it on:

  • Sony Vaio VGN-SR19XN, just to play around and check if can use for keynotes, and runs Haiku x64 only
  • Ryzen 5 2400G with 8GB ram, only 4 GB available for Haiku (already ticketed) which I plan to use for some porting/development (yeah, if I first gain the skills), and runs Haiku x64 only (homebrew hw)
  • AMD A8 with 16GB and Radeon RX560 with 4GB which I use to try to make games on Linux, and shares Haiku x64 with Xubuntu 18 LTS x64 and Windows, which I plan to use to learn to code for Haiku (homebrew hw)

Regards,
RR


#8

I have never been very interested in running Haiku in a VM. I am far more interested in seeing how it runs on real hardware. I have two generations of Intel Atom desktops and a couple of Atom based netbooks. I’ve got access to other Intel based desktops and laptops. I’ve tried the beta on the laptop I’m using to compose this (Toshiba Satellite C55B, Intel Celeron N2820 w Bay Trail graphics) and it works except for WiFi.

I’ve also installed it on a desktop based on an Intel DH67GD mobo with a Core i5 2500k. The flash drive booted up fine but, after I installed, the installed version is having issues with the graphics driver. I used the same install media that I used for this laptop which uses EFI while the desktop is set to boot legacy. Not sure if that is the problem.

My most recent attempt to boot on real hardware was a Mac Pro 3.1 (Intel based). These are pretty decent computers despite their age. Very easy to open and upgrade and relatively inexpensive. The older models (1.1 and 2.1) are available at even lower prices but, they ship with 32 bit EFI firmware despite having 64 bit CPUs and architecture. This means that it is not straightforward to run 64 bit operating systems (even Mac OS X) on these machines since the built in 32 bit EFI will not load them. There are workarounds but, it can be frustrating to fight with them.

The one I tried today was similar to one I’m seeing on ebay (US) for $183.58, Buy it Now with free shipping with the description “APPLE MAC PRO 3.1 A1186 E5462 2.80 GHZ/ 500GB 13GB RAM SNOW LEOPARD”. When I held the “option” key down after the POSt completed it showed the Haiku install media as “EFI boot” and when I chose it nothing happened, the computer just froze, display the boot device selection screen. Anybody else trying Haiku on Apple hardware?


#9

I am a bare metal user myself. Started out using Haiku on a Pentium 4 machine with 3GB of RAM and eventually moved on to a Core 2 Duo with 2GB. Thankfully there isn’t much need for huge amounts of memory.

My best Haiku laptop was a Toshiba Protege M200 which got damaged recently. I’ve tried various other laptops but so far haven’t had much luck getting the right combination of working hardware. Hoping to find something portable and maybe slightly newer to Haiku with soon.


#10

I have Haiku permanently installed on an Lenovo x131e, x140e and HP T5710.

I also test it on my Ryzen 1700x desktop (works with debug switches)
And 2500u laptop HP x360, doesn’t work at all… just dead hang right after the bootloader.
Also doesn’t boot on TC1000.

Tyan Thunder 2 ATX + Radeon 9800 + 2x 300Mhz PII + 512MB ram, it can apparently run 1GB of EDO though I need to revive it. It still has BeOS 5 Max on it… it should run Haiku fine.


#11

I just tested the installer on a Dell Insperon 1525 and I got the boot graphic, but then the screen went black and didn’t come back up after that and the CD stopped spinning.

There’s no upgrades or alternate hardware in this machine, it’s stock off-the-shelf. Are there CD boot options that aren’t immediately obvious or bios settings I should change or should I wait longer? I think I waited about 5 minutes with a black screen. if I hit keys, the disc would start spinning again then quickly stop spinning.

Not sure what the issue is here. Thanks for any help.


#12

I run Haiku on both virtual machines (such as kvm/qemu/VirtualBox/etc.) and on real hardware.


#13

Please open a new discussion and/or create a bug report, your aswer does not have anything to do with this discussion jow.


#14

While not the only OS on this machine, I currently have Haiku 64-bit running on it’s own partition on a Dell Latitude D630.

Not the most up-to-date laptop, but it serves my needs. Haiku works wonderfully in almost every aspect but sound (Intel HDA), though once I have time to test the x86_64 OpenSound recipe hopefully that’ll resolve.


#15

I took the liberty to add a poll to your post, lelldorin.


#16

VM all the way. Vmware (meh performance), libvirtd (gooood). I can download stuff without caring, install extra packages and code, port, whatever.

In real hardware, trying to work with it in my laptop:
Asus K541UV _ Intel Core i5-6198DU/4GB/1TB/GF 920MX/15.6"

I need to enable both safe video and safe mode for it to boot to desktop, and have no trackpad/ethernet/wifi/sound (as many people), but runs blazingly fast.

PS: I enabled safe video permanently with the instructions but… can I do the same for general safe mode? :stuck_out_tongue:


#17

Running Haiku on a Dell Optiplex 3020M. Which is a Mini PC.
Works fine, besides of i had to run it in VESA mode :frowning_face:
WLAN and all things work perfect though.

And of course i am running Haiku as Guest with VirtualBox on my Linux Machine :slight_smile:

Oh, i forgot my Toshiba Tecra M9… which works perfect with Haiku out of the Box :slight_smile:


#18

Running Haiku on my Thinkpad X61s and X220.
Using Haiku as my main OS and do 90% of my computer related stuff in Haiku.


#19

Libvirtd - Now that sounds interesting. I’m running Haiku on a baremetal Atom Netbook from about 10 years back (Samsung N150) and it utterly smokes GNU+Linux in every test. It won’t run the internal WiFi which is a drag but not the end of the world. The N150 was never a great machine anyway and this at least gives it a lease of life beyond Windows 7 Starter.


#20

Since everyone is listing their hardware and describing what is/is not working, I’ll shill for Lelldorin and promote his BeSlySAT hardware analysis utility, which you can find here: https://www.software.besly.de/index.php?system=haiku64