Hi, I have looked through and read several Update questions in the forum , but it appears that there is no clear cut way of doing it.

I downloaded the latest nightly update, i.e. Haiku nightly r35864 - x86gcc2hybrid , burnt it to a cd but it failed to boot past the third icon. I then downloaded Haiku nightly r35864 - x866gc4, burnt it and that booted perfectly. I ran the installer and found that my Alpha rc-1 had disappeared and that Bezillerbrowser wouldn’t fire up because of a missing : Libstc ++ .r4.so.
I looked around and found someone had found that creating a link from Lib???.so to lib???.so would make it work. I tried that but it refused to write to the file.
I then downloaded the Haikulauncher and was/am impressed with it.

So, my question is , can anyone offer a good way of updating to the latest without losing what I already have?

One alternative for you could be to install a nightly and then use the installoptionalpackage command from terminal to add the various optional packages/applications. The following command…

installoptionalpackage -l

…should give you the list of available packages.

Download iso, burn it to cd, boot cd and use installer. Or dd image to usb key, boot key & use installer.

Installer will replace the system directory and should merge the other directories but you have to stick with the same gcc version.

Official Haiku releases, like Alpha1, are gcc2hybrid. So, you must use gcc2hybrid (or gcc2 non-hybrid). Updating gcc2 Haiku with gcc4 version is going to cause issues.

The gcc2hybrid nightly should have worked too since the gcc4 version worked. But bugs can occur from code or from different (version) compiler too.

I always boot off the usb or sd card first, and confirm it boots ok before installing it to my main boot drive.

Also, I have run into some weird behavior where the boot fails because it can’t find a boot drive after the third icon on the slash screen but if I go into /boot/home/config/settings/kernel/ and create a VESA file containing the text “640 480 32” the drive will boot fine. Just had it happen to me yesterday on the latest nightly image.

koki, thankyou for the reply. I’m trying to get the installoptional to work , but am getting nowhere. I have used the -help switch but as yet cannot get it to work.

Added: Amazing, yesterday I couldn’t get it to work and this morning it worked first time.

tonestone, thanks for the help.

When I said it wouldn’t boot, I was talking about the CD.

i guess i was lucky. i started with the public alpha 1 i’d put to CDR (i had trouble getting it to boot on this old computer i’m using, but once i removed all the SCSI and put in a second IDE drive and replaced the CDR drive with an IDE version… all was ok),

after that worked on my machine, i saw WebPositive would NOT work on that version of Haiku. i created a new CDR from the nightly builds iso (burned via BeOS R5 included CDBurn app). it booted as a live CD just fine, so i installed over top existing version and it works. Now using Walter Revision 35949.

granted, not knowing how things changed from BeOS to Haiku, i messed some things up later… [hides behind couch]