Today no sound in Beta 2

Asus Laptop FX 705 GM with Beta 2 and all updates.
Two days ago the sound worked good.
Today I wanted to Play some music.
No Sound to hear.
I restarted the media Server. No Sound.
The Asus hast Intel sound.
What can I do?

Does it show up? Do you have a HD Audio option in “media settings” (don’t remember the name of the app)?
You could try also try download OpenSound from HaikuDeport. For me it didn’t work.

If it still don’t work look in our https://dev.haiku-os.org/.If you write ‘listdev’ in terminal you will se the audio “card” and what name and Id it has.

Your ID should be in here if HD Audio shows up. Row 61 - 117
hda_controller.cpp\hda\audio\drivers\kernel\add-ons\src - haiku - Haiku’s main repository (haiku-os.org)

1 Like

…sometime my box just act like yours… but i assume that mybox act weirdly becaues hardware issue… because lately mybox will suddenly shutdown itself (hardware problem)…

my solution just restart media server and plugin… sometime try twice to effect…

1 Like

After work I booted Haiku today. There was an update for Qmplay2. I don’t know if it was the update or whatever else. The sound works now again and I can play streaming radio successfully.
I hope that the sound is stable now. :grinning:

1 Like

On some hardware its necessary to warm boot Haiku (AFTER loading another OS with working HDA drivers, which correctly maps the HDA I/O pinouts). For instance, on my laptop this enables headphone out. For other hardware, it may be necessary to cold boot Haiku for sound to work (eg. my desktop). There are many variations in I/O pin mappings, and our HDA driver needs more development.

Just try warm rebooting into Haiku from another OS if you notice that you have intermittent sound output. Identify a pattern to find what works. Then gather data about your system and report the findings (as a Haiku ticket).

3 Likes

That could be the reason why sounds works after a cold boot. Good to know. Thanks.
I will report.

I booted my Haiku laptop now several times. After a warm reboot I have no sound and after a cold boot the sound works. Strange…
I write a ticket to the bugtracker.

As Zenja says I think some of the pin mapping code in the Haiku HDA driver needs to be improved. I tried to work on it a few years ago but it is quite difficult for me to interpret some of the pin mapping log output, plus I’m not much of a driver guy. I also don’t think the driver handles some of the disconnected pins properly. That’s really important because even the same sound chip can have totally different mappings on different motherboards and if you wire up a disconnected pin as the sound output, well, surprise, no sound comes out!

Linux has some tools to dump the pin mapping which is quite handy. Maybe we can add an ioctl for that to our HDA driver and write a command-line tool and maybe even use the same output as Linux to make it easier to do a diff between the two.

I did think comparing the output from Linux with what our driver does could be useful to see what needs to be corrected.

For now the main thing we have is the log items in /var/log/syslog which begin with “hda:”. Please be sure to attach that portion of the log to any tickets. It could be there multiple times from previous boots so find the latest entries and maybe see if the output changes for cold and warm boots (it probably does given the situation here.)

3 Likes

Because Haiku is still in heavy developement, it will happen often that things work today and not tomorrow. So be carefull when updating!
More over If you use Haiku nightly!

Do not expect Haiku to be stable after every update!

At least it is very easy with Haiku to go back to previcious hrev-states by fast hitting space bar at boot process to get into the bootloader and select your successful Haiku-hrev version there.

Look into the user guide how to do that.

1 Like

My MSI Laptop has only headphone out, Equal cold or warm Boot.

Your Explanation makes for me some issue clearand i hope the haiku-devs will find a solution for that.

Best wishes

Booting another hrev is no problem. I know that Haiku is in beta state. For that it works very well.

1 Like

The command line tool was good to have because I only have headset output and don’t want to use it all the time.