Thinkpads compatible with Beta2?

I’ve tried a bunch of Thinkpads that I own but all of them give me a kernel dump when I try to boot from the ISO. I’ve tried both burning the ISO and using USB.
So far I’ve tried x270, x250, x230, x220, T440, x31, and an x32.
If you’ve successfully installed Beta2 on a Thinkpad, can you let me know what version you have?

T450s here - x86-64. No problem running it - essential stuff works, including wifi, but as has been the case all along, the trackpad is a too sensitive and easily freaked out, so when possible I block it off. The “trackpoint” works fine.

hmm… the t450 and x250 are the same generation and mostly had the same components… did you use a USB stick or USB DVD drive to install Beta 2?

Stick. dd copy. I tried the “use DriveSetup to make a volume” option, but couldn’t get anything that would boot that way. That isn’t your problem, of course.

You’re installing the 64 bit version?

yea 64 bit. I even tried the 32bit as well. Whats weird is that I installed Beta1 on my x31 without any issues.
I might try the old trick of popping the drive out and hooking it up on my desktop to install.

New guy here. I have Beta 2 on a ThinkPad T61, and everything works very well. Haven’t tried the thumbprint scanner though, haha.

All of those should work. What is the kernel panic, please?

It’s the one I’ve seen others post thats caused by not finding any boot partitions.
My guess was that it was a problem with the USB driver in some way. I know on FreeBSD every once in a while when booting from a USB, the device doesn’t settle enough for the switcheover to happen so the device isnt available when the kernel/initrd tries to hand off to the userland for the rest of init to continue, I had to add a small timeout. Idk if that’s what’s happening here or not.

I am not familiar with all these Thinkpads, but if they have USB3, it is usually better to use USB2.

I’ve just loaded Beta 2 onto the ThinkPad 570E that Scott gave me long ago to try Haiku on. Installed without problem, but I had the advantage that it already had older Haiku (pre PM) on a couple of partitions. I had Beta 2 loaded onto a USB stick (bootable on newer machines but not on the ThinkPad) so I just installed from that onto one partition using the Installer in the other.

Although the systm is solid, both HaikuDepot and ftpPositive are failing strangely. They connect, but don’t show very much of the contents of the target. Actually ftpPositive is fine connecting to my Pi, but doesn’t work with another Haiku machine!. Odd.

Oh…yeah. It’s running in 191MB of memory! So it’s a mite slow, with lots of swapping. I’ve upped the swap to 3GB+, so things like Ruby run. In the end it’s not even intolerable… :grinning:

Adding some other points later… I forgot to mention one important failure – WebPositive doesn’t run because the CPU doesn’t have SSE2! Shame. OTOH, HaikuDepot now seems to be fine after I gave it the extra swap. ftpPositive still won’t connect to my other Haiku box properly – seems to be totally garbling what it reads…

x230 here, no problem

1 Like

Despite being eight years old, the X230 is almost a modern computer, and a very fine one.

1 Like

Have you tried the different USB ports. My System76 only boots Beta2 from only one of the three USB ports. Before the Betas I could boot from any of the USB ports, I don’t know why.

It’s running “smoothly” on a X31 here. But i have to admit, that there was trouble with the installed wifi-card first.

I am writing this post from a R60. while listening to a youtube video on the other tab (so much for the "we-need-a-real-webbrowser-guys) :wink:
Works great for me - but my Wifi reconnects every now and then. I remember there was a fix for this problem…

If this happens with every single device, the problem may actually be with your USB stick somehow, i.e. some kind of incompatibility…

Typing this from Beta2 installed on Lenovo G530, which is basically a ThinkPad. WiFi does not work, (Haiku still doesn’t have the driver for the Broadcom BCM 4315), but everything else works, even the video driver.

It was a while ago but I had a Lexar USB that would not boot Haiku, but the same image booted ok on my SanDisk USB sticks.

I’m running a brand new Beta 2 install on a Frankensteined ThinkPad (cobbled together from parts of an X200, 2 X201 s and a T410s). I installed it from USB. The USB drive was a repurposed Dell branded Microsoft Windows 8.1 factory recovery media 8GB USB stick which turned out to be a Toshiba 8GB USB flash drive when I broke the read only lock on it. I have to agree with the others assessment that your USB drive is likely at fault. I usually use a USB 2 drive for Haiku install media.

On a sidenote, I’m really liking the fact that my Beta2 install is on a SanDisk 32GB SD card on this notebook as it allows me to easily dual boot to Qubes OS 4.0.3 on the internal SSD.

I think I want to scream in public!:angry:

As I said last night, I was getting a 570E all set up with Beta 2. It all took me several days, but I finally got it set up with all my utilities and scripts and so on, and was satisfied. Then I turned it on one more time…

No bloody display!! Seems (from das Blinkenlights) that everything is running, but the display is black. Ultimate frustration.