Sound on the Lenovo X 220


#1

Hello

I bought a used Lenovo X220 as it seemed Haiku compatible.

I installed Haiku, updated it regularly, but can’t get a sound

listdev shows

device Multimedi controller (Audio device) [4|3|0]

pressing the physical buttons for disabling/enabling the sound has no effect
pressing the physical button for sound low or high has no effect

when I try to install OpenSound in Haikudepot, I get an error message

Fatal error occured while installing package opensound: Failed to download package opensound.

but I am connected to Internet, as I can update Haikudepot or use any browser.

Thanks for any hint


#2

You can download it manually:
https://depot.haiku-os.org


#3

Yes, you need opensound to get sound working on the X220.


#4

I have installed it, rebooted, but still no sound, either playing with mplayer a video from a USB disk, or in youtube.com or allocine.fr

in mplayer, the sound is at 50%, still no sound if I put the gauge higher.

Any ideas?

Thanks


#5

Try with headphones, and check the mixer… IIRC with opensound there may be many options there, could be some need un-muting. But also perhaps @PulkoMandy can advise as he has a similar (the same?) laptop I believe. I have an x240 here, where I’m fairly sure sound worked fine last time I tried.


#6

Did you blacklist hda driver?


#7

You need to blacklist the HDA driver first, and then yes, you may need to tweak the outputs in Media preferences.


#8

no sound in the headphones

how do I blacklist the Hda driver?
a doc on that topic?

thanks


#9

First link on google search:

https://www.haiku-os.org/guides/daily-tasks/blacklist-packages/


#10

thanks

in

I see 4 dots, in the doc I see 3 dots after

entry blacklist

I tried both but still no sound


#11

You’re looking at the first code-box in the docs which gives its syntax, where “…” stands for optional additional entries. The next code-box and the following example show the actual usage in an example.

In your case the text file /system/settings/packages that should read:

Package haiku  {
	EntryBlacklist {
		add-ons/kernel/drivers/bin/hda
	}
 }

#12

thanks humdinger

done it, rebooted, still no sound


#13

in fact I have sound, not very high, but it works.

I guess I need to check the various gauges.

thanks to all


#14

I just tried this in my X220. If the audio is stuttering, in the process controller widget -> Threads and CPU usage -> MediaPlayer -> MediaPlayer or MediaPlayer audio ou controll and set it to real-time priority.