[Solved] Installed successfully but Haiku boot menu needs my help finding boot

So after a full weekend trying to get the system installed (the easy part) and booting from hard drive (the impossible part until I replaced GRUB 2 with rEFInd), I’m able to (finally!) boot Haiku from hard drive.

It’s installed in its own BFS 32GB partition, no warning or error whatsoever during install. rEFInd detects Haiku, but when I try to install Haiku, almost every time I’m greeted by Haiku’s bout menu, and I must manually select Haiku’s partition (default is “None”). Partition is there and seems to work just fine. There is a “latest state” option along with a saved state from each of the few boots (just finished interesting last night before going to sleep). It started from first boot, so I guess the problem originated during installation. Or maybe rEFInd (installed later, because GRUB 2 wouldn’t find Haiku) broke something?

1 Like

please open a ticket at https://dev.haiku-os.org

1 Like

I wonder if you are suffering from the same problem I used to have.
When I originally installed Haiku I reused a partition created using linux, re-formatting the partition with Haiku’s DriveSetup.
Every boot I had to manually select the state I wished to boot.
I came across a thread by javanx in which he mentioned problems because the partition type was not correctly set.
I created some free space on my disk, booted into Haiku, started DriveSetup and used it to create a new partition and format it as Be File System. Used Installer to copy/install Haiku (with all my settings and files) into the new partition.
Next time I booted my computer I didn’t need to make a manual selection.

1 Like

This problems happen when your partition is not set to the correct Haiku/BeOS type in the GPT partition table. You just need to change the partition type, but deleting and recreating the partition in DriveSetup will also fix this (just reformatting won’t).

1 Like

I had created a FAT32 partition with Windows 11 drive and position manager, then formatted to BFS with Haiku DeviceSetup. It’s a 32GB partition, because I think it’s more than enough, right? Type: Be Filesystem, cluster size: 2048.

I’ll start over. I have a question, though: Should I delete the folders I’ve created (/Haiku) and files (bootx64.efi) I had copied to the EFI partition before reinstalling? I mean, should I delete them now and then create the folders and copy the files after installing and before first boot?

Sorry for asking such stupid questions. I’m more familiar with BIOS/MBR than with (U)EFI/GPT.

It is better if you delete the problematic partition, and recreate it with DriveSetup.

As for the files in the EFI partition, if they are in the right locations, you can leave them there. No need to delete then copy them again to the same place.

1 Like

It’s fixed now and works fine. I followed your advices , removed the partition and re-created it using DriveSetup. Then installed Haiku

Thanks everyone! What an amazing community!

You can mark this as solved.


I followed this instructions.
Now Haiku boots without problems.
But Window 11 does not?
Do I need to reinstall Window 11?
It should be still there on its own partition!

Where do I get a good tutorial to multiboot Haiku with refind?

I like to add a partition for Linux later… Or maybe better get a own drive for Linux will mak it easier!?

For now I would be happy to get Window 11 work!

Refind is extremely well documented, and nothing special is needed for Haiku support. So you can follow the official rEFInd documentation.