[SOLVED] How to use entire usb stick space when installing haiku .iso on it?

I discovered very early this morning that my new haiku install on a 64Gb memory stick was only using a tiny fraction of the stick. so on rising this morning i put it in the linux box where i created it & have been trying to get the install to use all the stick. i can’t.

When i installed yesterday i used the MX Linux Live USB Maker (which only works live with MX). It removes a lot of configuration options if you aren’t making an MX stick.

So then i tried using dd as follows:

sudo dd bs=4M if=haiku-r1beta4-x86_64-anyboot.iso of=/dev/sdf status=progress conv=fsync

I still only got ~1.5Gb of partitions size.

How do i make haiku use the entire stick when it is installed to it?

If there is somewhere that has all of this info’ in an easy to understand style, then please point me to it?

thank you

1 Like

you need 2nd flash disk to install haiku into it… after finish you use the 2nd flashdisk…

OK, so you install from one to the other. i have never needed to do that before. i will see how i go. thanks for your reply. :slight_smile:

yes, after that test the 2nd flash, if ok, your 1st flashdisk free and can be use for other purpose

I just read a longish thread where someone was having trouble (last year - you did make a post or two in that thread as well). At the end was a link to this page:

Which i had skimmed prior to installing, but now i see that there is info’ on using the entire destination media. so it should translate to another usb stick fairly well (hopefully). I know about the the “boot” flag, so with a bit of luck i’ll end up with a bootable 64Gb stick. which will do for the time being.

thanks again for your assistance. :slight_smile:

Well, i’ve installed from the 64Gig stick onto a 120ish Gig stick, & i can’t make it bootable. no option in the drivesetup.

when i look at the stick via linux, it is befs; little-endian; Haiku; 114.7G available.

When i look inside it, it has
/home ~38k
/system ~720.5 Mb
/trash 0

So how do i set the boot flag? GParted doesn’t know what it is looking at & says it is only ~7Gig in size. so i’m lost.

I think perhaps the problem is that it was initially formatted & setup with ext2 fs & perhaps it has somehow interfered with the process.

I primarily use the Installation Guide when going through the process.

Note: i just tried to 0 out the drive so i could start again, & its talking about the 7Gigish size again (which never existed previously). I did the following:

sudo dd if=/dev/zero of=/dev/sdf

After doing that when i looked inside, nothing had changed. I then manually tried to remove the contents, but it is beyond the administrator rights of linux.

Then i went back to gparted & managed to get it to put an msdos partition table on it. this gave me the ability in haiku to actually get the stick back to a raw state. then i could initialise it; partition it to its full size; format it beos - 117Gig.

After which i could install. all done following the installation guide.

it won’t boot. is not seen in the bios, & when i look at it from linux, it still has this 7.7gig size & the same content as previously stated (which is likely what should be installed).

Looking at it from haiku (booted from the 64gig stick), it is the correct size of 115.38gig, but it is missing the win32 efi partition. it has all of the flags except the boot flag?

I expect someone will come along to point to the documentation for bootable Haiku setups - you may have to re-do the installation with an EFI partition, as in https://www.haiku-os.org/guides/uefi_booting , plus run makebootable.

Or you could just use DriveSetup on the same USB install you’re running, and add another BFS partition that uses the extra space.

1 Like

Thanks for your reply. I’ll have a look at the linked info & see what i can do with it.

There isn’t really any space apart from that unused in the one, 100+ gig partition.

NOTE: makebootable is not for use with UEFI booting (i’ve learned).

? I don’t follow you here. What I mean is, you have a working install on a 64Gb space, whereof only 1.5Gb is in active use and the rest is unavailable. DriveSetup can put a BFS partition on that 62Gb leftover space, and then you can use it. This is all on the install USB we started on.

I’m trying to put a working install on one partition (well 2 if you count the 64Mb efi partition) that is ~115Gig in size.

When i was trying to install software last night on my 64gig stick (i didn’t realise at the time that i only had a the tiny partition that comes as default) i very quickly ran out of space. which is when i discovered the size.

So are you telling me that i can install applications onto a 2nd beos partition on the same stick? i wouldn’t have thought that possible.

Also, i have gone through the process of creating a 64Mb partition for efi. i then installed (haiku once again, in a blank unformated partition that i made with gparted. which i think was an error, as after the installation the befs formatted partition is considered to be a linux partition & it was also not given the boot flag…

i created the directory structure in the EFIBOOT partition & copied the haiku.efi file into it.

So, now i’ll delete the large installation directory & try to make it again in a way that gets the boot flag & is considered to be haiku. I’m not too far from just saying bugger it, i’ll wait for R1 & try again then. :slight_smile:

Now at least the ~115gig stick is seen by the bios. but it still won’t boot. so i’ve spent 10hrs on this. i reckon i have better things to do with my life.

If i put a 2nd befs partition on my 64gig stick so that i have the live 1.4gig partition on, can i get the live partition to save apps that i download & install, into the new partition?

I doubt it, but i have to ask the question.

This is me clutching at straws.

First, if linux fdisk sees it as a 8GB drive, maybe it has some problem. Increased if you cannot zero out it from dd ( as root, preferably ) .

On the chance it is just some linux oddity, can you try this :

  • Create the haiku usb disk in the 120gb ( is it really 120 ? not 128gb ? Which brand is it ? ) . See if it boots.
  • If it boots, with both disks connected ( 64 and 120gb ), booted to the 120gb haiku , run the installer to install in the 64gb disk.
  • on this, IF your system uses EFI, use drivesetup to create the efi partition ( 100mb, formatted as fat32 ) .
  • create the partition for Haiku ( type BeFS, then format as BeFS )
  • now installer will show this partition as a possible destination to haiku. Install it there
  • If need to use EFI, follow the instructions on the links above to copy the efi bootloader to the efi partition, in the correct folder.
1 Like

Yes, if you want a USB with one big partition, that probably has to be done by Haiku running on a separate device. I mean, it would be fun to play around and see what’s possible, but this is the main chance.

I’m unclear on whether you tried to dd the install disk to the 120 Gb USB, and if it worked. It should, of course. If you do that, and the same with the 64 Gb, then it seems to me you can run the install from the larger to the smaller, and it ought to just work - the 64Gb, having already been set up to boot the install, will be able to boot the newly installed image just as well. Clean dd copies on both USBs, please, no gpart or anything. This is just a way to use a preconfigured bootable setup if that’s what you need.

When you do that install, of course you’ll have to reformat the partition - it won’t automatically know you want to use the whole area. Just leave the FAT partition where it is.

[ edit — maybe never mind this. I went and looked at my own install USB, and the partitions were laid out differently than I expected, with the BFS first and then the FAT. That introduces some doubt in my mind about how well my idea would work. I thought the EFI partition would be in front. ]

1 Like

I’m stuck with one tiny partition with a working bootable haiku that is so small i can install next to nothing on it before it is full. a bit of a shame that. no one can say i haven’t tried… lol

i don’t want to put haiku on a HDD, i just wanted to be able to install some software & use it. as it is it is just something for me to look at & fiddle around with, beyond that it is still useless to me.

Does your system boot via EFI or legacy BIOS? If the former, you need an EFI partition, and you must use GPT partitioning, and make sure the GPT partition entry for Haiku has the correct type (if it doesn’t, the EFI loader won’t find it; but if that’s the problem, you’d at least get to the Haiku loader screen after the BIOS.)

If legacy BIOS, you want Intel partitioning, and make sure to set the “Active partition” flag.


thanks for your reply.
I’ve tried (more than once) both ways of setting up the stick. I can’t get the bootable flag (from what i read it is supposed to happen automatically?) i haven’t seen anywhere where i can set it?

I tried to use the makeitbootable (or whatever its called) command, that didn’t work. it did not make it bootable.

It would seem that the failure is between the efi partition & contents & the main partition. Somewhere, related to that, i must be doing something wrong?

I follow the guides, i intitialise the stick as GPT, create the efi boot partition & structure as told in the guide. create & format to befs the main partition. install to it & then find & copy the appropriate file into the depths of the efi boot partition’s structure, as told. (i have also tried putting the file in prior to install, makes no difference.)

reboot & look in the bios & the stick is seen, so i can set it to be booted. Then reboot & it won’t boot, i go to the MX linux grub menu instead.

The above is the best result that i’ve got, as at least the stick is seen by the bios after installation. so yes, it needs to be gpt/efi system used. beyond that i’m chasing my tail.

Just to verify… Did you also rename the file to bootx64.efi when you copied it to the EFI/BOOT subdirectory?

If you want to use legacy/MBR booting and you have zeroed out the drive then it may be necessary to write a new boot sector using the writembr command or the “Write boot sector” menu from the Installer app, as described near the bottom of the user guide page.