SoftwareUpdater not working


#1

Yesterday I called the SoftwareUpdater at a modern machine.
And it worked, I got a lot of updates.

But the same procedure on 12 year old laptop HP nc8430 is not working.
I get the message
refreshing repository ‘HaikuPorts’ failed.


#2

Do you have the right Server data for the current repos in this haiku Version?
Is your network card supported?


#3

My ethernet connection is ok.
my wifi connection is now working sometimes.
There are sporadic drop downs.
I downloaded the R1/beta1 version 64bit from 09/2018.
What are the right Server data for the current repos ins this version?


#5

Try a nightly build. You can install it directly over the beta without having to start with a fresh partition. Just choose the partition you installed the beta on to as your destination in the installer. Doing it this way will preserve any settings you may have already set on your current install. https://download.haiku-os.org


#6

Take a look here: IMPORTANT: Repository changes


#7

I tried it. But no success.
I downloaded the nightly build. I started from the usb-iso.
The normal installer did nothing after I pressed the Begin button.
With and without internet connections.

I there a date problem? because this ancient laptop has a wrong bios date.


#8

Make sure your bios time and date is correct. HaikuDepot/pkgman uses SSL, therefore won’t work with wrong system time/date. You may have a dead cmos battery. If that’s the case you’ll have to set the time/date manually after every hard power down/ reset until you replace your battery.


#9

After hundreds of cmos changes and following date settings, this is the first laptop without a set date menu. HP nc8430
I put a new cmos battery in the laptop.
I just changed date and time by Haiku Time menu.


#10

Did that solve it?


#12

Open the terminal…
and type: pkgman drop Haiku; pkgman drop HaikuPorts
choose yes and then type:
pkgman add https://eu.hpkg.haiku-os.org/haiku/master/$(getarch)/current
choose yes again and then finally type:
pkgman add https://eu.hpkg.haiku-os.org/haikuports/master/$(getarch)/current

No! Don’t do that :slight_smile:

“I downloaded the R1/beta1 version 64bit from 09/2018”
Don’t mix nightly and R1/beta1 haiku repositories.

If this is indeed R1/beta1:
pkgman add https://eu.hpkg.haiku-os.org/haiku/r1beta1/$(getarch)/current
pkgman add https://eu.hpkg.haiku-os.org/haikuports/master/$(getarch)/current

The package repositories that were configured during the installation of R1/beta1 should still work. Since they’re “stable” i’m definitley not breaking them any time soon :slight_smile:

I downloaded the R1/beta1 version 64bit from 09/2018.
Take a look here: IMPORTANT: Repository changes

That only applies to nightly installations. It was also pre-R1/beta1.


#13

It also has been a while since we cherry-picked updates to the R1/beta1 haiku branch. HaikuPorts updates will occur all the time, core OS updates are more seldom and reduce in frequency the further from R1/beta1 we get.

We’re planning on a R1/beta2 to come out “before 2019 is over” :slight_smile:


#14

The only thing that saddens me about this is the inability to assign more than one of my likes to it.


#15

Here’s a non-original idea… How about letting people pick the individual updates they want to install? That way, if one of the updates is causing a failure, they can still update the rest of the modules w/o trying to keep updating 15-40 modules all any once. Maybe adding a checkbox or an option to choose some or all updates?


#16

This could possibly work for packages that aren’t in the base install. But there are quite a few instances where an updated package depends on the update of others. This could get a user into a sticky point where the package(s) that are wanted to be left as is get broken by packages that are chosen to be updated. I could be wrong, but I don’t think that I am. Allowing this would require the user to be knowledgeable of individual dependencies. I know, it’s a double edged sword. Damned if you do, damned if you don’t.


#17

Ok, here’s something I just tried - I have R1 & build 52369 in VMWare on my 5K iMac. Build 52369 just updated 79 packages to 52801. R1 tries updating 15 packages and fails on ffmpeg or LibraOffice (if it gets that far). Both of those same packages were updated fine as part of the 79 packages, and they updated noticeably faster! I thing there’s a bug in the R1 updater right now.


#18

Could be a admin option to left some update away. A admin should know that He do.


#19

Not original at all. :slight_smile:
See ticket #14427.

Until then, you can specify the package to update with the commandline tool “pkgman”. Of course that’ll also update the package’s dependencies, if needed.