Shutdown power off problem

Power off freezes the screen after a few seconds
and nothing happens.
I tried the shutdown command on the terminal, but
It didn’t work, either…

This is because transmission-daemon is still running. By default, Transmission doesn’t shut down the daemon when you leave the interface. This allows you to keep on receiving or seeding when you close the window to do something else. There is certainly an option in Transmission to stop the daemon when you quit.

“There is certainly an option in Transmission to stop the daemon when you quit.”
I can’t understand this.
Please explain.

On Desktop tab, chose, Show Transmission icon in systray, it helps to see things.
To close Transmission completely, you must click on Quit in the interface menu. If you click on the square in the tab, it only closes the interface. As a bonus, you will be also able to quit it from that systray icon menu.

1 Like

I cannot find “Show Transmission icon in systray”
on the desktop tab.

Because you’re looking for it in Haiku, not in the app settings.

where are the app settings???

Open the Transmission app. In the menu, you will find something called Modify. Below it, there will be an entry called Settings or Preferences (I don’t know which one exactly, I have interface in French.) If you click on that on will have a window with seven tabs, the first is about speed. Desktop is one of the last.

This said, the daemon shouldn’t crash either on quit. You may want to open a ticket about it on Haikuports bug tracker.
For info, This is a list of known Transmission bugs. Some should probably be closed.

1 Like

There was no “Transmission icon in systray”
so I pressed
Show transmission icon in the notification area,
the I clicked quit

the shutdown problen WAS NOT SOLVED, though

I don’t understand what the transmission app, which downloads torrents, has to do with the SHUTDOWN process.

It’s simple. When you ask Haiku (or another system) to shutdown, before proceeding and shutting down the system itself (In Haiku case, Tracker, app_server, virtual file system etc), it is asking gently to every applications that are still open to quit.

1 Like

ok, but
I still can’t shutdown
neither with GUI nor with the terminal shutdown command,
problem NOT SOLVED

The strange thing is that
yesterday when I used HAIKU on a live USB stick, on a Lenovo Thinkpad
shutdown worked in two seconds,
today that I INSTALLED HAIKU on a Toshiba
shutdown does not work ?!

If you didn’t run the Transmission program on the USB stick then it shut down fine. Now that you can’t shut down because you ran a buggy program, you are shooting the messenger for telling you that Transmission can’t shut down. To force it off you might have to hold the power button for 5 seconds. Next time don’t run Transmission and you’ll be fine.

The easiest thing to do is to uninstall Transmission. That will solve it.
If you don’t want to do that, and don’t want to click on its icon in the System tray, you can run Terminal, do the ps command, find transmission-daemon in the list, then use the kill command on its process number.

The issue isn’t Haiku, here; it’s Transmission.


The Transmission package declares the transmission-DAEMON (notice the name, it is a non gui program) to be autostarted at boot. This daemon doesnt gracefully shuts down for some reason.
This causes the trouble for you.
If this annoys you either uninstall transmission or try to fix it. You can also instruct launch rooster to not start it automatically, also it is possible to instruct the debug server to ignore the crashing transmission-daemon and not show the “app crashed blabla” window.


I uninstalled Transmission,
but shutdown DOES NOT work
neither on GUI nor on the terminal.
Reboot works immediately, though.

when the shutdown process starts it first says
“dbusdaemon to quit”
then something about the tracker
and then it freezes

when I’m using the internet the message above also keeps appearing

If I don’t solve thw shutdown problem, i don’t think I can use HAIKU .
I don’t want to force shutdown the laptop all the time.
It does not remember the wi fi configuration either and it keeps asking me to verify the password, each time I turn on the laptop.

I feel sad , because I really like HAIKU…

The dbus thing is part of Qt, so you have a Qt based program installed, and I’m guessing it’s one of the web browsers. That’ll slow things down, but generally shuts down properly.

It’s been a while since I’ve seen QtWebEngine cause an issue but, again, getting rid of whatever browser you’re using should clear it up. Although I’m surprised clicking on “Oh no!” doesn’t allow it to finish shutting down.

I’d recommend uninstalling whatever is using QtWebEngine and going with Web (also known as Epiphany).

Also, have a look if something’s in the /system/var/log/syslog (and possibly syslog.old).

When something fishy appears to be going on, I like to have a Terminal open running tail -f /system/var/log/syslog.

Maybe install Haiku from scratch, see if that runs well and then install specific apps you need. One at a time, testing in beween, you may find out who’s spoiling the fun.

tail -f /system/var/log/syslog.
tail: cannot open ‘/system/var/log/syslog.’ for reading: No such file or directory
tail: no files remaining

I uninstalled Web & Falkon (which worked much better than WebPositive)
but shutdown didn’t work,
I may reinstall HAIKU,
or wait for a new version some time in the future.

Anyway, thanks for the help.