RESOLVED THE INSTALL ITSELF -- Catch 22 of -- OLD -- WIFI firmware install and get connected (ONLINE) in Haiku Legacy

Ahoy ALL,

Finally I understood why failes on my DELL Inspiron 9100 laptop.

bug ticket

I got into an infinite loop, a Catch 22 of WIFI firmwares.


Great !!

Can we have europian downloads of nightly images – that would contains such must have wifi packages offline ?

Or at least can someone make available firmware adapter installers those – installs on Haiku Legacy ?

Thanks in advance !!!


What you have to do in case of no internet connection is actually explained in the comments on top of, starting with line 25. You are then referred to Workshop: Wireless networking where you can find the information on how to download the required files manually from anonther OS. Hope that helps :slight_smile:


In case of the broadcom 43xx chip the install-wifi-firmwares script also needs the package b43_fwcutter. You will have to manually download this from another machine/OS too. The URLs are for x86_64 and for x86_gcc2


This has nothing to do with european vs US laws.

The license on these firmware says we are not allowed to do any modifications on them and redistribute the changed version. This is a very bad idea, of course. The Wifi device manufacturers have been notified about it by Linux developers, and for later devices (anything in the last 15 years) they have solved the problem by using a better license. For any device after that, the firmwares are included directly in Haiku and there is no problem anymore.

So, no, no one is legally allowed to redistribute these firmwares in any other forms than what the original manufacturer provides. This is why we made the “install wifi firmware” script, to automate the process of converting the firmware to an usable format. You really have to do it yourself, but you can do it from another OS or another machine.


El kellene olvasni a felhasználói útmutatót…

Ha netán a Broadcom 43xx driver érdekel, jó ha tudod, hogy a termék-nevezéktan nem konzisztens, ez csak nagyon régi wlan chipeket támogat, újabbaknál ne várj csodát. Forumban tudsz keresni beszámolókat.

1 Like

Just tried this in Ubuntu, downloaded and created the zip file, so should be ok. :slight_smile:

1 Like

Thanks for everyone for answers.

@BlueSky for exact links to download hpkgs. I created NTFS and after fat32 partition on SD card to be able to swap files with Haiku and WinXP, but Win refused to give letter to the second ( NTFS ) partition.
Only Haiku Live , the first one, but that is unknown for it, so not possible to copy dfiles on it ;))
I must always use a second thumb drive. Ha-ha.
I love actual IT to be able to become true the Queen song for me :
"I’m going slightly Mad "

@PulkoMandy Pulkomandy for corrected background info - why is it happens this way.
Yes, on DELL Precison (made in 2012) the Intel wifi was recognized, however dropped connection after the key phrase was given :wink:

@extrowerk Just for usual, burned me (rightfully ) :stuck_out_tongue_winking_eye:
However here I’m the newbie, and I try out tips and tricks I got earlier on other platforms… finally I do almost the same as a generic user.

All accepted - I try to resolve manually - Thanks again for all of you.

As I wrote once :
Haiku says and I could find that way in tool or program "Eszközök in hungarian version) - Devices (I assume) " the wifi card was written also Broadcom besides wired net chip.
However on XP the little Icon on Launcher writes always “Intel Wireless 1350”.

So let’see : is this DELL stuff : Broadcom chip or not ?

Here I’m on Fujitsu Amilo Li 1720, so I cannot provide proof about it now.

I tell you a way to solve the problem. I get wlan running on my amilio in the past (think it was Zeta times) and someone help me at the BeGeistert here in Hamburg 2018? But it does not run anymore (why ever).

I found the hint into a other discussion here on the forum, buy the wifi adapter and it runs good for me.


Ta-Damm !


The SD card installed Haiku finally got a wifi access !

  1. I followed the Windows process.
    I got the zip file but -turned out on Haiku - it was empty regarding to broadcom stuff only the Marvel fw archive was in it . It could not download the firmware from there - Win XP - the firmware of Broadcom by batch file also. I had not checked what was in the cmd window.
    I was just happy it had created the zip file.

  2. Fortunately I downloaded the firmware directly and put old_Wifi directory of separated necessary thumbdrive.
    I extracted and first copied to the mentioned thumbdrive, from there to desktop of Haiku, then as a backup copy of it onto befat32 directory on the same SD card from Haiku and from Haiku desktop to the extracted - almost empty - broadcom firmware directory.

  3. For second run the broadcom driver was installed, and after a reboot the WiFi adapter finally appeared in the network connections.

  4. However the Marvel chip support was not important for me it was strange that it was available as tar.gz in the fw install dir. it was not installed as “could not download” (sic!) so somehow the script not checked the availability in target dir. as it did in case broadcom chip.

  5. oh yes I also downloaded and installed fw-cutter package BEFORE the whole stuff, it was also fortunate as seems it was not packed into zip file on Windows.

Thanks for all of your help – now I will test package manager stuff : update - upgrade – what happens.

Also webpositive.

And I will try to logon and write a post from within Haiku.

Dear @lelldorin

offline yab install failed - without reading I tried to associate the yab file but I was not successful or lucky enough - Haiku messages told on gui it is not the appropriate program or regular package.

I assume I should have put files in the appropriate dirs :(( instead.
I check out later to be able to put your repo and do the easier way to install.
Fingers crossed !

I will check this too and ask @lorglas. I mean yabide have the docs as dependecies, but i can be that this package need to installed too.

Ahoy everyone !

The topic title was changed – I had modified.


“Catch 22 of WIFI firmware or how to get Europian nightly image downloads”


“RESOLVED THE INSTALL ITSELF – Catch 22 of – OLD – WIFI firmware install and get connected (ONLINE) in Haiku Legacy”

This was necessary as

one hand :

@Pulkomandy explained
the writers of explicit firmwares do not let to include these older firmwares to include these files into nightly images . Not some US laws or orders. This way no more europian nightly images needed.

the other hand :

The install of Broadcom wifi chip(s) half-automatically succeeded - I could use Haiku UserGuide for Windows users to download and create firmware zip, besides I downloaded original Broadcom firmware directly,
installed 32bit hpkg of fwcutter (the tool of broadcom thatt helps extract firmware to usable pieces to install) of
@BlueSkye given direct links independently earlier - just after R1B3 started first and installed this onto SD card 3rd partition - that one of two I bought to try out Haiku Betas - both.

32 bit - 64bit nightly images of 1-1 :
hrev55733 and (now) hrev55758 images burned onto – 128 GB Kingston SDXC

hrev55733 and hrev55758
Dell Inspiron 9100 P4 laptop computer (2004) - 32bit Haiku -
OK, desktop reached without fails - internet ( getting online ) failed only as old wifi firmware - that finally resolved in R1B3.
Now connection drops just as Webpositive started and I try to reach Haiku website in Haiku R1B3

This way I write Here this post of a

Fujitsu Amilo Li 1720, aka – Amilo_XP from within XP – laptop computer (2004?) - 32bit Haiku -
hrev55733 nightly (just as later hrev557758 nightly, R1B3 as well in case Amilo)
fails to reach Haiku desktop
hrev55733 : using F12 to get optional Multiboot option - that failes as if hrev55733 the image and with the USB SD card reader never happened to enlisted
hrev55758 Haiku 32bit : still not probed fully – boot was interrupted by me due to failing to reach desktop
R1B3 : stops at chip icon I think and “no bootable image found” error message appears

Dell Precison 6700M Intel core i7 3940XM Extreme Edition laptop computer (2004?) - 32bit Haiku -
hrev55733 : desktop reached Intel wifi installed and configured but drops connection immediately after password added and connected
hrev55758 : not probed yet
R1B3 : not probed yet

Dell Precison 6700M Intel core i7 3940XM Extreme Edition laptop computer (2004?) - 64bit Haiku -
hrev55733 : desktop NEVER reached – ALL icons remain grey –
That laptop is actually configured in BIOS using Legacy + CSM in UEFI Bios
and probably 64bit nightly Haiku requires UEFI – that setting not probed yet
hrev55758 64 bit: not probed yet
R1B3 64 bit : not probed yet

32 bit - 64bit Haiku R1B3 images of 1-1
Haiku R1B3 32 and 64 bit images burned onto – 128 GB Sandisk SDXC

Dell Inspiron 9100 P4 laptop computer (2004) - 32bit Haiku -
OK, desktop reached without fails - internet ( getting online ) failed only as old wifi firmware - that finally resolved HERE in R1B3.
Now connection drops just as Webpositive started and try to reach Haiku website in Haiku R1B3.

IDEA – to have shared NTFS BeNTFS) or shared FAT32 (befat32) partition on the same SD card – FAILED, as Windows NEVER gives drive letter to secondary but the first partition on removable media - at least XP %
I don’t remember what happened on Win7 or did I check it now with install images.
That failed to check out BeFS partition as Windows just wanted to format them when I attempted to see what can I see on it (there’s no BeFS.IFS yet )