Resize Parallels VM

Here is my situation. I have an existing Haiku VM running in Parallels (current version). However, I’m running out of disk space.

Using the normal disk resize in Parallels corrupts the disk.

So, I tried doing a new install following the instructions on to do so. Getting the any boot image to boot worked perfectly. However, I then tried to install it on a VM drive that I created and attached to the VM. Everything went fine, until I rebooted and tried to boot from this new install drive.

Screen Shot 2022-01-19 at 12.35.35 PM

I can’t create a new VM drive that boots. Has anyone had any success with this? It obviously worked at some point, that’s how I created the original VM, that is larger than the any boot image.


First, you can not resize a BFS partition iirc.

So you need to create a new one, inizialise with BFS and copy all files to the new one.

I did that…same result. Is there a trick to this?..thanks

I would create a whole new disk image, attach that to the VM and then create the correct partition scheme (GPT or MBR) for the desired boot method. I recently discovered the wonders of booting EFI, so yeah… it is not straight forward in Haiku yet. When you have the scheme sorted our, initialise the partition for BFS and use the installer to copy your current install there.

For MBR (32bit) you just, take the drive, partition it MBR and create one partition, format that to BFS and install. I guess you might need the bootman too, but I think if the part ion is active it should be okay,

For EFI (64bit) I had to create a GPT partition scheme, create a 256MiB partition that has the partition type set to “EFI system data”, mount the partition and then copy the contents of the EFI partition from the install CD image to it (it is one directory called EFI with a subdir called BOOT and that has the BOOTX64.EFI file in it.) The make a second partition and format that to BFS and install the OS… but do NOT install bootman. Basically this → UEFI Booting Haiku | Haiku Project

The important part is - the installer app should clone the install for you. You might need to copy stuff in home, but that is easy.

So far, no luck…when I try to boot off the new drive, that I just installed from my working drive, it just keeps resetting the VM…in a never ending loop…

Maybe I’ll try the UEFI boot next…

Is the VM 64bit?

Attach a second drive to your VM, start the installer, install to the second drive, unmount the first one from the vm on reboot.

There is no need to manually copy files, Installer will do this for you.

This works for MBR, but not EFI. EFI you need to manually create partitions as noted.

Installer does not create partitions, you have to do this in drivesetup in both cases.

You need to yes, but you need to do more for EFI… you need to create two partitions, the EFI one is a specific partition type and you need to manually copy files.

Aslong as it is fat32 and you just copy the efi dir it should work.

I’ve tried all of this with no success so far…but, I appreciate the feedback. If I get it to work, I will let y’all know the details here…thanks

Yes. I am installing from my current 64 bit Haiku VM.

Do you know if it is booting with EFI? If you re using the original MBR, have you tried installing bootman?

Yeah, I have tried all 3…MBR, MBR with Bootman and EFI…none worked. With the EFI, the partition didn’t seem to “stick” after reboot (very weird)…I attached the drive to my other Haiku64 VM and looked at the drive with drive setup and it shows 2 partitions that were “not formatted”…

Could it be that your version of parellels has a bug and creates broken disk images…?, try creating your disk image with qemu-img and then install haiku with parallels and see if it works

Anything is possible…I am a subscriber, so I have the latest version. It’s worth a shot…thanks.