Problems running emulators on BeOS 5


I had installed few emulators on BeOS 5 including:


I had installed SDL 1.2.7 and x11-base 1.3.

All emulators don’t start except Snes9x, bemastergear and besmsplus (which start).

mupen64 returns message that libz needs to be installed (where do I download it?).


Take it from haiku or search on beshare.

Please choose the Be Inc. category for threads about BeOS.


I installed zlib 1.1.4 and mupen64 still returns error message: missing library-libz 1.1.4.

the file is located at /usr/local/lib


We are not linux :wink: I’m not sure where you got the zlib archive from but from the looks it seems from some linux archive?

EDIT for one the library should be in /boot/beos/system/lib (or /boot/system/lib) (don’t know which path is correct anymore for BeOS :wink:

I had downloaded source code from sourceforge.

I had checked zlib webpage and found that (I haven’t found anything exactly for beos).

Also the error message is missing library 1.1.4, while the compiled library file is libz.a.

I have just found this site for sources Index of /fossils

It’s looking for the shared library, a precompiled version would be hard to find I guess

I had messaged the maker of zlib and he wrote me to download and compile from his sources.

Our port for zlib uses cmake, does BeOS come with that (long time ago so don’t know anymore)
Here is our haikuports one:

you are taliking about zlib 1.2.11 I’m looking for 1.1.4 for mupen64 0.4, not mupen64plus.

Build a shared lib then (possibly some patching will be required). You can also look for lib packs at BeShare/web.

Have you tried to link the newer version to the needed one?

No. I don’t know what to do on that .recipe file?

I had installed mplayer on BeOS 5. I’ve been reading something and it stopped at

So I have, but mupen64 still returns the same error message.

Anyone knows of other dependencies that are needed for the emulators listed that don’t start (maybe SDL-mixer or similar or)?

Would be great to develop an OpenEmu like client for Haiku.

I had e-mailed Mark Adler for zlib 1.1.4 on BeOS 5.

zlib 1.1.4 is almost 20 years old! I only support the most recent version.
All I can suggest is that you try ./configure -s, and then make.

I did that.

Also I’ve read that mupen64 uses gtk, so I installed gtk.

But mupen64 still doesn’t starts ( 1.1.4 is missing).

Also I’ve been trying to copy (which was installed probably with mplayer - I couldn’t find the version number) from /BeOS5/home/config/libs/ to /boot/apps/mupen64/ - doesn’t starts.

I’ve found this on emutalk:

BeBits has version 1.1.4. Sorry to say I don’t use Be anymore since it’s demise so I can’t say if this will work or not, but here is the link

But the link is not working.

On pulkomany’s website I’ve found zlib 1.1.3 but not 1.1.4

I’ve been searching for ‘zlib–’ and I couldn’t find it anywhere.

And finally I’ve got the zlib 1.1.4.pkg for BeOS and I had installed it.

mupen64 still returns the same error message.

You need to copy it to /boot/apps/mupen64/lib/


I just had tried that and that doesn’t works too. mupen64 doesn’t starts - same error.

I had copied and libz.a from /BeOS5/home/config/libs to `/boot/apps/mupen64/lib/.

you can try to create symlink to in the same folder and name it or whatever version is needed. With some luck it could work.

Also since you have zlib 1.1.4.pkg you can open it in SoftwareValet (the default) and in the wizard there will be a step where you can see which files are copied where. Maybe that could be of any help.