Problem with "" in Haiku


I have Haiku hrev52138 on my Dell Inspiron 1545 laptop, dual-booting with Ubuntu Linux. My Haiku system doesn’t have working WiFi and I don’t have access to an Ethernet connection, so I tried using the method that uses a Linux shell script to download the WiFi firmware into a zip file on my Ubuntu system. The problem I keep running into is this: Even after I extract the zip to Haiku’s “/boot” directory, the script “” still tries to download the firmware off the internet, even though the files are already in the “/boot/system/data/firmware” directory. Does anyone know why this is happening, and/or is there a fix?

P.S. My WiFi card is a Broadcom BCM43xx.

If the files are in /boot/system/data/firmware, you don’t need any further steps to install them. If your wifi still doesn’t work, the problem is elsewhere.

that particular card is not working yet, there are several topics about it

Thanks for the responses. To be more exact, my card is a BCM4312 (14e4:4315). I posted a reply to Wi-Fi & Ethernet Testers Wanted, saying that if waddlesplash created an implementation of a firmware version for that card, I would be able to test it on my machine and report back.