PANIC: Did not find any boot partition


#1

I ran BeOS in the early 2000’s; loved it.
Trying to install Haiku R1Beta1 on a brand new Intel NUC 8i5BEH
Ram: G.Skill Ripjaws DDR4 SO-DIMM DDR4 2400 4GB x 2
Hard drive: Samsung 860 evo 2.5" 500 GB ssd 2.5 inch SATA ssd

Downloaded an anyboot 64-bit copy from https://www.haiku-os.org/get-haiku/
and burned to DVD – using Plextor Optical drive in a USB3 enclosure;
then to install .

The install stopped at the 4th icon (Mounting boot disk) and gave us an error report:
(I hope one link opens and shows the image of the error report that showed up on the screen.)

Hope someone can shed some light on what I’m missing.
Thanks

(upload://8a65zrNmHCVMx9cdk4l1YgUWkBg.jpeg)


#2

image


#3

External USB DVD drives are extremely “hit & miss”, doubly so for EFI (actually I think that EFI boot via DVD was not working on the beta image.)

Using a USB stick instead is much more reliable.


#4

We were using Legacy, not EFI.
Ziff forwarded an image of the error report we received.
We have tried installinv via a thumb drive in usb3 and internal usb2 ports as well.
We seemed to get farther into the install on the DVD.

Do we need to partition the drive before the install
when installing on a never-before used hard drive?


#5

For short, yes.

Once you managed to boot your installation image. Partition your new hard drive by using DriveSetup tool (in Applications menu). Detailed instructions are available here.

Best regards
Masaol


#6

OK. Just wanted to make sure we do not need to partition before the splash screen. So far we’ve only gotten to the 4th icon on the splash screen with the dvd.

Attempt #2 USB3 flash drive — got to 3rd icon in Haiku splash screen.
Boot Drive Order: UEFI-USB-PatriotMemoryPMAP (flash drive)
Secure Boot Not Checked

Attempt #3 Same as #2 except used internal USB2 port
Same error message![IMG-0023|666x500]IMG-0023
.


#7

If you want to make certain that the drive you are wishing to install to isn’t the issue, disconnect that drive. Then just try booting from the install media. You shouldn’t have to partition or initialize it before booting the install media. I’m will to bet your problem exists elsewhere.

Have you tried loading the bootloader before booting haiku itself? You can set safe mode options here. I forget which, it’s either spacebar or shift that you hold down while bios hands off control to the boot media. I hold down both and that works for me.


#8

This error message is unrelated to boot media, it’s a page fault in the XHCI bus driver.


#9

@Mary1, this issue was fixed in master but not in the beta1 branch. Please download a recent nightly image and try that instead.


#10

OK. I’ll give that a try.
Thanks


#11

Tonight I tried a new usb2 drive, 8GB “Verbatim Clip-it” attached to one of the external USB3 ports in the back of the NUC… (instead of the previous tries with usb3 32GB flash drive.) Used UEFI in Bios.
I also loaded the anyboot iso hrev52815 onto the new usb2 drive.
Same result. Same Panic message.


#12

Samsung EVO 860 has some known flaws. My 250gb 860 has some odd behavior in Haiku, FreeBSD, and OpenBSD.

See my post:
AHCI breaky Samsung EVO 860 SSD blues

Also see:


#13

#5 1/30/19 USB2 8GB flash drive - Internal USB2 port on NUC -
hrev52815 64 bit iso - Got to 3rd icon; no change in error report

#6 1/30/19 Same configuration as #5 except disabled Samsung SATA EVO 860 drive -

#7 1/30/19 Same configuration as #6 except disabled options in Safe Mode Bootloader

haiku1%3A30%3A19-3%20bootloader%20%20%20%20IMG_0035

haiku%201%3A30%3A19%20%20-3%20%20%20%20thread14%20%20IMG_0033

Panic: get_boot_partitions failed!
Thread 14 “main2” running on CPU 0

#8 hrev52824 Legacy Plextor Optical drive - Samsung SATA disabled
PANIC: get=boot=partitions failed!
Thread 22 “main2” running on CPU 2

![haiku%201%3A30%3A19%20-4%20plextor%20IMG_0038|666x500]
(upload://rr7lqbtNrTKBij9ZDVaFzSPigfl.jpeg)

#9 Same configuration as Trial #8 Plextor but with Samsung SATA connectedhaiku%201%3A30%3A19%205%20(4)%20sata%20%20IMG_0044
PANIC: did not find any boot partitions!
Thread 22 “main2” running on CPU2

Maybe I’m missing a step. Out of things to try.


#14

Yes, most likely we don’t support your USB controller properly, and so booting off of anything connected via USB will not work. Checking the last few lines of “syslog” by running that command at the prompt will probably show some “XHCI” error message, and more than likely it’s a duplicate. There isn’t anyone on the dev team right now who is an XHCI expert unfortunately…


#15

When installing Haiku to an existing partition using GPT layout, there is an issue with the GTP UUID partition code which can prevent Haiku Boot EFI from identifying a Haiku partition. See this post for a way to resolve the issue: