OpenMW (Morowind) and other 3d games


Some progress:

1. Not worked S3TC textures for now (FIXED)
2. Not worked mouse grab in SDL2 window (FIXED)


what is that black background under mouse hand? I see it in all animations


i think it’s bug in llvmpipe mesa render


Very great work. Waiting for complete port :slight_smile:


The black artifact under the cursor is actually a limitation of the BDirectWindow API, which doesn’t work with software cursors.

The best way to fix it would be to implement hardware cursors in all of our drivers.


Texture fixed:


wow very impressiv… good work! Great!!!


Good day,

This artifact is also shown in Blender and Godot 2, and also shows the square trail when moving around the cursor.

@Polli it also happens on native (non VESA) driver.



white box artifact it’s cross-pointer without texture!


This is looking really good. Does it run in full screen, also, or only windowed?


Use fullscreen in SDL1/2 is not good idea.
It’s very buggy under Haiku.


I try set 1920x1080 resolution for window and I have only 6 fps


but it works! :slight_smile:



Issues: not worked mouse grab (FIXED)


Yeah? Gimme more


AWESOME!!! GREAT WORK!!! (yes i realize that I am shouting because this is FREAKING AWESOME!!!)



Lugaru HD:


I see the earlier images are gone, although they’re linked to this forum. Does something happen in the backend that causes losing images accidentally?


A lamentable state of affairs, for sure… See ticket #14370.


Wow, that’s a lot of lost/broken images. I’ll hope the LibreOffice thread was not affected, because it showed nice progress.

P.S. The two threads posted months ago are fine, but the two blog posts featuring LibreOffice were affected. :expressionless: Hopefully the authors can restore the images, in this thread as well.