New Install

I decided to try and go ahead and install Haiku to my HD. I had not done this and years and honestly it was a mistake. 2 hours it took to install to secussfully install to HD. I had every single bug I have ever experienced in install Haiku. It’s like none of those partitioning issue have ever been resolved. I fear that when released it is going to cause so many people to be turned off. But, nothing I can do. These issus I had have been well documented for years and years.

But the one I am most frustrated with right now is my wireless network. I have it setup, the password is saved. It works just fine. But even though I have “automatic” selected in my network preferences. It never auto connects to my network. Each and every time I have to select the wireless from the list. it will then connect, doesn’t even ask for my password as I have saved the configuration. So, tell me then why? Why will not just connect to my wireless network?

Hi. It’s great that you finally managed to get Haiku installed, and WiFi working. It would be useful if you can document exactly which step gave you problems (which you eventually resolved) so that the team can see what they need to “better explain” so that other users dont run into similar issues. Likewise, log an issue in the bug tracker for your WiFi issues.

At the end of the day, from a volunteer based project you managed to get a working install, thats great in retrospect. Now imagine how much better the experience will be in time and with more users / developers.

1 Like

I assume it’s a matter of your specific hardware and partitioning combination. A constellation that promises to be very difficult for the devs to replicate.
Personally, I still use MBR booting and never had a problem with that in the past.

AFAIK, the “Choose automatically” setting in the Network prefs doesn’t auto-connect. Can’t find a ticket for that though…

I use the line
ifconfig /dev/net/iprowifi4965/0 join MySSID MyPassword
which can be added to /boot/home/config/settings/boot/UserBootscript or used as a separate script in the “launch” subfolder there.

I will add a ticket for the Auto Connect issue. As for the other stuff. It is all known issues. On one hand I do understand the difficultly of duplicating these issues. I ran into a different one each time I did an install. Sometimes it would say that there was no bootable partition. Sometimes it would say that “Haiku” is not a bootable partition,. Sometimes it would say “no bootable device” A few times I would partition the drive and then discover after a failed boot that the partition had someone changed and added a one that I didn’t have etc… I do wish I could recreate each one of these on demand. I just fear that these things will give new users a poor first experience and then give up on Haiku.

Okay, can you point to tickets about them, then?

No need; I already fixed it in the wpa_supplicant repo (I think), but we can’t deploy the new wpa_supplicant yet as it depends on nightly build stuff that isn’t on the beta.

1 Like

OK, I saw this one once:

I am pretty sure I ran into this where I created a partition for the entire drive. Haiku wouldn’t boot and when I looked again at Drive Setup, running from USB. I found that Haiku had not actually created the partition. However at first it was fine in Drive Setup. It only showed me it had done it wrong after a reboot. I will stress I created only one partition for the entire drive. Somehow Drive Setup decided to do something different.

Here’s one from 4 years ago.

Honestly Wadlesplash. You’ve been around for a long time. These types of issues are not new. All I wanted was to use the entire drive for Haiku. It should have been simple. It should have “just worked” instead it was a 2 hours trial and error and I even had to install the boot loader to get it to work in the end. I should not need BootMan if I am only using the computer for Haiku and nothing more. Once more at no point did Haiku even indicate there was a problem. Each time the installer finished, no errors and happily told me that the boot sector had been written. I should have been good to remove the install media and reboot to Haiku.

I already opened a ticket for autoconnect. Just close it out.

It’s not like that for everybody. I think you have been unlucky.

I played around with Haiku on several old laptops I had lying around, and finally installed it as the sole OS on a Thinkpad T61P. Absolutely no problems, and the installation was completed in no time at all.

Thinkpads are known to be very Linux-friendly, which perhaps helps. What hardware are you using?

Agreed. I’ve installed Haiku on a number of desktops and laptops (Lenovo and Dell) and never had an issue.

I’ve had issues, but they all had something to do with the drive setup thing.

From what I see in the 3rd ticket (the one you reported yourself), you are misusing DriveSetup. If I read your steps correctly, you create an Intel partition table, and then erase it by formatting the whole drive as BFS. Formatting the whole drive as BFS is known not to work with some BIOSes.

What you need to do is:

  • Create an intel partition table
  • Create a single partition that fills the whole drive
  • Format that partition (not the whole disk)

If you do it this way, things will work just fine. If they still don’t, that’s a different problem.
This is why we have this “are you sure you want to format the whole disk” warning alert, but if you are used to Windows and mentally trained to dismiss alerts that pop up all the time without carefully reading them, there isn’t much we can do.

There is also a ticket to add “automated”/“assisted” partitionning, where the Installer would create a partition layout for you so you don’t have to worry about these technical details. We will work on that eventually.

For the other two tickets, if you are sure you hit the exact same problems, please comment there and provide a syslog, details of your hardware, and the exact steps you took (if in doubt, go as far as screenshoting each action), then maybe we can understand what you did that triggers these problems. If there is a chance that it’s a different error, create your own ticket. It is much easier for us to close it as a duplicate if it turns out to be the same problem, than having to deal with a single ticket that mixes two different problems and that we can’t eventually split.


At this point I am just done with the partitioning thing in Haiku. Yes that ticket is 4 years old and was just an example of the things I ran into the other day. Not meant to be taken literally. I am happy to know that most of the others on this thread have not had issues. Haiku is the only OS that gives me problems. I have installed a lot of OSes on this laptop including:

Lord knows how many different flavors of Linux.
ReactOS (yep even got this installed on this thing)
FreeDOS (a fun flashback to my childhood)
I even made it a Hackintosh once. (not really worth the effort)

My point only is that out of all of these the only one that gave me any significant problems is Haiku. When B2 comes out. I will try it again, a simple install using the entire drive. It will either work the first time or not. If not I will put B2 down and wait for the next one. I will not spend an other 2 hours trying to get Haiku to work for me. Not again. I love the OS and when it is installed and running it is wonderful. But never again will I spend 2 hours fighting with the installer.

You have it installed successfully now, why would you need to do that? Just upgrade the system in-place.

1 Like

Because after seeing issues with video playback on Youtube I went back to Linux. Next time though… Before I even install I will use DiskParted to wipe the SSD clean first. To try to make sure there is nothing left on it that can trip up the installer. Hopefully that will do it for me.

I am still running it off a flash drive. That is one of the things I LOVE about Haiku. Run the installer of your currently installed HD and it will install Haiku, all your setting, all your files etc… no fuss, That is very nice. So, while it isn’t on the SSD right now I do have it on USB and will continue to update.

1 Like

You mean GParted or diskpart? GParted is a graphical frontend to GNU parted; diskpart is a CLI tool from ReactOS/win32 land. Either way, to be helpful here, when running parted (as root) you can do (i.e. for sda): parted /dev/sda mktable msdos, or from a bootable ReactOS nightly (or a Windows) disk, run diskpart, then (i.e. for disk 1 in the list) select disk 1, and then run clean. But, be aware the ReactOS version isn’t fully ready yet, so using GParted or Redmond’s version of diskpart will probably be safer choices.

Another option on a Unix(-like) system, including OpenIndiana and Mac OS 10.0+ is to run dd as root from the Terminal to write out zeroes to the disk over the first part of the disk. That may also be helpful as it should help ‘reset’ things, after which you can use DriveSetup, Disk Utility, Gnome Disks, or whatever disk utility you prefer to set the disk up. As for formatting problems, it’s pretty rare (most of the time, it does work as intended), but I have had DriveSetup mess up before; to remedy this, run parted /dev/sda mktable msdos (for a legacy table, which I’d recommend unless you need GPT), then do parted /dev/sda mkpart primary with 100% of the disk to create a single volume. After restarting into Haiku, DriveSetup should be able to create a BFS (or “BeFS” in modern parlance, since there’s another BFS out there) volume for you and install with no problems. But again, as others have said, I haven’t had much trouble with DriveSetup so I’m not sure what’s going wrong.

I have, however, had where Haiku doesn’t always write the boot sector as advertised. The quickest fix for this is just click “Write boot sector” from the Tools menu, then click Quit or Restart. But always remember to run bootman after the first phase of installation is done, even if Haiku is the only OS on there. I suppose for a simpler install you could image out Haiku and write the image to the drive directly, but that might be harder than doing the three step format -> install -> bootman path.

As for the other issues (like the returning WiFi box), looks like they’ve been answered already. But I do hope you don’t give up on Haiku, as it’s still getting to R1, but is a great little system. Granted, not all the hardware will work on everything, but it’s definitely doing what it can with the sea of hardware out there. Hope all of our answers help… and good luck with everything! :slight_smile:

Writing the bootsector in the partition is done automatically when you run Installer.
Writing the master boot record at the start of the disk is done by DriveSetup when you create an intel partition table, the one it installs requires you to set your Haiku partition as active when creating it.

So, there is no need to install either of these or bootman manually. If you have a case where that is needed, we need a bugreport urgently! People may fail to install Haiku because of the bug, and move on to other things. We can’t afford to lose users over such a silly thing.

So, if you have a case that doesn’t work as expected, please document all exact steps you take. It may be that you did something “wrong”, but in that case we should improve the UI to avoid users failing into the same error.

1 Like

I installed Haiku on a hard drive that had DragonflyBSD, so I erased everything, recreated the intel partition table, created the partition and formatted as BFS. After the installation I did not install the boot manager, so now when the computer boots the DragonflyBSD Bootmanager appears and lists F1, by pressing enter Haiku starts… Is this behavior correct?

No. Creating an intel partition table should install a basic master boot record that will automatically boot the first active partition.

As always with these things we need to see exactly what you did. Take screenshots at every single mouseclick. A text description as you gave here is not exact enough.


Just to make sure I understand, I’m going to give this a short.

  1. Create Intel Partition table to entire drive.
  2. Create an Active Haiku partition.
  3. Run Installer.
  4. Reboot

This shuold get me a working Haiku Install.

The only thing I have noticed. I have folled these steps before… I make a partition Active and it doesn’t stay Active. When I take a look at that partition again, the Active flag is gone. I don’t see any errors. This may be the root of all my install issues. provided my steps are correct.

I every time use my steps to a install of haiku:


Those directions apprear to be for installing along with other OSes with bootman. I am wanting an install for the entire drive for Haiku. It should’t require bootman to boot.