Networking a little stodgy?

I notice that when I boot Haiku (I’m running R1/Beta 4 with all updates (Revision+93)), it either takes forever for Networking (connection to our router) to start or it never does and I have to manually go in and select our router’s name and THEN Networking starts rolling. Any idea why?

I’ve already (previously) assigned Haiku to our Router, given it the passphrase, saved it to the keychain (remember the passphrase) and authorized it to always use the keychain to access to the router. But that’s not enough?

1 Like

Could be the driver for your network card.

Open your terminal, type: listdev | grep -Ei "Network|Wireless" -A2 and post the output here.

Here ya go!

~> listdev | grep -Ei “Network|Wireless” -A2
device Network controller (Ethernet controller) [2|0|0]
vendor 10ec: Realtek Semiconductor Co., Ltd.
device 8168: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

However, I’m using a Netgear USB Wifi dongle (micro nub).

1 Like

See: Wi-Fi & Ethernet Testers Wanted - Development / OS - Haiku Community ( - lead person: waddlesplash

Make sure you post a bug ticket…

1 Like

Didn’t think it was bad enough for that. Aren’t bug tickets for things that totally don’t work? Or are bug tickets for every little thing that doesn’t quite work as expected?

  • “Could be the driver for your network card.” - kallisti5

If you expect ‘anything’ driver-related or Haiku-related in general, bug reports (i.e. ‘the bat/dev signal’) allows and alerts devs to look at it through bug reporting (they mentioned this several times - that many of them don’t always review forum posts - but they relatively are alerted through the bug report system for tracking purposes).

1 Like

Finally figured out a fix for my own particular situation.

Added this to my UserBootscript:

sleep 2; ifconfig /dev/net/realtekwifi/0 join [SSID name] &

Without the sleep command, it only brings up the setup window. Even if you add your passphrase, you still need to get involved. Sleep 1 = no sleep command, so the same diff. Even at sleep 2, it still takes about 10 seconds for the networking to start. So setting sleep between 2-10, it takes the same amount of time.

Hope this also helps someone else.