Need help updating BIOS on Haiku machine

Hi there, I use a Dell Latitude D600 as my Haiku machine. Since it is fairly old (2002) and has a slow 1.4 GHz CPU with just 1 MB cache, I’d like to upgrade it to a newer and faster CPU. Replacing the chip proved unproblematic, everything still works, Haiku will boot and run faster as intended, but the BIOS revision installed (A09) does not recognize the chip and stops the boot process with an error message. I can force it to continue by pressing F1, but having to do this every single time I switch on the computer is a nuisance. So, I need to update the BIOS. Dell Service offers a fairly simple procedure - for Windows only. (Of course, there are no operating systems in the world other than Windows. What did you think?) In case that somehow, inexplicably doesn’t work, their advice is to create a bootable USB drive and copy the .exe file for the latest BIOS onto it, then boot from this. Trying to achieve this, I formatted a USB stick in FAT32, copied the .exe file for BIOS A16 onto it and marked the partition as “boot”, all using GParted on my Ubuntu machine. Inserting this into the Dell and starting it up with the “one-time” boot option, however, I can see it tries to boot from the stick but fails. If it did, could it even execute the .exe file to update the BIOS? I’m at a loss here. Could someone please help me out? How do I do this right?

The instructions say that you need to make a bootable volume on the mass storage device. To boot dos that means it will need to use Intel partition scheme, not gpt, and will need to have an active partition (which means it is bootable).

It will also need to have the dos system filesin order for the system to boot from it.

If you have a windows or dos system around I think you can do this with “format /s”. The /s option tells format to make the volume bootable by copying system files into it. I think this might also be exposed as a checkbox in the format gui tool, but I don’t have a windows machine around at the moment.

You might also be able to use FreeDos.

Thank you very much! The partition on the USB stick is active (it’s the only partition), but the Haiku machine BIOS can’t detect a boot sector anyway. You mean I can’t use Gparted? Hm. No Windows system around here, I’m afraid, so I can’t use this, but FreeDOS I do have - as an .iso image, that is. I’ll have to install it first somewhere to use it, but that’s at least an idea, I’ll try that! :slight_smile: Sigh, why is upgrading the CPU so easy and this small nuisance so complicated to remedy? I like a clean install without having to resort to forcing the machine to continue the boot process at every startup, especially since Haiku runs smoothly on the old Dell, so I’ll keep trying, though. Btw, I hope Beta 2 will have a 32-bit version, too, so I can upgrade?

Yup there is still a 32-bit version. You can test out a pre-release image from this thread if you want to try it early.

Hey, great! I thought you had to build these from source (which is beyond me, for now). Just downloaded it, shall try it ASAP!
Update: Just tried Beta2 32-bit pre-release version on a Dell Latitude D600 with Pentium M CPU, booting to desktop from USB drive. Boots faster than Beta1, looks great, runs smoothly! Ethernet works, USB works. Kernel panic and crash, though, when I called up the Workspaces applet, but hey, it’s beta, it happens.Thanks for the sneak peek!

Uh, a kernel panic on opening Workspaces sounds pretty bad, and I don’t think we know about it. Can you please report that, and include a picture of the crash?

Oh, sorry to hear that. I didn’t capture the panic screen, though. In the first line it said something about an “NMI” exception and an error code 0x0, I think. I was just trying it out, booting to desktop, nothing installed yet, and it’s a very old machine with a very limited CPU (I’ve put the old one back in, so it’s 1.4 GHz, 1 MB cache). Perhaps that explains it?
And I just tried to replicate the error like a good scientist by firing up the machine again and calling up Workspaces - and this time, of course, the applet works fine, I’m switching around among 4 workspaces without a problem right now. (A few days ago, btw, I tried Beta1 64-bit on a ThinkPad T60, a mighty beast in comparison with the poor old Dell, and it would let me use just one workspace - every time I clicked on one of the others, the screen went completely black and the system became unresponsive like I had pushed it over the rim of the world or something.)

If I need a bootable msdos disk I normally use ms-sys to write the msdos boot sector from linux, and then copy io.sys, and msdos.sys onto the drive.

Also, your second problem with workspaces (with black screen) sounds like you have invalid video modes configured on the other workspaces (somehow). I think you can fix that from the screen preflet by setting a valid mode for all workspaces (though it probably indicates a bug in a video driver).

Thank you! So there might be a way to create my BIOS update stick in Ubuntu, after all. Makes it easier. Thanks for the advice re. workspace black screens, too! I’d have thought video mode would be the same for all of them? I don’t use the T60 for Haiku anymore, though, it just wouldn’t get an ethernet connection (showing “configuring” forever), and I had bought it to install TempleOS anyway.

The default should give the same mode for all of them, but I have had that same problem before and that was the work around, so I guess in some circumstances it doesn’t work.

Another tip is that I’ve sometimes found old machines dont like it if you use FAT32 with LBA for the partition ID.

I would like more testing about this. I fixed some problems with the workspaces setting file and the intel driver that could lead to this situation when updating an existing install, but not a fresh install. If it reproduces easily, it may be worth a mention in the release notes, and if you find a way to reproduce it, saving a copy of the workspace files and syslog before/after, etc would be great, as the existing ticket didn’t really come to a fix.

I don’t remember what hardware I found it on, or if it was a new or old install. It was also a long time ago. I will search some old logs and try out the beta build to see if I can reproduce it.

I just checked trac… I reported this issue back in 2014 [1]. My x230 is out of service at present, is it possible someone else could test it on an x230?

Edit: BTW, it seems trac lost my email address, so I was not getting notified about changes to my tickets. Otherwise I would have tested this when requested. My no reply was apparently why the bug was closed… Anyway I have put my email address back in.