MacBook Experiences


#1

Hi All,

I would like to start this thread to collect all the experiences in running Haiku on MacBooks.

Useful resources:

http://www.appleserialnumberinfo.com/ To see which model you have

My Experience:

I tried yesterday night to boot HAIKU Alpha 1 on my White MacBook Mid 2007 (Intel GMA 950) with 3 Gb of RAM.

Results:

Ok:
It boots!
Screen resolution
Ethernet

Fail:
Keyboard
Track Pad
Sound

Problems:
When I open the Haiku menu some entries “flicker” like when you select a low refresh rate on a CRT monitor.

Sadly I couldn’t check more than that because I don’t have an external keyboard right now.


#2

MacBook Pro, Oct 2006 generation (model 2.2)

OK:
Boots 100%
keyboard/mouse works
Ethernet works
Intel HDA initialised (but no sound due to mixer)

Not working:
BIOS and VESA cannot agree about video resolution (limited to 1152x852 or similar)
Broadcom Wifi not working
D/A mixer not initialised properly
MBP specific keys (screen brightness/audio volume/backlit keyboard etc) are unknown to Haiku.

I’ve been testing Haiku on this box for over a year now, and on the plus side functionality is improving (at a slow and steady pace). Eventually the laptop will be 100% supported …


#3

Macbook Aug 2006

Boot - ok

Keyboard, touchpad - fail
USB mouse - fail

Conclusion: cannot get past the first question LiveCD vs Install…


#4

Black Macbook - First Generation - May 06 - model 1,1
Intel Core Duo 2.0 GHz
2GB RAM
Intel GMA 950 graphics

Good:

Boot - Check
Screen resolution - Check
USB mouse - Check

Bad:

Keyboard, touch pad - No Go.
Display has random/jumpy pixels all over.

Guess I’ll stick to testing Haiku in VMware Fusion for now.


#5

I got to try out Haiku on 3 different white Macbooks and a white iMac today. Results:

White Macbook (model 2,1)
Intel Core 2 Duo 2.16 GHz
1GB RAM
Intel GMA 950 graphics

This one boots, trackpad and keyboard don’t work but I could use a USB mouse with it. No sound, no network wired or wireless.


White Macbook (model 4,1)
Intel Core 2 Duo 2.4 GHz
2GB RAM
Intel GMA X3100 graphics

Boot screen comes up and stalls before the first icon lights up. I couldn’t get into the boot options with the built-in keyboard or a USB keyboard.


White Macbook (model 5,2)
Intel Core 2 Duo 2 GHz
2GB RAM
Nvidia GeForce 9400M graphics

Same as above.


White iMac (model 5,2)
Intel Core 2 Duo 1.83 GHz
1GB RAM
Intel GMA 950 graphics

Best compatibility so far. Network connected instantly. No sound from the speakers or headphones but the media player actually acted like it was playing with the progress bar advancing and the output meters working.


#6

I have a santa rosa Modbook tablet, it boots but the wacom pen input doesn’t work unfortunately.


#7

I have a 2009 MacBook Pro unibody. the alpha install CD does not work - it hangs at the 4th icon (the hard drive one). so I followed the instructions on this page: http://www.haiku-os.org/documents/dev/how_build_haiku_mac_os_x

and it works! those instructions were very good, but I had a lot of trouble creating a case-sensitive disk image in Disk Utility. the instructions say ‘Click “New Image”’, but they should say ‘Click “File->New->Blank Disk Image”’, because there’s a “New Image” icon that seems to be what the instructions want you to click, but it is not the right thing.

I created a new partition using Boot Camp (Disk Utility hung while trying), and followed the instructions to compile and install to it. then I used rEFIt (I had to run its enable.sh manually even though I used their .mpkg, which is something their instructions did not make clear) to give me a choice of OS on boot.

so it was harder than it had to be, but haiku works great. the touchpad does not seem to be recognized - I think haiku thinks it’s a mouse, which makes it pretty frustrating to use (no tapping, no multitouch).

I’m not sure if the sound works either. I don’t have a way to get sound files to that partition until the wireless stuff is ready, but I tried to use the sound recorder to record something and it just blinked at me.

anybody know anything about the touchpad or sound thing? great work on haiku.


#8

latest nightly (09/01/2010) is a no go on my Macbook Pro (15", mid/late 2007, SantaRosa), aka macbook3,1

stuck at boot screen


#9

Working fine with the last macBook Pro under VMWare 3.0 :slight_smile:
Networking and sound card are OK.
Trackpad is recognized only for scroll up and dow.n


#10

MacBook Pro Haiku experience is available here in details :

http://labeille.net.free.fr/haiku/articles/haiku_alpha1.0_experience.html


#11

Works good on my MacBook2,1 (nighlty build 20. Jan)

HD Audio is detected, but no sound.
Wifi works! (unencrypted)
I’m working with an external keyboard and mouse.


#12

As a progress-followup to my earlier post, I just tried installing alpha 2 on the same macbook last night. This time it went a lot smoother and I was able to install straight from the CD. I used refit to boot into Haiku and pretty much the same deal. The trackpad is still recognized as a mouse as far as I can tell but maybe that is a known issue. Networking is great with an ethernet cable but I couldn’t get the wireless working because the wifi card (a BCM-4322) doesn’t seem to be recognized - it doesn’t show up in the network preferences or /dev. Sound also doesn’t work; media player pretends to play mp3s but no sound actually happens. Anyway, Haiku seems to be coming along which makes me happy. :slight_smile:


#13

Haiku Alpha2 boots extremely slow (2-3 minutes) on my Macbook Pro (15", mid/late 2007, SantaRosa), aka macbook3,1

After that it installs fine, but neither keyboard, nor the touchpad works. (it does work during the install!) :frowning:


#14

Macbook 2,1. I also have to use external mouse and keyboard, but they have to both use the USB port nearer the front (mouse piggybacking off the keyboard). If either of them is plugged into the other USB port on the machine, the action is jerky and slow.

Anyone else have trouble ejecting CDs? I have “eject when unmounting” checked on but I have found no way short of rebooting to shift a CD once it’s in. The keyboard eject button has no effect.

Runs native resolution with Intel Extreme driver.
No sound.
Wired network good; haven’t investigated wireless.


#15

Hello,

Just thought I’d restart this thread, because there probably are still some of us (other than myself) who try to run Haiku on older Intel Mac hardware…

I just installed Haiku nightly (hrev52796) on my MacBook (black, Late 2007, Santa Rosa chipset, MacBook3,1) and am dual-booting it with Mac OS X v10.7.5; every essential component works, except the AirPort Extreme wireless card (Broadcom BCM4321, Vendor: 0x14e4, Device: 0x4328). Tried to get it working by installing the bwi driver firmware; that was a no-go. In the FreeBSD 11.1 manual pages, neither the bwi driver nor the bwn driver have that device-ID in their “supported chipsets” list, though they do both list other types of AirPort Extreme cards as being supported. Is there a solution for this, other than swapping in a different MiniPCI-e WiFi card?

Thanks for any response that might shed some light on a solution to this issue.

-BeDifferent-1


#16

The community standard and netiquette in general is to start a new thread rather than dig up old, buried threads. Let old discussion rest in peace. Instead, feel free to open a new thread.