Macbook 1,1

Not sure if I’m posting this in the right forum, and sorry for the long post, but here goes…

I thought I’d post a summary of my experience with haiku running natively on my macbook.

macbook 1,1. It’s the very first macbook from 2006 - core duo, not core 2 duo.

Haiku version:-
Haiku version is nightly r44475.

Getting haiku to boot is very tricky, whether from CD or hard disk. First off, it gets to the haiku screen with grey icons fine, but sits there indefinitely unless you press a key.

Then blue desktop appears with cursor, but a white box appears at the top after a moment, and then nothing else happens. Mouse and keyboard don’t respond. Safe mode options make no difference (tried various combinations and all enabled) except that with some combinations you don’t have to press a key to get the icons to light up. I thought the video mode might be wrong and the white box I am seeing is the bottom of the KDL window. However, when booting with all safe mode options enabled sometimes the deskbar and/or desktop tracker icons manage to start in the correct place before the white box is overlayed on top, so the video mode must be right.

After attempting to boot many (5-15) times it will eventually get there. It seems to take a few less attempts if you alternate between all safe mode options enabled and then none, but this might be chance, or me seeing patterns where there are none.

Freezes, every time, with a blue screen and no windows present. i.e., after the little window asking everything to quit has been and gone.

Installation wasn’t too difficult once booted. I had to mess about a bit with gptsync (see here: but this is probably just a typical mac issue. I can’t really advise on the procedure as I already had refit triple booting OS X, linux and windows XP, and I can’t remember how I managed that. I simply replaced XP with haiku and it Just Worked ™.

Hardware support:-
Once started everything mostly seems to work fine, although sound and wired networking don’t appear to work.

Wired ethernet (marvell_yukon)
I haven’t tested it that much, but basically although it gets a DHCP address ok, the DNS server and gateway are wrong. Since you can’t set it to DHCP and specify DNS and/or gateway (is this a bug - other OSs allow it?) I set it to static and changed my router settings. Then it can resolve DNS names, but pings still dont come back and of course web browsing is out of the question. I only tried it because I didn’t expect wifi to be fully working.

Wireless (atheros)
I was very pleasantly surprised to find that wireless works perfectly, even with WPA2. The only problem I’ve noticed is that if I do an “ifconfig /dev/net/atheroswifi/0 down” when connected then most of the system freezes up (deskbar freezes and doesnt re-draw - I think wpa_supplicant is the culprit but I wasn’t able to kill it).

While on networking, I’ve noticed a bug where if you accidentally type a net device that doesn’t exist into ifconfig (e.g. “ifconfig /dev/net/atheroswifi/ down”) you get an entry in the network config applet of the deskbar for whatever you typed, even though that interface doesn’t exist.

Sound (Intel HDA)
As widely reported by others, the system claims to have sound but it doesn’t actually produce any noise. I fiddled around with the media preferences app for a while trying to get it working. I thought maybe the output was mapped to the wrong place or something (this happened with early attempts to boot linux on this machine - e.g. sound would only come out of the microphone socket). But if this is the case then it is not fixable from the media applet, there is no sound from headphone, mic or built-in speakers, whatever you do.

But - I noticed a bug in the applet - if you make the window larger you cannot make it smaller again. I guess I should raise a ticket for this.

Keyboard and mouse
I haven’t found a way to right click yet, but I’m using an external mouse so it’s no problem. The keyboard works fine, except that stuff normally accessed with fn doesn’t work… namely page up/down and home/end, which is a bit of an annoyance. I don’t know that anything else really needs fn, since the media keys don’t work in haiku anyway.

General usage:-
Other than the issues above (booting and shutting down haiku does seem to be bringing the ‘good’ old blue screen of death days back to my computing experience) everything works great, and you get all the super fast easy to use goodness of haiku. Hopefully alpha 4 will be more stable.