Libreoffice on Haiku R1/Beta1


#1

hi guys,

i installed haiku r1/beta1 in virtual box. both releases (32bit and 64bit). some applications in the list of haiku ports cannot be installed. also libreoffice cannot be installed.

i get an error window with the title “Package problems”. It says in case of Libreoffice: “nothing provides haiku=r1-beta_hrev52295_129-1 needed by cairo-1.16.0-1”.

i can only choose “do not install” and the window will close. the same problem comes out when i try to install some other packages like kdevelop, krita, koder and so on.

is this problem known, has some one an useful solution?


#2

Does this problem still exist if you try the nightly builds?


#3

Unfortunately, the only way to fix this currently is indeed to update to a nightly build.
Supposedly there was an update to the haiku beta package with some bugfixes, but apparently it didn’t make it to the repos for some reason?


#4

no i havent installed a nightly build. i just downloaded the r1/beta link directly given on the haiku homepage. i am so sad. do i need to download a nightly build and install all again? does it really work? i wont do that all, if there is not a guarantee


#5

It is simple and it dont gives you any draw back

Open a Terminal and copy this lines in:

pkgman add https://eu.hpkg.haiku-os.org/haiku/r1beta1/$(getarch)/current
pkgman add https://eu.hpkg.haiku-os.org/haikuports/master/$(getarch)/current
  • Update to the latest packages:

pkgman update

  • Reboot once complete:

shutdown -r

And you will have the nightly Version of haiku in your computer and the All packages should work now.
I use nightlys for over a decade now… And i only had two problems in 10 years…


#6

thanks it works now :slight_smile:


#7

Hm, if noone send bugfixed packages to beta branch anymore, then why are they broken, if they`ve worked before?


#8

no idea, i am the wrong person to give an answer. i am new to test and check haiku


#9

We have not branched haikuports, so haikuports packages get updates, but core haiku ones don’t. The result is, of course, a mess :frowning:


#10

I folllowed the steps recommended by Paradoxon and got Haiku to finally update to the latest codebase without issue. After doing so, I tried installing Libreoffice and am still having the same issue as the original poster (options to not install or ignore only). And yes, i did rebooot prior to my attempt to install the suite.

I’m not sure what else to try.

Thanks!


#11

As Pulkomandy pointed out, the HaikuPorts project neglected to branch for the beta and already the Haiku nightlies have diverted enough for some packages to work on them and not the beta anymore.

You’ll have to use nightlies if you want use these packages, sadly.

See https://www.haiku-os.org/guides/daily-tasks/updating-system :

pkgman add https://eu.hpkg.haiku-os.org/haiku/master/$(getarch)/current
pkgman add https://eu.hpkg.haiku-os.org/haikuports/master/$(getarch)/current

#12

It looks like Paradoxon by mistake gave the beta url, use the one humdinger gave you and use

pkgman full-sync

instead of

pkgman update

Hope it’ll work this time.


#13

I’ve gotten to the point where Libreaoffice mostly installs. However, when it gets to the qthaikuplugin package (somewhere around 26 packages left), I am seeing the following:

  • The WiFi connection appears to be dropped and reconnected
  • The distribution fails to download and I can’t continue with the install

#14

You can manually install a few of the dependencies to do the install piecewise. But we should really get to implementing continuing interrupted downloads :frowning: