LibreOffice is now available for Haiku


#42

Yes, all dependencies are met, and then you get an X11 based GTK. You can then ssh -X to your Haiku system and run apps there, displaying them on a nearby Linux system or whatever. But this isn’t useful for what we’re trying to do here.

Then you can start thinking about running an X server on Haiku and get something like TiltOS did a few years ago. But this is still not what we want.

So, you need to rewrite large parts of GTK to render using the BeAPI rather than X11. And also probably write an “engine” using BControlLook so the apps look nicely integrated. This is a lot of work. Not impossible, but a lot of work.


#43

Lol, of course we shouldn’t have an X server running. I assumed that if X11 is required, the configure script would complain about X11 missing. It does now sound like a lot more work would be needed to get GTK to work.


#44

Natron needs OS specific GL code and PySlide.
The GUI is written with Qt4.


#45

LibreOffice 6.2alpha with working file picker and KDE5 backend (which looks more native) has just hit x86_64 repo.


#46

Wonderful news! Thanks for all your (and everyone elses) hard work.


#47

The new version doesn’t work on my system. If I start it from deskbar nothing happens. If start /boot/system/apps/LibreOffice/program/LibreOffice from the terminal I get the message “no suitable windowing system found, exiting.” Do I have to install some kde5 related libraries manually?


#48

Indeed, just tried on a fresh nightly and got the same problem. Will need to figure out what’s wrong.


#49

I suppose it checks somewhere for KDE.


#50

It was a missing library. To fix install libxcb:

  • pkgman install libxcb

Will fix the recipe a bit later.


#51

Still not working.
“Timers cannot be stopped from another thread.”


#52

This message is harmless. Have you tried to run it again? LO creates profile dir the first time you run it and quits.


#53

I tried. Even removed the profile folder. The splash screen shows but then quits.


#54

Try to start it from Tracker. There are some differences when you start it from cli vs Tracker.


#55


#56

At exit, the program crashes. it’s an alpha app running on an alpha OS. :grin:


#57

Actually, this seems to be a bug in Haiku itself. See https://dev.haiku-os.org/ticket/13159


#58

Thanks Diver, that fixed the problem. The new version with the KDE5 backend is really a big improvement.


#59

When can we expect it? :slight_smile:


#60

Thanks for the mail sent KapiX :wink:


#61

By the end of this week.