I am new to Haiku and I really like the look&feel. I installed quite a few things and all went smooth except LibreOffice.
When I try to install from HaikuDepot (Repository: HaikuPorts) a error-message pops up:
The following problems have been encountered. Please select a solution for each:
nothing provides lib:libpoppler>=104.0.0 needed by libreoffice-126.96.36.199-2
I can only cancel or take solution 1 (also cancel).
It is a clean install R1/beta3 (Revision hrev55181+63)
AMD A4 Micro 6400T + Radeon R3, Memory 7865MiB
Yup, there is definitely a problem with Libreoffice. It wants Poppler >= 104.0, however poppler 22.0.1 is the latest version of the libpoppler library in the Depot. I have the same issue with the latest nightly, hrev55845.
I installed 22.0.0-1 but LibreOffice was not impressed.
Hi! I already submitted a ticket for this issue:
Replied to the issue, sorry for not having the time or means to fix this atm
So far the issue seems fixed for 64bit, thanks to @un_spacyar
Would keeping the old poppler for compatibility have help this transition?
I think this was about more than poppler though. Bison was updated to a version which had some breaking changes otherwise a simple revision bump in the recipe would have been enough.
Don’t think so, a rebuild for libreoffice would reveal the issues mentioned at the poppler PR, for now @un_spacyar already applied the “bison” fix needed for 64bit, for 32bit it seems an issue with gcc11 (that wasn’t around at that time so would have popped up sooner or later) (I think)
EDIT the previous poppler version could be kept (only needed a rebuild for poppler_data then)
Thanks a lot for that quick help! LibreOffice works perfectly for 64bit. I attached the screenshot.
It looks like GIMP has the same issue but I don’t use GIMP. I just checked yesterday if other packages result the same error.
For GIMP I think gegl needs to be fixed first (as mentioned earlier)
Just a little comment: I didn’t fixed anything. I just reported the issue
Keeping compatibility libraries avoid being dependent on a fast rebuild of packages using the old library. For some binary packages like qtwebengine, this is almost required.
My bad that was @augiedoggie also fixed the issue for scribus atm
For what is seems, this wasn’t an issue with poppler rather with bison and gcc11?
The issue was the error message when installing libreoffice. Libreoffice not being rebuilt was still dependent on the old poppler version, which wasn’t available anymore. Providing a compatibility lib for the old version would have avoided this issue. I know it can be more work, but at least the repository stays consistent for the users.
…i don’t have idea how to do that… can you little explain ?
This is how it should (finally) be!
I take full responsibility in this matter, atm there is an open PR by @cocobean (not checked yet), if need be I could still enable a libversion for previous poppler for LO, sorry for this …
Note: libreoffice_x86-188.8.131.52-8 package
Issue is now resolved for LO on x86 once the PR is reviewed and merged.