Lenovo touchpad doesn't work

Hi! I made a bootable usb for my laptop (Lenovo S130-14IGM) to try out Haiku beta 3. I get to the language selection screen, but the touchpad doesn’t work. Anything I could try except getting a mouse? Is touchpad support something that is being worked on or should I file some kind of bug report?

try the mouse now USB mouse support os better then touchpads at all.

Yes, I will try a mouse when I have one available, but I actually prefer using touchpads when I use laptops.

Welcome to the Haiku community! I would say that as a rule, touchpad is working in Haiku well. But not on your laptop at the moment! In Haiku, there is the file location /boot/system/var/log that stores system messages in syslog that may help troubleshoot. You can also invoke listdev from the Terminal to see what Haiku recognized for hardware. Sidenote from linux-hardware site: ps/2:3081-3081-elan469d-00-04f3-touchpad

1 Like

I see the link you posted says hardware “detected” for the touchpad, but I know it “works” in Linux. Or did you just want to show me the device name in Linux?

We have a hardware database for Haiku too: https://hardware.besly.de

Many touchpads runs well, but some not, thats it. You can take your data and make a bug report on: https://dev.haiku-os.org.

Reporting bugs (haiku-os.org)

1 Like

Thanks! I connect a mouse and make a proper bug report tomorrow.

1 Like

Yes, just trying to help any devs with device id’s. A bug report as lelldorin suggested is the best bet.

1 Like

If you have fun, you are welcome to help collecting more hardware infos for Haiku:

Hardware List: Complete Systems - Compatibility / Hardware - Haiku Community (haiku-os.org)

I connected a mouse and it worked. However there’s no wifi options in the network settings (they show if Haiku finds a wifi card?) and the keyboard doesn’t work (meaning I can’t go to Terminal and type listdev).

yes, i2c touchpads aren’t well supported yet.

Bummer, but on the other hand if I2C touchpads get supported eventually it’ll raise compatibility significantly? Or are there lots of different 12C touchpads that each need to be added individually?

No touchpad, keyboard or wifi is a bit too much for me to overcome right now. Hopefully I can come back to Haiku in the future. I like to have something snappier than Windows on weaker hardware and I do prefer the concept of Haiko over Linux.

There is i2c HID support, but I guess i2c chipset has to be supported first. Most of recent laptops I’ve tested have touchpad, keyboard or touchscreen through i2c bus. I hadn’t luck with Haiku, but even on Linux I need recent kernels and sometimes devices behave erratically.

So… We already have I2C-HID, not sure what is missing, however, seems it is buggy protocol.

Understandable. If possible, try to plug in a USB keyboard to gather a syslog for diagnosing the problem and create a ticket. It could help to get a solution. Thanks!


ACER TravelMate P2410:
Touchpad the touchpad doesn’t work.

Today, I modified the CMOS settings.
Main – Touchpad --Advanced -->> Basic

It is working now

1 Like

LENOVO x1 carbon had the same issue - but the touchpad was disabled on the bios…