Lazarus (delphi alternative)

Hi all!
First of all - sorry for my bad english.
I tried to look for similar topic but found none.
Liked the project haiku. I would like to participate in something like the life and development of the system. But I am very sad because I can not find the Lazarus delphi or other alternatives. Where once heard that there is a version of Lazarus and it works. Help me find it. And very much like a precompiled version.
PS: I agree that C - good programming language but now it’s not my choice.
Best wishes.

You will have to compile your own version. Steps are above.

You must also have Qt installed first.

I think you also need to get FreePascal. Version here is couple months old but may still work for you.

Hello. I have tried to install Lazarus in the last Haiku. Everything done according to,
But, when execute “make LCL_PLATFORM=qt”, I get the error:

Code: [Select]
Compiling lazarus.pp
Compiling resource …/units/i386-haiku/qt/lazarus.or
Linking …/lazarus
/boot/develop/tools/gnupro/bin/ld: cannot find -llocale
lazarus.pp(133,1) Error: Error while linking
lazarus.pp(133,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
make[2]: *** [lazarus] Error 1
make[2]: Leaving directory /boot/home/apps/lazarus/ide' make[1]: *** [ide] Error 2 make[1]: Leaving directory/boot/home/apps/lazarus/ide’
make: *** [ide] Error 2
~/apps/lazarus> /code]

How to solve this?

/boot/develop/tools/gnupro/bin/ld: cannot find -llocale

What is missing?

OK, I have found a dirty solution.
It seems that “/boot/develop/tools/gnupro/bin/ld: cannot find -llocale” is due to missing library.
There is however /boot/system/lib/ library, so I simlinked /boot/system/lib/ as “” wherever there was normal simlink as “”.
This enabled normal lazarus installation.

Few days ago i recompiled lazarus on A4 nightly and build a fresh app called ClipNote

Links / screens and download:

Lazarus for Haiku ready to Download:

lazarus can be downloaded from

Hi Guys,

what’s up with the “Lazarus” and “FreePascal” projects? Any news?

It’ll be good if ready for use package will be available.

converting FreePascal to a package has been more complex than expected.

The main reason for this is the compiler is writen in... pascal, and needs to compile itself. This requires some tricks to set it up, but it is possible.

Then once we have that package, we need other dependencies for lazarus, most notably, qt4pas which allows to use Qt in pascal. And then we can build Lazarus itself.

oco (Olivier Coursière) is a professional Delphi programmer and works on his free time on keeping freepascal up and running on Haiku. Unfortunately he didn't get up to making packages yet. Help is welcome!

1 Like

Well, running fpc ATM isn’t possible because of the broken sbrk() we introduced recently… Hopefully will be fixed soon…

Here a link that maybe interesting you…And myself too :slight_smile:

FreePascal for Haiku

Need to recheck, but I think I had some packages created a while back for both 32bit and 64 bit :slight_smile:

Good day,

Yesterday I was doing again the process for CudaText with Lazarus, which depends on FreePascal.

Regarding Lazarus:
1- I was mistaken. There is no need to move Lazarus to a location where user has write permissions. Default install would do.
2- The package that I’m using right now (Lazarus 2.0 unoficcial for 64bit) has some issues installing packages. Some packages would not install (LPK files). This issue prevents building some applications (In my case, I can build CudaText 1.133.7, I can’t build CudaText 1.134.4 nor 1.135.0). Nonetheless, I’m still not sure why this happens.
3- Have to move the FreePascal config files from the install location to the user’s Settings folder. That way Lazarus will find the FPC at launch, as well as the config files. Maybe a post-install script would make this easier?

Spoiler: CudaText 1.133.7 will be available soon. @Begasus, I’ll let you know about the links these days.



Should really focus on the fpc package to see if I can force some things there in regard of the config fies, the default ones are fine?

Good day @Begasus,

Actually… I presume that they are fine. Not sure if the LPK package install is a Lazarus issue or a FreePascal one.

The settings should be moved from the default location at /boot/system/data/fpc which is where they appear upon installing FPC to /boot/system/settings/etc.
Looks like it’s the location where FPC is going to search for them. Thus, Lazarus will find the FPC exec and the config files upon first launch.


1 Like

@roiredxsoto just created a fpc_bin package for x86_64, don’t see any files for fpc in /boot/system/data/fpc?

Good day @Begasus,

On my box there is the folder fpc/ in /boot/system/data, inside it the riles fpc.cfg, fppkg.cfg and a folder fppkg/. These appear after installing FPC and disappear when uninstalling it.

Maybe they are already at /boot/system/settings/etc?

I have to test copying the /fpc folder and check if it works like that. Just because I think it would be better to keep all FPC stuff inside its own folder.

I really don’t know why you don’t get that fpc/ folder… :thinking:
Might have something to do with the packaging?


Aaaand… it doesn’t. Those settings files need to be in /boot/system/settings/etc


I used the download for 64bit from here: Free Pascal Compiler - Browse /Haiku/3.2.0 at