Lazarus 1.9 trunk Qt4 and Qt5 interface (screenshots)


#41

Where do we have to put the Qt4pas libs?

I’ve installed Qt4pas also from HaikuDepot, but it seems to be missing a link from libQt4Pas.5.so to libQt4Pas.so - I’ve downloaded “Download libqt4pas and libqt5pas (qt5.9) for Haiku gcc5_hybrid (builded in Haiku gcc5_hybrid)”, but I don’t know where to place the libs so Lazarus can find them and use those libs to link the application.
I cannot put them in the “/system/lib/” or “/system/lib/x86” because that folder is readonly.

BTW, thanks for bringing Lazarus to Haiku


#42

Try system/non-packaged/lib.
I also have them in home/config/non-packaged/lib/fpc/3.0.4/

Apparantly one location is needed for compiling the app, the other for running the app.

But I’m a beginner as well here, so maybe I say something strange here :wink:

Oh, also I have 4 ‘versions’ there (links to the one):
libQt4pas.so, .so.5, .so.5.2 and .so.5.2.5.

Bye!

Rudolf


#43

For testing create a ‘simbolic link’ from a different version into non-packaged libs. Change the name of the link to that one you are need.


#44

Hi Rudolfc & Lelldorin,

linking does work now, but trying to run (A simple form) gives the following error (the same Rudolfc had a few messages ago :slight_smile: : Missing symbool___tls_get_addr


#45

Hi zittergie,

Sounds the same indeed. I am also still stuck here. If you solve this, please let me know here… :slight_smile:

Bye!


#46

BTW,

I installed the lazarus version that can be found via this thread.
But I just saw that on the net is also fpcupdeluxe, in a Haiku Build (v1.6.0q). I think I’ll try that as well to see what happens… :slight_smile:


#47

I think there are known problems with freepascal not being fully aware of hybrid systems. As a result it may occasionally mix gcc2 and 7 libraries and search paths. And this doesn’t work right, of course.


#48

Next to the one I’ve downloaded here, I’ve compiled fps and lazarus from svn without trouble. Lazarus does start too, but a compiled application gives the same error.
Will investigate some more.


#49

In the meantime I was able to build the cross-compiler for Haiku for Lazarus and FPC trunk on Windows 10. I was able to build my app there, and this version actually runs on Haiku!

Tomorrow I’ll repeat these steps on my Windows7 system to see if it will work there too.
So now I know for sure that the app was not compiled correctly yet on Haiku with Lazarus, since crosse compiling on Windows delivers a working app.
Nice!


#50

Hi again, Now also on windows7 I can crosscompile to Haiku.
The trouble was that while both win7 and win10 are 64bit version OSes, I installed the 32bit fpcupdeluxe package on win7. While this works for the windows and linux targets, it currently does not for Haiku. For the Haiku cross compiler to compile correctly with fpcupdeluxe/lazarus/fpc you need to use the 64bit version.

That’s all I have atm.


#51

In the meantime I have my first testing app running on Haiku using Lazarus on win64 as described earlier. This app tests our company’s products hardware by connecting to it via a serial port (or USB to serial) and sending / receiving I/O commands. All data are shown in various forms. It’s working OK it seems, apart from a timer not firing on a form: but this is something that I hear on other platforms as well (Probably need to replace the old delphi timer with a Lazarus ‘native’ one).

But: it turns out the haiku specific code in lazarus/FPC is at least partly outdated. Haiku has evolved (a lot) since someone worked on the haiku specifics I think…
In order to get serial ports working (I use a USB adapter here) two files have to be updated in the source repository. I have updated these files locally to make it work: specifically the configuration of the ports (baudrate, control lines) fail miserably as it was.

I can provide these two files if someone can put them in place. Also I guess it would be handy if someone would check other parts being outdated too…

I have to say I am impressed it’s actually doable to get Delphi programs up and running on Haiku and other OSes apart from Windows with relative ease. I remember back in the Kylix days our company spent a lot of time and money on trying to do this, and we failed. This time however it’s another story… :slight_smile:

The files I updated are:
termios.inc;
termiosproc.inc.

Bye!


#52

Hi all. I came back :slight_smile:

A little time, a few cups of coffee and … we have freepascal 3.0.4 for x86(gcc7). Lazarus run again.

See view more pictures in my blog http://s40in.blogspot.com/

After several tests I’ll post for download patched fpc 3.0.4, qt5pas lib, lazarus 1.8.4


#53

Have you managed to make it work with Qt5?


#54

Yes. Work fine and look very good. But I have some errors after close Lazarus or test-apps.


#55

Lazarus with Qt5 interface widgets


#56

Who want download my last build fpc and lazarus you can do it.

Download from my blog


#57

What kind of changes were required ? Maybe it is time to upstream them and/or complete my old instructions to compile Lazarus : http://wiki.freepascal.org/Installing_Lazarus_on_Haiku.


#58

Hello, any change since then?

What changes are needed for cross-compiling to Haiku from Windows?

And oco and s40in as old FreePascal/Lazarus users, There is any working in progress to include Haiku as target in new releases as hpkg?

Saludos.


#59

http://wiki.freepascal.org/Installing_Lazarus_on_Haiku

I have translated to spanish, if you update the english version i will translate new changes too.

http://wiki.freepascal.org/Installing_Lazarus_on_Haiku/es


#60

Actually Lazarus is in Second Realease Candidate previous to 2.0.

http://forum.lazarus-ide.org/index.php/topic,43071.0.html