Lazarus 1.9 trunk Qt4 and Qt5 interface (screenshots)


#21

i try but cant install it, cause the dependencys… i dont know why.


#22

ok is not a dependency it say cant install is not installable qt 5 etc…can you just put it on the repositorys?


#23

You need to install qt4 (optional qt5 ) from HaikuDepot


#24

:slight_smile: FreePascal / Lazarus, a good thing for me. If it could be installed easily in Haiku id like to try it.

Thanks s40in


#25

Today i have download and installed FreePascal 3.0.2.

The install.sh works. The next step was to install ncourses package that it needs.

One installed ncourses fp works ok, and i have been compiled my first program under HAIKU :slight_smile:

In fp is best to accept default fp.cfg file.

The target OS Haiku is configured OK.

If Lazarus 1.8 could be working with QT would wonderful. By now this is in 1.8 RC4 version.

Regards.


#26

https://sourceforge.net/projects/freepascal/files/Haiku/


#27

Hello s40in:

I downloaded qt5-5.9.0-3-x86.hpkg but when i try to install show me a message: package qt5-5.9.0-3 is not installable. Any recomendation?
Is there a GTK3 or similar in Haiku that can run Lazarus?

Also there is fpGUI but i dont know if it can run on Haiku.


#28

Hello jma_sp! You are downloading the package using the HaikuDepot app?


#29

Hello jma_sp!

qt5-5.9.0-3-x86.hpkg for Haiku gcc5_hybrid (not for x86_gcc2_hybrid). You can install qt5 from HaikuDepot.
Lazarus for Haiku work with qt4 or qt5 only.

If I have time, I will do Lazarus 1.8 HPKG after the release.


#30

OK, s40in. Nice news for the next release.

Thanks.


#31

un_spacyar

Hello jma_sp! You are downloading the package using the HaikuDepot app?


No, I haven’t found it listed in HaikuDepot.


#32

Now yes.

I have been installed from HaikuDepot and also GDB.

StartLazarus find FreePascal 3.0.2 sources also OK.

Is some difficult to drag and drop components but it may because is slow to work from pendrive.

I placed a simple FORM wich simple components 2 Labels and some buttons, but when i run it generates a Linker error.

BinUtils are installed OK, so the next step is build Lazarus with haiku, i386, …configuration (cleanly)…


#33

Published Lazarus 1.8 Release Candidate 5, i hope next will be 1.8 Stable.


#34

Lazarus 1.8 was released December 06 2017 :slight_smile:
with FreePascal 3.0.4
There is not package for Haiku in Lazarus but FreePascal have it

https://sourceforge.net/projects/freepascal/files/Haiku/3.0.4

Best Regards.


#35

Hi,
I’m trying to build and run one of my Delphi Windows testing apps on Haiku using Lazarus 1.9.0 with FPC 3.0.4.
This app is already running OK via Lazarus on Windows, Linux/i386 and Linux/ARM.

While I can succesfully compile the app on Haiku hybrid it won’t run yet. When I start the app it fails with the message:
Could not resolve symbol ___tls_get_addr
Runtime loader: /boot/system/lib/x86/libstdc++.so.6.0.21: Troubles relocating: Symbol not found.

Does anyone know what I am doing wrong here? Please note I am a beginner here. concerning apps on Haiku.

Bye!


#36

Hi Rudolf!

Usually this kind of error means that program was linked with wrong gcc libs. Probably Lazarus picks up wrong libs and need to be taught how to do it correctly on a hybrid system.


#37

Hello Diver,

Hmm, I suspected this a bit already, so I tried with QT4 and QT5, same error.
Since I could figure out where Lazarus searched for it, and also where it was searched for during loading the app, I placed the same version there. But that has no influence.

In the meantime I am tried to compile Qt4.8.6-haiku-4 myself, but no luck sofar (must be done with setarch x86 apparantly).

The other thing I guess is libstd++.so… I don’t know yet if there would be another version I could try, or where I’d need to place it exactly (I’m just doing trial and error so to speak…)

If you’d have any more pointers then I’d love to hear them…

Oh, I also tried to build the cross-compiler on windows7, but that fails as well unfortunately. Don’t know howto overcome this either, yet.
For the Linux/ARM and i386 versions I used crosscompiling and only testing the app on the target systems. Worked almost instantly. I must say I’m impressed with the results sofar using Lazarus (apart from debugging I guess).

Bye!

Rudolf.


#38

AFAIK, but FIXME one should never link anything against -lstdc++, but one should use the correct compiler, so g++ instead of gcc in this case.


#39

I don’t know how Lazarus is configured on Haiku in this respect, but since it’s delphi pascal code it should be compiling with fpc. Linking is done with ld apparantly. gcc/g++ don’t come into play here?

Or do you mean the libs? I just downloaded a precompiled Qt4 and 5, which don’t make the app work (though the compile and link succeeds, and the app_loader doesn’t complain about these libs missing).

I just see the build of QT crashing on Haiku with O_LARGEFILE not being defined in a scope.
This I just started with:
setarch x86
./configure
make.

Rudolf.


#40

True, then i haven’t said anything…
/me hides